Project

General

Profile

Bug #12363

more bbPress problems - now students unable to post either a new thread or a comment

Added by Marilyn Weber over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority name:
Urgent
Assignee:
Category name:
WordPress Plugins
Target version:
Start date:
2020-02-03
Due date:
% Done:

0%

Estimated time:

Description

I'm sorry to report there are more problems connected with
https://redmine.gc.cuny.edu/issues/12354
https://redmine.gc.cuny.edu/issues/12336

I have new tickets from two of the sites:
https://humanities2020.commons.gc.cuny.edu/
https://2020larsson130.commons.gc.cuny.edu

I'll pass on the ZenDesk tickets in separate replies on this thread


Related issues

Related to CUNY Academic Commons - Bug #12354: sites (including Net-Art) are reporting critical issuesResolved2020-02-02

Related to CUNY Academic Commons - Bug #11313: Overly aggressive spam filtersResolved2019-04-11

Related to CUNY Academic Commons - Support #12395: comments again being blocked Resolved2020-02-11

History

#1 Updated by Marilyn Weber over 1 year ago

First, the ZD ticket about https://humanities2020.commons.gc.cuny.edu/

Two of my students have been unable to post either a new thread or a comment on our class introduction board. I am forwarding the email from one of the students. Please can you advise.

Regards,

Yolande

________________________
From: <>
Sent: Monday, February 3, 2020 8:02 AM
To: Yolande Brener
Subject: [EXTERNAL] Re: CUNY Academic Commons

This is how it looks like when I hit post comment with the writing I have from the previous email

[cid:2753641B-3C2C-4CD3-8971-AEB90C584D60@home]

On Feb 3, 2020, at 07:48, Yolande Brener <<mailto:>> wrote:

Hello Victor,

Thank you for sending this. I'm not sure why you were unable to post this on the discussion board. I wonder whether you could try again later and take a picture of the error message for me. I will mark your assignment as complete.

Best,
Yolande

________________________
From: <mailto:> <<mailto:>>
Sent: Monday, February 3, 2020 1:14 AM
To: Yolande Brener
Subject: [EXTERNAL] CUNY Academic Commons

Hello,

My name is Victor Bailon. I am a student from your 9:30AM Mon/Wed Class Section B

I am emailing because I am not sure if my post is being placed on the discussion board. I was able to reply to 2 others but was unable to post my own reply and was even hit with a "duplicate post" popup. I will attach a view of it in the event that it isn't made available on the discussion board. Thank you

Best,
Victor B.

#2 Updated by Marilyn Weber over 1 year ago

Second, the ZD ticket about https://2020larsson130.commons.gc.cuny.edu:

I am encountering a different problem. Below, I have forwarded the email exchange I’m having with a student. I have encountered a similar phenomenon before but I was able to post just fine this time. I don’t know what to tell my student. I will send his other email after this one.

Thank you for any help you can offer,

Alexis

From: kenny moran <>
Date: Monday, February 3, 2020 at 7:28 PM
To: Anna Larsson <>
Subject: Re: Forums Discussion post

Soooo...... Something interesting I found out, If I click on the link I have sent you while being logged out of my commons account, I can perfectly see your posts. The only problem is that I won't be able to make a comment unless if I'm logged in. Once I log in, however, is when I get hit with the error that the page is not available

On Mon, Feb 3, 2020 at 6:46 PM Anna Larsson <> wrote:

Hi Kenny,

Thanks for your email. I can probably fix this, but I need your help. Please send me the address (URL) of the discussion forum, and tell me how you got there. If possible, send me a screenshot (ctrl+shift+3).

Thanks!

Alexis

p.s. This is what I find when I go to the forum:


From: kenny moran <>
Sent: Tuesday, February 4, 2020 5:26 AM
To: Anna Larsson <>
Subject: Forums Discussion post

Good Evening professor, hope all is well

I've read your post on how to write a post on the forum discussion, I clicked on the link and have also followed your instructions but have been met with an error describing how the page is not found/available

I just wanted to let you know about this error. If anything, I'll write the answer to the question regarding animals on a piece of paper.

This is from Kennedy Moran in your Tues. Thurs. class at 9:15 am

#3 Updated by Raymond Hoh over 1 year ago

  • Related to Bug #12354: sites (including Net-Art) are reporting critical issues added

#5 Updated by Raymond Hoh over 1 year ago

  • Category name set to WordPress Plugins
  • Status changed from New to In Progress
  • Assignee set to Raymond Hoh
  • Target version set to 1.16.5

Thanks for the report, Marilyn.

I've made another commit to try and address this: https://github.com/cuny-academic-commons/cac/commit/7b660b5cf4062e3b79bba3335d011346fae64326

This is deployed on production.

I did some local testing involving posting a topic and replying with a regular user and things seemed to work. Can you check in with those users to see if the forums are working now?

#6 Updated by Raymond Hoh over 1 year ago

  • Related to Bug #11313: Overly aggressive spam filters added

#7 Updated by Raymond Hoh over 1 year ago

The previous reply was regarding the second Zendesk ticket for the "page not found" problem.

For the first Zendesk ticket, it looks like another case of the Akismet false positive spam problem (see #11313). This is unrelated to bbPress.

Can the instructor for the Humanities 2020 course verify that those comments are not spam here?
https://humanities2020.commons.gc.cuny.edu/wp-admin/edit-comments.php?comment_status=spam

#8 Updated by Marilyn Weber over 1 year ago

So sorry, here's more:

Danielle Monterroso
3 minutes ago

I have tried to post the comment again and it still isn't showing on the page. It is still sending me to the page that says it is a duplicate comment. Here is the URL below.

https://cstspring2020.commons.gc.cuny.edu/reading-response-feb-4/#comment-34

________________________
From: Marilyn Weber (CUNY Academic Commons) <>
Sent: Monday, February 3, 2020 8:18 PM
To: Danielle Monterroso <>
Subject: [CUNY Academic Commons] Re: Problem with posting comments

Marilyn Weber
10 minutes ago
(assign)
We were having a problem that I think was just resolved. Please try now. If you're still having problems, please send me the URL of the site. Thank you!

Danielle Monterroso
13 minutes ago

To whom it may concern,

I am having trouble posting my comments on this website. I am using this site for a course and I am able to see my classmates comments but when I attempt to post my comment it doesn’t appear on the page it’s suppose to and when I refresh the page or log off and on again to comment I am sent to a page that says “duplicate comment detected; It looks as though you’ve already said that!

Danielle Monterroso

Get Outlook for iOS<https://aka.ms/o0ukef>

#9 Updated by Raymond Hoh over 1 year ago

Marilyn, the resolved problem was with the bbPress forums.

The problem noted in the first Zendesk ticket and the latest one by Danielle is the same Akismet comment problem noted in #11313.

I can confirm that Danielle's comments were marked as spam. I just approved the first one in the spam queue:
https://cstspring2020.commons.gc.cuny.edu/reading-response-feb-4/#comment-34


Whenever Akismet marks a comment as spam, the user isn't aware of this. So the user will continue trying to post the same comment and will therefore receive the duplicate comment message.

What I can do in the meantime is disable Akismet for the mentioned sites in this thread, but this is just hiding the problem and not a sustainable workaround going forward.

Boone, do we want to do something drastic like look into a different comment anti-spam solution altogether? Use reCAPTCHA?

#10 Updated by Boone Gorges over 1 year ago

  • Status changed from In Progress to Resolved

I believe the main issue in this thread is resolved. Further discussion of the spam issue can be found at https://redmine.gc.cuny.edu/issues/11313#note-40

#11 Updated by Raymond Hoh over 1 year ago

#12 Updated by Marilyn Weber over 1 year ago

Not sure if I should put this here or in #11313. Via ZenDesk:

"I am trying to set up a forum board on our Commons website, https://iletc.commons.gc.cuny.edu/forums/topic/general/
One issue is that no one is able to post, reply, or quote on the board itself, except for posting through the backend as administrator. I have set the settings so that people can post anonymously and granted all users Author statuses, but no one has been able to contribute. My account as well will not allow to click "REPLY" etc.
I am using the plugin bbPress. ?I would greatly appreciate your help as soon as possible. I am also reachable by 678-662-7491 at this time.
Thank you so much!
Juwon Jun
College Assistant, ILETC"

#13 Updated by Raymond Hoh over 1 year ago

I'm looking into this, Marilyn.

#14 Updated by Marilyn Weber over 1 year ago

Thanks, Ray.

#15 Updated by Raymond Hoh over 1 year ago

Hi Marilyn,

Tell Juwon that someone on the ILETC site added some CSS to hide all forms across the site. I've just removed the CSS snippet and the forum reply form should be visible now to all users.

#16 Updated by Marilyn Weber over 1 year ago

thanks - problem solved!

Also available in: Atom PDF