Project

General

Profile

Bug #126

Report of Lost Forum Attachments after Upgrade

Added by Matt Gold over 9 years ago. Updated over 9 years ago.

Status:
Resolved
Priority name:
Urgent
Assignee:
Category name:
Upgrades
Target version:
-
Start date:
2009-12-06
Due date:
% Done:

0%

Estimated time:

Description

A member of the site who is directing the NCC (New Community College) organizations on the Commons tells me that the group appears to have lost attachments that it posted in <a href="http://commons.gc.cuny.edu/groups/ncc-assessment-portfolio-working-committee/forum/topic/assessment-portfolio-drafts/">one of its groups</a>. I have asked for more details, but this is a very serious matter, so I think we should prioritize it first on Monday morning.

History

#1 Updated by Chris Stein over 9 years ago

Ok I agree it's serious. If they can remember the names of some of the files and have a rough idea of how many there were (ballpark) that might be helpful.

#2 Updated by Matt Gold over 9 years ago

Heard back from the reporter with no new news of file names but with the news that there were 6-8 attachments on the thread at the url above.

#3 Updated by Boone Gorges over 9 years ago

The files are there. I joined the group and was able to download all the attachments in the thread (I count 10 of them). It's likely that the user is getting a 404 message because of the HTTP issues that Chris has been working on. I will load up every browser I can find this morning and see if I can find an environment in which it does not work. In the meantime, it would be very helpful to have some details about the problem: 1) What OS and browser (specific version is important) is being used? 2) Exactly what is happening when the user views the group? Are the attachments' filenames missing? Or are they there but they lead nowhere?

#4 Updated by Zach Davis over 9 years ago

Just spoke with Boone on IM -- Lucas or I will look at this when we get to work this morning, around 8:30 PST. We'll test in our various testing environments and see if we can isolate the problem.

Zach

#5 Updated by Matt Gold over 9 years ago

Thanks so much, guys, for your quick work on this. I will contact the member to tell her that the files are there but that we're dealing with browser conflicts that should soon be resolved.

#6 Updated by Lucas Thurston over 9 years ago

Matt,
I've tested several browsers (IE8, IE7, IE6, Chrome, FF/Mac, Safari/Mac) and the download works in all except IE6. The layout is so broken in IE6, however, that the links aren't even accessible (I couldn't find the "Attachments" sections on the page). It was only by copying and pasting the download link from IE7 that I was able to determine that the IE6 download was failing.

I'm not entirely sure how the user might have found the file links on the page in IE6, so it would be good to get confirmation that they were using IE6 and not something else.

Thanks,
Lucas

#7 Updated by Matt Gold over 9 years ago

  • Status changed from Assigned to Reporter Feedback

Great. Thanks so much, Lucas. I will pass word of this on to the member but I will tell her that everything appears to be working correctly for us with the exception of occasions when members use an eight-year old browser to view the site.

Deepest thanks to all of you work your work on this. Changing status to feedback awaiting confirmation from member.

#8 Updated by Boone Gorges over 9 years ago

On a side note: whatever the outcome of this particular ticket, I think it's worth having a discussion at some point about the extent to which we are willing to sink dev resources into making the site functional with IE6.

#9 Updated by Matt Gold over 9 years ago

I was about to say that given our limited resources, it's not worth supporting an eight-year old browser that has been twice superseded by new versions, but then I looked at our stats. Can this be right? Are 10% of our visitors really using IE6? http://www.sitemeter.com/?a=stats&s=sm3commons&r=13

#10 Updated by Boone Gorges over 9 years ago

It wouldn't surprise me. And there may be cases in which people don't have a choice - it's possible that individual campuses refuse to upgrade.

#11 Updated by Chris Stein over 9 years ago

Good work on this all. Glad to see that the bug was due to an older browser and not something more serious. As for supporting ie6, it will get less important each year but it could be that for now some people in their office on a college issued computer may not have a choice.

On the side I will look into the downloading issue and whether the judicious use of some conditional comments may make the layout viewable at least .

#12 Updated by Boone Gorges over 9 years ago

Chris, you should feel free to totally rewrite the markup for the attachments box under the post. Start at function bb_attachments_post_attachments, around line 240. I suggest putting it inside of a div class="bp-widget", or some other markup that already exists in BP core. If you don't get to it, I will look at it sometime soon myself.

#13 Updated by Matt Gold over 9 years ago

  • Status changed from Reporter Feedback to Resolved

Member has confirmed that everything is working correctly. Thanks again to the team for great work on this.

Also available in: Atom PDF