Project

General

Profile

Bug #12724

Jetpack administration page crashes

Added by Anonymous over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority name:
Normal
Assignee:
-
Category name:
WordPress (misc)
Target version:
Start date:
2020-04-29
Due date:
% Done:

0%

Estimated time:

Description

Site: socialmediums.commons.gc.cuny.edu

When visiting the Jetpack settings page, all of them show up briefly only to disappear soon thereafter.

The console shows:

Failed to load resource: https://socialmediums.commons.gc.cuny.edu/wp-json/jetpack/v4/rewind?_cacheBuster=1588200101862 The server responded with a status of 400 (Bad Request)
Failed to load resource: https://socialmediums.commons.gc.cuny.edu/wp-json/jetpack/v4/site?_cacheBuster=1588200101940 the server responded with a status of 400 (Bad Request)
WebSocket connection to 'wss://public-api.wordpress.com/pinghub/wpcom/me/newest-note-data' failed: Error during WebSocket handshake: Unexpected response code: 403

TypeError: Os(...).filter is not a function
    at Ns (admin.js?ver=8.3-1.16.10:2)
    at Function.mapToProps (admin.js?ver=8.3-1.16.10:2)
    at r (admin.js?ver=8.3-1.16.10:2)
    at f (admin.js?ver=8.3-1.16.10:2)
    at admin.js?ver=8.3-1.16.10:2
    at i.r.selectDerivedProps (admin.js?ver=8.3-1.16.10:2)
    at i.o.renderWrappedComponent (admin.js?ver=8.3-1.16.10:2)
    at i.o.indirectRenderWrappedComponent (admin.js?ver=8.3-1.16.10:2)
    at ph (react-dom.min.js?ver=16.9.0-1.16.10:221)
    at lh (react-dom.min.js?ver=16.9.0-1.16.10:126)
    at O (react-dom.min.js?ver=16.9.0-1.16.10:121)
    at ze (react-dom.min.js?ver=16.9.0-1.16.10:118)
    at react-dom.min.js?ver=16.9.0-1.16.10:53
    at unstable_runWithPriority (react.min.js?ver=16.9.0-1.16.10:26)
    at Ma (react-dom.min.js?ver=16.9.0-1.16.10:52)
    at mg (react-dom.min.js?ver=16.9.0-1.16.10:52)
    at V (react-dom.min.js?ver=16.9.0-1.16.10:52)
    at Sb (react-dom.min.js?ver=16.9.0-1.16.10:213)
    at Object.enqueueSetState (react-dom.min.js?ver=16.9.0-1.16.10:203)
    at t.q.setState (react.min.js?ver=16.9.0-1.16.10:21)
    at admin.js?ver=8.3-1.16.10:2
    at d (admin.js?ver=8.3-1.16.10:2)
    at admin.js?ver=8.3-1.16.10:2
    at admin.js?ver=8.3-1.16.10:2
    at dispatch (admin.js?ver=8.3-1.16.10:2)
    at admin.js?ver=8.3-1.16.10:2
ve    @    react-dom.min.js?ver=16.9.0-1.16.10:103

TypeError: Os(...).filter is not a function
    at Ns (admin.js?ver=8.3-1.16.10:2)
    at Function.mapToProps (admin.js?ver=8.3-1.16.10:2)
    at r (admin.js?ver=8.3-1.16.10:2)
    at f (admin.js?ver=8.3-1.16.10:2)
    at admin.js?ver=8.3-1.16.10:2
    at i.r.selectDerivedProps (admin.js?ver=8.3-1.16.10:2)
    at i.o.renderWrappedComponent (admin.js?ver=8.3-1.16.10:2)
    at i.o.indirectRenderWrappedComponent (admin.js?ver=8.3-1.16.10:2)
    at ph (react-dom.min.js?ver=16.9.0-1.16.10:221)
    at lh (react-dom.min.js?ver=16.9.0-1.16.10:126)
    at O (react-dom.min.js?ver=16.9.0-1.16.10:121)
    at ze (react-dom.min.js?ver=16.9.0-1.16.10:118)
    at react-dom.min.js?ver=16.9.0-1.16.10:53
    at unstable_runWithPriority (react.min.js?ver=16.9.0-1.16.10:26)
    at Ma (react-dom.min.js?ver=16.9.0-1.16.10:52)
    at mg (react-dom.min.js?ver=16.9.0-1.16.10:52)
    at V (react-dom.min.js?ver=16.9.0-1.16.10:52)
    at Sb (react-dom.min.js?ver=16.9.0-1.16.10:213)
    at Object.enqueueSetState (react-dom.min.js?ver=16.9.0-1.16.10:203)
    at t.q.setState (react.min.js?ver=16.9.0-1.16.10:21)
    at admin.js?ver=8.3-1.16.10:2
    at d (admin.js?ver=8.3-1.16.10:2)
    at admin.js?ver=8.3-1.16.10:2
    at admin.js?ver=8.3-1.16.10:2
    at dispatch (admin.js?ver=8.3-1.16.10:2)
    at admin.js?ver=8.3-1.16.10:2
ve    @    react-dom.min.js?ver=16.9.0-1.16.10:103

WebSocket connection to 'wss://public-api.wordpress.com/pinghub/wpcom/me/newest-note-data' failed: Error during WebSocket handshake: Unexpected response code: 403
Screenshot_2020-04-30_09-38-03.png (68.7 KB) Screenshot_2020-04-30_09-38-03.png Boone Gorges, 2020-04-30 10:38 AM

Related issues

Related to CUNY Academic Commons - Bug #12950: I messed up the JetPack connection on one of my sitesResolved2020-06-17

History

#1 Updated by Boone Gorges over 1 year ago

Hi Kalle - Thanks for the detailed report and especially for sharing the output of the console.

I'm unable to reproduce what you've described. When I visit https://socialmediums.commons.gc.cuny.edu/wp-admin/admin.php?page=jetpack I see the attached, prompting me to 'Set up Jetpack'. Did you perhaps disconnect from wordpress.com in an attempt to debug? If so, are you able to get it back to the state that you described above, so that I can do further debugging? If not, perhaps I'm looking in the wrong place?

#2 Updated by Raymond Hoh over 1 year ago

Hi Kalle,

I would also check your adblock settings. I know with the uBlock Origin or uMatrix addons, you can block websocket connections. Maybe a filter list is blocking them?

#3 Updated by Anonymous over 1 year ago

Thank you, Ray! That seems to have done the trick!

#4 Updated by Raymond Hoh over 1 year ago

  • Status changed from Reporter Feedback to Resolved
  • Target version set to Not tracked

Great! Marking as resolved.

#5 Updated by Raymond Hoh over 1 year ago

  • Related to Bug #12950: I messed up the JetPack connection on one of my sites added

Also available in: Atom PDF