Project

General

Profile

Bug #12950

I messed up the JetPack connection on one of my sites

Added by Raffi Khatchadourian about 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
WordPress Plugins
Target version:
Start date:
2020-06-17
Due date:
% Done:

0%

Estimated time:

Description

Yesterday, while trying to refresh JetPack connections on my site, I messed up one of them. It turns out that if you disconnect JetPack from a site on wordpress.com, when you try to reconnect it, you can't. Specifically, when I navigate to https://cybercamp.commons.gc.cuny.edu/wp-admin/admin.php?page=jetpack, I now see a blank page. Normally, this is where I would reconnect JetPack in order to refresh the connection. It seems to me that some kind of cache needs to be flushed, perhaps.


Related issues

Related to CUNY Academic Commons - Bug #12724: Jetpack administration page crashesResolved2020-04-29

History

#1 Updated by Boone Gorges about 1 year ago

  • Assignee set to Raymond Hoh

I did a bit of searching but I didn't see at a glance how to reset the Jetpack connection on the Commons end.

Ray, could you have a look to see what needs to be deleted on the Commons for the Jetpack setup routine to be triggered?

#2 Updated by Raymond Hoh about 1 year ago

  • Related to Bug #12724: Jetpack administration page crashes added

#3 Updated by Raymond Hoh about 1 year ago

I'm seeing the same JS console messages on the Jetpack page as the one in #12724. However, if I visit another subsite with Jetpack enabled, I am not encountering the problem.

Raffi, can you try the following guides to disconnect directly from wordpress.com site and then try the Jetpack dashboard and reconnecting again?
https://jetpack.com/support/reconnecting-reinstalling-jetpack/#disconnecting-jetpack
https://jetpack.com/support/disconnect-jetpack-sites/

#4 Updated by Raffi Khatchadourian about 1 year ago

Raymond Hoh wrote:

I'm seeing the same JS console messages on the Jetpack page as the one in #12724. However, if I visit another subsite with Jetpack enabled, I am not encountering the problem.

Raffi, can you try the following guides to disconnect directly from wordpress.com site and then try the Jetpack dashboard and reconnecting again?
https://jetpack.com/support/reconnecting-reinstalling-jetpack/#disconnecting-jetpack
https://jetpack.com/support/disconnect-jetpack-sites/

Hey Raymond. Sorry for the delayed response. Disconnecting from wordpress.com is actually how I got into this pickle. When I disconnect from the Commons side, everything seems to work out fine.

#5 Updated by Raymond Hoh about 1 year ago

  • Status changed from New to Reporter Feedback

Hi Raffi,

I just deactivated Jetpack and reactivated it on the cybercamp site and it appears that helped to clear out any older remnants.

Try setting up Jetpack again on Jetpack's dashboard page and let us know if that works:
https://cybercamp.commons.gc.cuny.edu/wp-admin/admin.php?page=jetpack#/dashboard

#6 Updated by Raffi Khatchadourian about 1 year ago

It worked. Thanks!

#7 Updated by Raymond Hoh about 1 year ago

  • Category name set to WordPress Plugins
  • Status changed from Reporter Feedback to Resolved
  • Target version set to Not tracked

Great! Glad that worked!

#8 Updated by Raffi Khatchadourian about 1 year ago

Raymond Hoh wrote:

Great! Glad that worked!

Well, sort of. Now I just get my usual wordpress.com connection errors :).

#9 Updated by Raymond Hoh about 1 year ago

Hi Raffi,

Are the problems you mention the same as the ones you mention here?
https://redmine.gc.cuny.edu/issues/12624#note-21

If they are the same, please reopen that ticket. My initial readthrough is that you're experiencing problems when logging into wordpress.com from your browser to edit posts from your Commons site. Is that a fair takeaway? If so, my first thought is your browser is blocking third-party cookies and/or frames via a browser extension like uBlock Origin or uMatrix.

#10 Updated by Raffi Khatchadourian about 1 year ago

Hi Raymond,

The problem is in the description of that bug: https://redmine.gc.cuny.edu/issues/12624#content. I don't have the ability to re-open it. It's a nice thought, but even the Wordpress app on Android is no longer able to read the posts and pages from any of my CAC sites. OpenLab continues to work, but since leaving City Tech, I have been mainly using CAC.

Just to double check, I tried using an incognito Chrome browser window. I could not load any pages on https://wordpress.com/pages/khatchad.commons.gc.cuny.edu. I get the message, "You haven't published any pages yet. Would you like to publish your first page?" despite already publishing several pages.

Also available in: Atom PDF