Project

General

Profile

Support #13243

Request to copy group library

Added by Matt Gold about 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
Group Library
Target version:
Start date:
2020-08-26
Due date:
% Done:

0%

Estimated time:

Description

Speaking to the need for this to be part of our future release schedule, I would like to request the copying of the group library from my previous course to my new one (I promise I'm going to change things around and update my syllabus, but this will make the process easier!)

Source library: https://commons.gc.cuny.edu/groups/introduction-to-digital-humanities-2019/documents/

Target library: https://commons.gc.cuny.edu/groups/dh70000-introduction-to-digital-humanities-fall-2020/library/#/

Note: I'm almost positive we had more than 8 items in the source library from last Fall. Is it possible that the issue in this ticket is also affecting this group library? https://redmine.gc.cuny.edu/issues/13227

cac-group-library-copy.php (2.97 KB) cac-group-library-copy.php Boone Gorges, 2020-08-27 08:40 AM

Related issues

Related to CUNY Academic Commons - Support #13138: moving Library contents for Steve BrierResolved2020-08-02

History

#1 Updated by Boone Gorges about 1 year ago

  • Related to Support #13138: moving Library contents for Steve Brier added

#2 Updated by Boone Gorges about 1 year ago

  • Status changed from Assigned to Reporter Feedback
  • Target version set to Not tracked

I've copied the library.

I also confirmed that the source library only had eight Files, so it's not being affected by #13227.

#3 Updated by Matt Gold about 1 year ago

Okay -- thanks so much, Boone!

#4 Updated by Matt Gold about 1 year ago

  • Status changed from Reporter Feedback to Resolved

#5 Updated by Matt Gold about 1 year ago

  • Status changed from Resolved to Assigned

Hi Boone,

Students in the group are saying that when they try to download the files in the library, they are getting error messages. -- " “You must be a logged-in member of the group "Introduction to Digital Humanities 2019" to access this document. “ - cannot view/download files…"

they are indicating that though the files show up in our new group library, the links to them point to the older group.

If you could help with this, I would appreciate it.

#6 Updated by Boone Gorges about 1 year ago

I rewrite the copy script and ran it again. It looks like it's working now. Please verify: https://commons.gc.cuny.edu/groups/dh70000-introduction-to-digital-humanities-fall-2020/library/#/

#7 Updated by Matt Gold about 1 year ago

  • Status changed from Assigned to Resolved

I can confirm this is fixed. Thank you, Boone!

Also available in: Atom PDF