Project

General

Profile

Bug #13494

Brief Descriptor and About You Profile Fields do not display on mobile devices

Added by scott voth about 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
Public Portfolio
Target version:
Start date:
2020-10-23
Due date:
% Done:

0%

Estimated time:

Description

Bret Maney writes "When you view the profiles on mobile (Safari or Chrome on iPhone but I believe on Android as well), the “Brief descriptor” and “About You” fields don’t show. If you swipe down, you can sort of get a glimpse of them, but not really."

I too see them briefly, but then they disappear.


Related issues

Related to CUNY Academic Commons - Bug #13352: jQuery update for bp-neloResolved2020-09-21

History

#1 Updated by Boone Gorges about 1 year ago

  • Status changed from New to Staged for Production Release
  • Target version set to 1.17.6

Thanks for the report. It looks like something funny happens when the WP toolbar height changes at narrow window widths, so that our 'sticky' library incorrectly calculates the offset of the top row, thinking that it should be 'stuck' even before scrolling has begun. It's likely that much of this logic will have to be rewritten as we move to an upgraded version of jQuery #13352, which will require an upgrade to the Waypoints library in cac-advanced-profiles. As such, I'm going to put a small hack in place to make it work rather than digging into the root causes. See https://github.com/cuny-academic-commons/cac-advanced-profiles/commit/8296401561c67dbb7eb7d202db5e53cb666b74c1

#2 Updated by Boone Gorges about 1 year ago

  • Related to Bug #13352: jQuery update for bp-nelo added

#3 Updated by Boone Gorges about 1 year ago

  • Target version changed from 1.17.6 to 1.17.7

#4 Updated by Boone Gorges about 1 year ago

  • Target version changed from 1.17.7 to 1.17.6

#5 Updated by Boone Gorges about 1 year ago

  • Status changed from Staged for Production Release to Resolved

Also available in: Atom PDF