Project

General

Profile

Bug #13499

Student repeatedly loses membership to private class group

Added by scott voth 12 months ago. Updated 11 months ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
Groups (misc)
Target version:
Start date:
2020-10-23
Due date:
% Done:

0%

Estimated time:

Description

Group: https://commons.gc.cuny.edu/groups/fall-2020-research-in-the-digital-age-lib-10000/

"Sometime I got kicked out of the group for no reason. For example, I was browsing the forum and the next second I wasn't the group member anymore. The professor didn't know what happened and I never touch the "Leave Group" button. Thus, is there any possible explanation for this?"

"Unfortunately, this situation is happening again now. All I did was refresh the web page and after that I suddenly lost the membership of the LIB group. Since you probably won't respond to this right now, could you please proved to professor Sarah Cohn that I encountered this situation again because I have an assignment that requires responding in the group due this midnight. Of course, I will also inform her about this but I need you to prove it so I could be excused. Thank you!"

User email - (not sure what member name)

History

#1 Updated by Boone Gorges 12 months ago

  • Assignee changed from Boone Gorges to Raymond Hoh

Ray, are you available to look at this this afternoon? I'll be out of office for a bit but it would be good to get this looked at sooner.

#2 Updated by Raymond Hoh 12 months ago

I can take a look. My guess off the top of my head is this might be an object caching issue, but I'll investigate.

#3 Updated by Colin McDonald 12 months ago

On the off chance it's related, I lost my membership in the CUNY Academic Commons Subcommittee group at some point recently, I believe earlier today, and had to request (and receive) access again a little while after the meeting today.

#4 Updated by Raymond Hoh 12 months ago

  • Target version set to 1.17.6

I checked the access logs for the user in question from their IP address, which I obtained from a bbPress reply that the user posted.

I can see that the user left the group on October 22, 10:24pm ET:

USER IP - - [22/Oct/2020:22:24:08 -0400] "GET /groups/fall-2020-research-in-the-digital-age-lib-10000/leave-group/?_wpnonce=87e9c568fa HTTP/1.1" 302 - "https://commons.gc.cuny.edu/groups/fall-2020-research-in-the-digital-age-lib-10000/forum/topic/db-8-social-media-activism/" "Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/63.0.3239.132 Safari/537.36" 80583 commons.gc.cuny.edu

I'm guessing perhaps the user might have pressed the "Leave Group" button on their mobile device desktop PC accidentally while scrolling? User agent says the user was browsing with Chrome 63 on Windows 10.

In any case, I have added a safeguard so the "Leave Group" button will prompt the user with an "Are you sure?" dialog to confirm their action. This is something BuddyPress does by default, but since we run the older bp-default theme, we need to manually add the #buddypress ID to a <div> container. See https://github.com/cuny-academic-commons/cac/commit/3c4040984c22fdcb11c3309dd8c83baefda78893.

I've applied this as a hotfix on production.

The same confirm action needs to be added to the Groups Directory for any "Leave Group" button click, but there is a JS conflict that prevents the confirm prompt from showing up. I'm looking into it.

#5 Updated by scott voth 12 months ago

Thanks Ray - I will let the student know.

#6 Updated by Boone Gorges 12 months ago

  • Target version changed from 1.17.6 to 1.17.7

#7 Updated by Colin McDonald 12 months ago

Just saw this in the help team tickets and thought I'd post here as another to look into.

Oct 27, 2020, 7:13 AM EDT
Good morning,

I seem to have lost the ability to post documents and files to my group (College of Staten Island English Department). When I go to my group page, I can see all of my previous posts, however, those options no longer appear on the menu to the left. The group administrator has repeatedly tried to re-grant me access, but I have not received any notifications via email. Is there some option that I am missing on my account and is there any way to get posting ability back?

Thank you
Fredi

Fredricka Grasso

#8 Updated by Raymond Hoh 12 months ago

Colin, it looks like the student still has access to the group in question. Can you ask Fredricka to elaborate on the following: When I go to my group page, I can see all of my previous posts, however, those options no longer appear on the menu to the left.

Does Fredricka mean the group sidebar items are missing? I don't think this issue is related to the main one in this ticket. I think the issue is she hasn't checked the Commons in awhile. Can you let her know about the new Group Library functionality and see if that addresses the issue about group documents?

#9 Updated by Colin McDonald 12 months ago

Thanks Ray, that did the trick and this user seems to be in good shape now.

#10 Updated by Raymond Hoh 12 months ago

  • Status changed from New to Staged for Production Release

The same confirm action needs to be added to the Groups Directory for any "Leave Group" button click, but there is a JS conflict that prevents the confirm prompt from showing up. I'm looking into it.

Just added a fix for this directly to our bp-nelo JS - https://github.com/cuny-academic-commons/cac/commit/5e08f6a6da3d676c358d5535b0d8bd96005719d9.

Boone, you can close out this ticket after the next maintenance release is out.

#11 Updated by Boone Gorges 11 months ago

  • Status changed from Staged for Production Release to Resolved

Also available in: Atom PDF