Project

General

Profile

Feature #1450

Modifications to BP Profile Social Media Icons

Added by Chris Stein over 10 years ago. Updated over 10 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
BuddyPress (misc)
Target version:
Start date:
2011-12-15
Due date:
% Done:

0%

Estimated time:

Description

This ticket is for changes and fixes for the display of social media links as icons in the Profile.
I am adding in my suggestions but expect others to chime in and veto or add different ones

  • Add space between the images by add css like the following to custom.css (this adds 5px, see attached image)
    #bp-smp-header img{
        margin-right:5px;
    }
  • Make sure all of the icons are links to the appropriate pages. On my page neither flickr nor YouTube are links (but delicious is).
  • I'm fine with the icons we have now. If you want something else offer up a GPL'd set so we can take a look. This is something we'll have to monitor to make sure we have icons as we expand the number of links we support.

Adding people who talked about it last time as watchers.

IconSpace-1.png (4.94 KB) IconSpace-1.png Chris Stein, 2011-12-15 03:31 PM

History

#1 Updated by Matt Gold over 10 years ago

  • Category name set to BuddyPress (misc)
  • Status changed from New to Assigned
  • Assignee set to Boone Gorges
  • Target version set to 1.3.1

#2 Updated by Boone Gorges over 10 years ago

  • Status changed from Assigned to Reporter Feedback

The spacing problem is caused by the second problem, having to do with links. I think the second problem was caused by my hasty setup today, which I have now fixed. Please try saving your profile again and let me know if it's fixed.

FWIW we don't have to have GPL icons for the site (though they do need to be licensed in a way that lets us use them). The GPL restriction is only crucial if I'm going to distribute the icons with the plugin.

#3 Updated by Boone Gorges over 10 years ago

Actually, it turns out I have the ability to resave your profile for you (through a script; see #1451). Looking good now. Let me know what you think.

#4 Updated by Chris Stein over 10 years ago

Great, looks good. This is resolved from where I stand.

#5 Updated by Boone Gorges over 10 years ago

  • Status changed from Reporter Feedback to Resolved

Thanks, Chris!

Also available in: Atom PDF