Project

General

Profile

Bug #14726

Group not letting me connect to already existing site

Added by Laurie Hurson about 2 months ago. Updated about 1 month ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
-
Target version:
Start date:
2021-08-25
Due date:
% Done:

0%

Estimated time:

Description

Hi All,

I am trying to enable group site for a professor but when I go to the manage area of the group, it is not allowing me to choose between create new site, connect to already existing, or clone. It is forcing the clone screen and I want to connect to an already existing site.

Group: https://commons.gc.cuny.edu/groups/evolution-expressions-of-race-bls-1003-fall-2021-1941033944/

Site to connect: https://bls1003shamptonfall2021.commons.gc.cuny.edu/

Is this a bug? Any ideas on how to resolve? I do not believe the site is already connected to another group.

Thanks in advance for your help!

Recording #7.mp4 (6.56 MB) Recording #7.mp4 Laurie Hurson, 2021-08-25 10:58 AM
group-site-click.gif (687 KB) group-site-click.gif Jeremy Felt, 2021-08-26 06:13 PM
Recording #9.mp4 (12.9 MB) Recording #9.mp4 Laurie Hurson, 2021-09-08 04:26 PM

History

#1 Updated by Laurie Hurson about 2 months ago

forgot to add this video of what i am seeing

#2 Updated by Boone Gorges about 2 months ago

  • Assignee set to Jeremy Felt

It appears that the group was created via clone, and that the clone source had a site. When this happens, we show the clone interface only.

Jeremy, this is based on what I'm reading in the code. Is this the intended behavior? Do we have documentation of how this decision was made?

#3 Updated by Jeremy Felt about 2 months ago

These are the steps I used to try and reproduce the issue:

1. Create a new group AAA with a new connected site AAA.
2. Clone group AAA to group BBB as a stand-alone group.
3. Navigate to group BBB -> Manage -> Group site
4. Check box for "Enable group site"
5. Select "Connect an Existing Site"
6. Select a site.
7. Click "Save Changes"

I think this flow worked as intended for me BUT there is some UI flakiness might be getting in the way. When I first navigate to "Group Site", the entire interface displays and then hides again until I check the box for "Enable group site". I've attached a GIF showing that interaction.

So with that, maybe a couple things:

  • I can definitely make that UI better.
  • Am I missing something in the steps to reproduce?

#4 Updated by Colin McDonald about 2 months ago

Hi Jeremy, I followed your same steps and got the same results, so agree on the UI. Wish I could better parse why our tests aren't matching up with what Laurie saw on her group. FYI, we might have to wait a bit for Laurie to respond, as she got married on Friday and is out I believe until after Labor Day.

One odd thing about her video, in case you didn't notice, is the long auto-populated URL that is coming up automatically in the Site Details. I didn't see any auto-population on my end, let alone something as involved as that, already longer than the limit. Not sure if that helps, just an observation. It's different because I'm choosing the cloning option for the new connected site, but she's not seeing those options at all.

#5 Updated by Laurie Hurson about 1 month ago

Hi All,

Sorry for my delayed response and many thanks for looking into this and testing on your end.

I re-tested this process with another connected group-site, following the steps Jeremy outlined:

Cloned group "class name" (group of a connected group site, did not clone site) to create "class name test clone" group
Went to Manage in "class name test clone" in the new group
"Enable group-site" functioned more or less as it should
video of this attached

It seems that this issue is only happening for the evolutions and expressions of race" group then? (Group: https://commons.gc.cuny.edu/groups/evolution-expressions-of-race-bls-1003-fall-2021-1941033944/)

Even though I am an admin on the evolutions and expressions of race group, I do not see a way to uncouple this group from the site it is not-really-attached to in order to connect it to the correct site. Would it be possible to uncouple this group in some other way in the back end so I can connect to the correct site?

Thanks!

#6 Updated by Boone Gorges about 1 month ago

Hi Laurie - I think I've made the necessary change, but I'm not 100% what I'm looking for :) Have a look: https://commons.gc.cuny.edu/groups/evolution-expressions-of-race-bls-1003-fall-2021-1941033944/admin/group-blog/

#7 Updated by Laurie Hurson about 1 month ago

Thanks Boone! This looks good-I can now connect to an already existing site.

#8 Updated by Boone Gorges about 1 month ago

  • Status changed from New to Resolved
  • Target version set to Not tracked

Awesome! Let's chalk this up to a one-time fluke.

Also available in: Atom PDF