Project

General

Profile

Actions

Bug #14940

closed

Discrepancy between Commons profile "sites" and actual # of sites

Added by Laurie Hurson about 1 year ago. Updated 4 months ago.

Status:
Rejected
Priority name:
Normal
Assignee:
-
Category name:
-
Target version:
-
Start date:
2021-11-05
Due date:
% Done:

0%

Estimated time:
Deployment actions:

Description

Hi All,

I am not sure if this a bug or intended behavior but when I try to view a user's sites it only list some of their sites, not all, especially and including course sites.

Some examples:

Prof Brandle's common profile list of sites: https://commons.gc.cuny.edu/members/brandle/blogs/
Brandle's courses: https://commons.gc.cuny.edu/courses/?filters%5Bkeyword%5D=brandle&order-by=semester
- some of which are public sites that are not listed in her commons profile

Another
Prof Hamptons commons profile list of sites: https://commons.gc.cuny.edu/members/scbrown205/blogs/
Pro Hamptons Courses (first two): https://commons.gc.cuny.edu/courses/?filters%5Bkeyword%5D=hampton&order-by=semester
- her site is private but I would think it still should come up in her profile?
For what its worth, Prof Hamptons group list seems to work as I assumed it would, listing (I think?) all her groups
https://commons.gc.cuny.edu/members/scbrown205/groups/

If this is a bug, i hope it can be resolved but if it is intended behavior I think we might consider modifying what is displayed here.

I think it would be ideal if, when you visit a users common's profile, you see ALL the Groups or sites that a user is associated with, including courses, irregardless of the privacy setting (unless its a hidden group). Obviously you would not be able to click into private sites and groups but I think they should still be listed? What do others think?

Actions #1

Updated by Boone Gorges about 1 year ago

Site directories on the Commons only show site that are fully public, ie those with blog_public=1, or "Allow search engines to index this site". If you have it set to 0 "Discourage search engines..." then it will not show up. This dates back to the early days of BuddyPress, and is by design. If you select an option that says "discourage search engines", but are then listed in the public directories that will be picked up by search engines, then it defeats the purpose of having the "discourage" option. This is what's happening with most of Prof Brandle's sites.

Actions #2

Updated by Laurie Hurson about 1 year ago

Ah, got it. Thanks for this info Boone. Sorry for my confusion I understand that rationale, it just makes finding a prof's sites more difficult sometimes - but i guess that is the point!

Actions #3

Updated by Boone Gorges 4 months ago

  • Status changed from New to Rejected
Actions

Also available in: Atom PDF