Project

General

Profile

Support #15685

problem with chrome?

Added by Marilyn Weber 3 months ago. Updated 2 months ago.

Status:
New
Priority name:
High
Assignee:
-
Category name:
-
Target version:
-
Start date:
2022-03-21
Due date:
% Done:

0%

Estimated time:

Description

\"\"
2 minutes ago

Hello,

I can no longer log into the Commons from my Chrome browser. I know you will tell me to try Firefox, but I really need you to work with me on this. This is an error that I have seen my students get and we never got an answer from you what is wrong. I do not want to use Firefox and I am teaching a class with the help of my Commons website in 1 hour, so that should be interesting given I cannot log into my site. What happened since last week? It worked great.

Please fix this!

Prof. Kucheva?

-------------------------------------------
Yana Kucheva
Assistant Professor
Department of Sociology
The City College of New York
NAC 6/108D
160 Convent Avenue
New York, NY 10031

History

#1 Updated by Boone Gorges 3 months ago

It appears that something in the user's browser is causing certain cookies to be rejected. Try visiting https://commons.gc.cuny.edu/wp-login.php directly and logging in from there.

#2 Updated by Marilyn Weber 3 months ago

She replies ?Unfortunately, it does not work. I have been able to open the site in Safari, so I will use that for now.

I tried clearing the cookies in Chrome and it did not work either. I will keep poking around to see if I can get it to work.

Thank you!

#3 Updated by Boone Gorges 3 months ago

The "Forbidden" message is triggered when a user attempts to log in, but does not have our special login cookie set. This login cookie, which is set anytime a user visits any page on the Commons, is a technique for preventing spambots. It's possible that a browser extension, such as an ad blocker, could be preventing the cookie from being set.

CCing Ray, as he has worked with the cookies-for-login tool in the past and may have other ideas.

#5 Updated by Raymond Hoh 3 months ago

Problem is due to an adblocking list. I've quoted a previous response from #11078:

I've ran into this before. The problem is with an adblock filter list:
https://github.com/easylist/easylist/issues/2687

They are blocking the Cookies for Comments asset needed to set the anti-spam cookie.

Tell the user to disable the Fanboy Annoyance List to workaround this.

#6 Updated by Raymond Hoh 3 months ago

I've taken a look at the video and the user has the Ghostery extension installed.

I've taken a screenshot so the user can unblock the asset in Ghostery:

#7 Updated by Marilyn Weber 3 months ago

We now have a different user with the same problem:

I am registered for CUNY Academic Commons with this email address and the username sarahs. I tried to log on yesterday and today from home and I received a messaged saying that I am forbidden from logging on from this server. (Screenshot attached.) Could you please help me figure out what's going on and get back on? Thank you!

Best,
Sarah

Sarah Schwartz (she/her)

#8 Updated by Marilyn Weber 3 months ago

She elaborates:

Going to any part of the Commons results in the same thing in Chrome. But I can log in in Safari. Could you perhaps alert me when the Chrome bug is fixed?

#9 Updated by Raymond Hoh 3 months ago

It's the same problem, but the user is probably using uBlock Origin or Adblock Plus.

See comment 5. Can you tell the user to uncheck the "Easylist Cookie" and "Fanboy's Annoyance" filter lists in their adblocking extension?

Can also add the following override filter into uBlock Origin or Adblock Plus so those filter lists can stay in place if preferred:

@@||commons.gc.cuny.edu/wp-content/plugins/cookies-for-comments/*$domain=commons.gc.cuny.edu

#10 Updated by Marilyn Weber 3 months ago

I will do this with both users. Will let you know how they react.

#11 Updated by Marilyn Weber 2 months ago

This is coming up again. The user asks "how do I go about disabling fanboy annoyance list?"

#12 Updated by Marilyn Weber 2 months ago

"Never mind I figured it out, thank you!"

Also available in: Atom PDF