Project

General

Profile

Bug #15756

Authors Unable to access dashboard

Added by Laurie Hurson 3 months ago. Updated 3 months ago.

Status:
Resolved
Priority name:
Normal
Assignee:
-
Category name:
WordPress Plugins
Target version:
Start date:
2022-03-30
Due date:
% Done:

0%

Estimated time:

Description

Hi All,

There is a professor who is having an issue with students being denied access to the dashboard an posting capabilities.

It is this site: https://s22casd1717.commons.gc.cuny.edu/wp-admin/

When students (and I) were added as an author we get the message "You do not have sufficient permissions to access this page." I was using Firefox when I received this message.

Is this a bug or interference from plugins on the site, or...? Any insight would be appreciated.

Thanks,
Laurie

History

#1 Updated by Laurie Hurson 3 months ago

  • Description updated (diff)

#2 Updated by Laurie Hurson 3 months ago

I should add, it seems that this is only happening to authors. When Marilyn was added as an admin, the site worked as intended.

Could this be a database issue or related to recent upgrade of WP?

#3 Updated by Boone Gorges 3 months ago

  • Category name set to WordPress Plugins
  • Status changed from New to Reporter Feedback
  • Target version set to 1.19.7

I identified the root of the problem as a recently-introduced bug in the sign-up-sheets plugin. I've described it in a support ticket here: https://wordpress.org/support/topic/non-admin-cannot-view-dashboard/

For the moment, I've put a hotfix in place on the Commons that fixes the issue. https://github.com/cuny-academic-commons/cac/commit/962f8673082a06120aabbce28e1236ab80928ecf

#4 Updated by Laurie Hurson 3 months ago

Ah, gotcha.

Thank you Boone!

#5 Updated by Boone Gorges 3 months ago

  • Status changed from Reporter Feedback to Staged for Production Release

The plugin author confirmed my fix and shipped it in the most recent version of the plugin. https://wordpress.org/support/topic/non-admin-cannot-view-dashboard/#post-15551898

#6 Updated by Boone Gorges 3 months ago

  • Status changed from Staged for Production Release to Resolved

Also available in: Atom PDF