Project

General

Profile

Bug #15808

Home Page "About" Dropdown

Added by scott voth 3 months ago. Updated 3 months ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
Home Page
Target version:
Start date:
2022-04-04
Due date:
% Done:

0%

Estimated time:

Description

When I hover over the "About" menu option on the home page, the drop down items are cut off on the right. Also, it seems the sub menu font should be a little smaller and maybe have a different background image.

Peek 2022-04-04 19-36.gif (682 KB) Peek 2022-04-04 19-36.gif Boone Gorges, 2022-04-04 08:42 PM

History

#1 Updated by Colin McDonald 3 months ago

Thanks, Scott. I'm adding Boone and Ray as watchers. Sara is out of the office for a couple of days. They might be able to speak to the cutoff issue, and maybe Sara can jump back in soon on the font and color in the submenu -- I assume you mean that the white submenu and general white background can blur together.

I was able to reproduce the submenu cutoff under About on my 13-inch Macbook. Maybe we need to account for laptops or browser windows at least a little smaller than that?

#2 Updated by Boone Gorges 3 months ago

When I hover over the "About" menu option on the home page, the drop down items are cut off on the right.

I noticed this when I was building it, but didn't bother to fix it. I've put a fix in place at https://github.com/cuny-academic-commons/cac/commit/7f507276a1d3cb2d09f3d51561576a3f27542490 that shifts the submenu to align with the right edge of the parent (rather than the default left edge) if there's not enough room for the submenu on the screen. See attached gif.

The issues with the font size etc, are really quite separate. The implementation was built to the approved spec, so it's not a bug that it appears this way. If we have ideas about how it could be improved, I suggest we open a separate 'Feature' ticket.

#3 Updated by Colin McDonald 3 months ago

Thanks for the fix, Boone. The gif looks good to me. We'll pick up the other points about the About submenu font and differentiation on a future call and go from there.

#4 Updated by Boone Gorges 3 months ago

  • Status changed from Staged for Production Release to Resolved

Also available in: Atom PDF