Project

General

Profile

Bug #15947

Slides and Site Running slow issues

Added by Laurie Hurson 2 months ago. Updated 2 months ago.

Status:
Resolved
Priority name:
Normal
Assignee:
-
Category name:
-
Target version:
Start date:
2022-04-21
Due date:
% Done:

0%

Estimated time:

Description

A user is complaining that their site is running very slowly. Site is here: https://lahtilab.commons.gc.cuny.edu/lab-publications/

I would imagine the site is running slowly because the slider has too many images and other pages are packed with media (pdfs, images).

However, I wanted to elevate this in case there is something else going on here and we might be able to speed up the load times on this site.

He is also having issues with meta slider on the site, he is unable to access several sliders he built in the backend"

"slider #1062 cannot be accessed in the metaslider page, and so cannot be edited. The description says there are 94 slides, which >is true, but the icon says 0 slides."

"slider #868 is a version of "people 09-17" that never saved-- it hung up. Description claims there are 54 slides and icon says 0. "

"I would like to be able to delete #868 but can't access it. I spent a lot of time on #1062 and it would suck to have to delete that one too and start all over again, but if that's the way it has to go, so be it. Is there a way to delete these two without actually accessing them in the GUI?"

I think these issues are caused by adding too many slides to a slider (and having multiple that are this large) but maybe I am mistaken? If there might be a bug on the backend here, I wanted to loop that in too.

History

#1 Updated by Laurie Hurson 2 months ago

  • Description updated (diff)

#2 Updated by Laurie Hurson 2 months ago

It does appear there might be a bug with Metaslider. It is inaccessible in the dashboard, see screenshot.

#3 Updated by Boone Gorges 2 months ago

  • Status changed from New to Reporter Feedback
  • Target version set to 1.19.8

I'm not seeing a slider here https://lahtilab.commons.gc.cuny.edu/lab-publications/ - perhaps it was removed?

This report appears to be closely tied to the issue reported in #15767. See specifically https://redmine.gc.cuny.edu/issues/15767#note-2. The plugin authors have promised to implement a fix https://wordpress.org/support/topic/call-to-get_plugins-causing-performance-problems/ but it's not out yet. In the meantime, I've put a hotfix in place that appears to mitigate the issue https://github.com/cuny-academic-commons/cac/commit/680824c1181888814ebdd49bfb9edbff926a3a77 - Could you please confirm?

#4 Updated by Laurie Hurson 2 months ago

Sorry - the slider is on the home page https://lahtilab.commons.gc.cuny.edu/

Thanks for the hot fix, the site performance is much better now. I hope the plugin developers patch this issue!

#5 Updated by Boone Gorges 2 months ago

  • Status changed from Reporter Feedback to Resolved

Thanks, Laurie. Marking resolved for now.

Also available in: Atom PDF