Project

General

Profile

Bug #1881

Double forum notification received

Added by Matt Gold about 10 years ago. Updated about 10 years ago.

Status:
Resolved
Priority name:
Low
Assignee:
Category name:
BuddyPress (misc)
Target version:
Start date:
2012-05-04
Due date:
% Done:

0%

Estimated time:

Description

I received two notifications of this post . Other posts that have come into that group have only been received once. I would have thought that this was a case of a user posting, then deleting, then posting again, but the two notifications appear identical and have the same timestamp.

History

#1 Updated by Boone Gorges about 10 years ago

  • Status changed from Assigned to Reporter Feedback

Other posts that have come into that group have only been received once

Does this include other posts to that specific thread?

#2 Updated by Matt Gold about 10 years ago

Does this include other posts to that specific thread?

Yes -- I received other notifications from the same thread that were not dupes.

#3 Updated by Boone Gorges about 10 years ago

  • Status changed from Reporter Feedback to Assigned

#4 Updated by Raymond Hoh about 10 years ago

I believe this is related to using @mentions in a group forum post:
http://buddypress.trac.wordpress.org/ticket/3980

Matt, can you confirm?

If so, I've already devoted some time to work around this issue for the Group Email Subscription (GES) plugin:
https://github.com/boonebgorges/buddypress-group-email-subscription/issues/6

I just need to merge in my fix with the newer updates for GES.

Once Matt has confirmed the issue, I can tackle patching GES and perhaps Boone can look into the BP issue.

#5 Updated by Matt Gold about 10 years ago

Great catch, Ray -- it makes sense that this is the problem, but I'm not sure what you'd like me to confirm. If you just want me to confirm that mentions were used in the message in question, the answer is yes. If you're looking for confirmation of something else, please let me know!

Thanks for your work on this.

#6 Updated by Raymond Hoh about 10 years ago

Hi Matt, thanks for confirming that an @mention was used in the forum post.

I'm going to work up a new patch for GES that will address this issue.

#7 Updated by Boone Gorges about 10 years ago

  • Assignee changed from Boone Gorges to Raymond Hoh

Thanks for having a look, Ray. Reassigning to you.

#8 Updated by Boone Gorges about 10 years ago

Ray has made some overhauls to BPGES to address this and a few other issues. These changes have been added to CAC in https://github.com/castiron/cac/commit/4de920d551131c84d6aa3f4f95ff530749818df4. I'm going to put this on cdev later today so that we can do some light testing (beyond what Ray and I have done independently).

#9 Updated by Boone Gorges about 10 years ago

  • Assignee changed from Raymond Hoh to Boone Gorges

Reassigning to myself so I don't lose track.

#10 Updated by Boone Gorges about 10 years ago

  • Status changed from Assigned to Resolved

I've run some tests on cdev and it looks like all is in place. I'm marking this ticket Resolved. If the double-notification issue persists, please reopen.

#11 Updated by Matt Gold about 10 years ago

Got it. Thanks.

Also available in: Atom PDF