Project

General

Profile

Bug #2045

Double Post/RBE Notification

Added by Matt Gold almost 10 years ago. Updated almost 10 years ago.

Status:
Duplicate
Priority name:
Normal
Assignee:
Category name:
BuddyPress (misc)
Target version:
-
Start date:
2012-08-13
Due date:
% Done:

0%

Estimated time:

Description

Just received a notification of your reply, which looks like it was posted twice with a day separating the replies. Any idea what is going on?

History

#1 Updated by Raymond Hoh almost 10 years ago

This looks related to #2046. Very odd indeed.

Boone, can you email me the "cunyacademiccommons" Gmail account credentials?
I want to login and check out the Gmail archive to see if the info matches up.

This also appears to have happened during the time after deactivating / reactivating the plugin on production. Did anything weird happen when deactivating /reactivating? Anything in the server error logs?

Also, the RBE debug log doesn't appear to be generating. Perhaps it's a permissions problem with writing to the /wp-content/ directory? If so, maybe try defining the "BP_RBE_DEBUG_LOG_PATH" constant to the uploads directory instead to see if that will work?

define( 'BP_RBE_DEBUG_LOG_PATH', WP_CONTENT_DIR . '/blogs.dir/1/files/bp-rbe-debug.log' ); // feel free to change the log filename for privacy reasons

#2 Updated by Boone Gorges almost 10 years ago

  • Status changed from Assigned to Duplicate
  • Target version deleted (1.4.3)

This is a duplicate of #2046. The notification came through twice because I sent the email twice, not knowing why the first hadn't been sent.

Ray, I set up the log like so:

define( 'BP_RBE_DEBUG', true ); define( 'BP_RBE_DEBUG_LOG_PATH', '/var/www/html/blogs.dir/1/rbe.log' );

and I created an empty log file at that location, chmodded to 777, yet nothing seems to be recording. Have I typed something wrong?

#3 Updated by Raymond Hoh almost 10 years ago

The notification came through twice because I sent the email twice, not knowing why the first hadn't been sent.

I just checked the Gmail logs and it looks like you only sent it once at the original time. The second email doesn't exist in Gmail. This issue is somehow related to #2046.


Boone, about the debug log, try deleting the empty rbe.log entry so PHP has a chance to generate the file. It could be an owner problem:
http://stackoverflow.com/questions/5219882/no-error-log-created-on-apache#answer-5220064

I should also note that I use the error_log() function to generate the debug log at a custom location. Can you check to see if PHP has the "log_errors" option set to 1? I'm guessing this is already set to 1, but just making sure!

#4 Updated by Boone Gorges almost 10 years ago

Ray - I deleted the log file but it's not being regenerated. ls -la shows

drwxrwxr-x+    8 commons apache   4096 Aug 14 20:37 1

so I'm not sure why it's not writing.

Here's what phpinfo says about log_errors:

log_errors    On    On

Sigh :)

#5 Updated by Raymond Hoh almost 10 years ago

Hi Boone,

Try putting the define in cac-env-config.php or wp-config.php (if it isn't already). Next, deactivate the plugin and reactivate it. Deactivating and reactivating worked for me locally.

Let me know what happens!

#6 Updated by Boone Gorges almost 10 years ago

Success! http://commons.gc.cuny.edu/wp-content/blogs.dir/1/rbe.log

I've locked it down with htpasswd, as it contains potentially sensitive info. Ray, I'll email you with the creds.

Also available in: Atom PDF