Project

General

Profile

Actions

Bug #20510

closed

"Account Settings > Export Data" functionality broken since BuddyPress 12 upgrade

Added by Raymond Hoh 19 days ago. Updated 19 days ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
BuddyPress (misc)
Target version:
Start date:
2024-06-25
Due date:
% Done:

0%

Estimated time:
Deployment actions:

Description

While working on #20509, I tested the "Account Settings > Export Data" screen and found that the button that kicks off the data export was broken since we upgraded to BuddyPress 12.

The issue is the "Account Settings > Export Data" button uses AJAX and BuddyPress 12 requires that any AJAX action requiring access to BuddyPress global properties will need to register their AJAX action with them. I've going to push a commit to fix this shortly.

Actions #1

Updated by Raymond Hoh 19 days ago

  • Status changed from New to Staged for Production Release
Actions #2

Updated by Boone Gorges 19 days ago

  • Status changed from Staged for Production Release to Resolved
Actions

Also available in: Atom PDF