Project

General

Profile

Feature #212

Create a way for group members to send out email announcements

Added by Matt Gold about 12 years ago. Updated about 12 years ago.

Status:
Resolved
Priority name:
High
Assignee:
Category name:
BuddyPress (misc)
Target version:
-
Start date:
2010-05-06
Due date:
% Done:

0%

Estimated time:

Description

We need to figure something out to replace the old "email to group" functionality of the wire . .

History

#1 Updated by Chris Stein about 12 years ago

Matt, there is this plugin http://wpmu.org/buddypress-group-email/. It's different than the wire functionality. You just get a typical email form and then can send it out to the group members. In a way that is nice but the issue is that there is no record left on the group like what happened with the wire.

Another option may be to have a checkbox or something by the update for the group activity so you can send out the update to everyone by email. This is closer to what existed with the wire.

#2 Updated by Matt Gold about 12 years ago

Thanks, Chris. Boone and I had a quick chat this morning, and he is already working on a function that will create a checkbox next to the group activity updates so that they can be pushed out to members via email. I agree that it will be useful to have a record of it in the group, and I'd like to see us replicate our previous Wire set up so that members don't get confused.

#3 Updated by Boone Gorges about 12 years ago

Matt, can you give me a format for the email? Subject + content. Suggestion:
Subject:
[CUNY Academic Commons] New update in 'My Group'

Message:
Boone Gorges posted an update in "My group":

Hey, what's up?

I guess since the email is being forced there isn't much sense in putting any "to unsubscribe" stuff at the bottom?

#4 Updated by Matt Gold about 12 years ago

That format looks good, Boone. I think we should have some unsubscribe language at the bottom that tells people that that if they want to unsubscribe from these updates, they'll have to leave the group. Maybe something like this:

To unsubscribe from emailed group updates, you must leave 'My Group'.

Thoughts?

#5 Updated by Boone Gorges about 12 years ago

I guess that will do for now, but it highlights what I don't like about this kind of thing - if you don't want to get emails, leave the group. Sounds pretty aggressive to me.

#6 Updated by Matt Gold about 12 years ago

How difficult would it be to implement a "mute" button, so that members can opt-out if they want?

#7 Updated by Boone Gorges about 12 years ago

Not too hard technically, but the UX is going to get pretty confusing when the new email plugin allows for activity update subscription. If I'm signed up on the new plugin to get immediate email notification of all group activity, and I hit this hypothetical mute button, what happens? Or vice versa, if I choose not to receive email notification of new activity (I prefer digests, let's say), isn't the assumption that I'm not going to get messages like this?

#8 Updated by Matt Gold about 12 years ago

Is there any way that the email subscription plugin could detect whether or not the email updates plugin is activated, and if so and if a member has chosen to "mute all discussions," it just would unsubscribe them? Ie, is there a way for these two plugins to work together?

#9 Updated by Boone Gorges about 12 years ago

Anything can be done. My question is whether that makes sense as a final UX. If someone has actively chosen to turn off immediate email notifications for all activity in a group, which I assume will be our default setting, it seems strange to require them to "mute all discussions" as a further step so that they don't get these special emails. On the other hand, if we respect the user's initial preference not to get immediate emails of group activity, then new activity items will go to all and only those who have chosen to receive immediate emails of all activity - thus the checkbox isn't actually doing anything.

BTW, there's a working version up. Only accessible to site admins. Matt/Chris, please log in and give it a test (I've been working in the Totally Cool group, but you should be able to use it anywhere).

#10 Updated by Boone Gorges about 12 years ago

Oops, I wasn't clear in my point: what I mean is that I assume that we'll subscribe everyone to all their group activity by default, so that anytime we have a user who is less than fully subscribed, it means that they made the active decision that they didn't want to get email notifications of new activity items. Asking them to opt out a second time is a bit peculiar.

Anyway, let me know what you find with the version of the checkbox that's on the site.

#11 Updated by Matt Gold about 12 years ago

Looks great.

#12 Updated by Boone Gorges about 12 years ago

OK, I'm going to open it up for all users.

Can we put ideas for further enhancement in their own tickets, please? Thanks.

#13 Updated by Boone Gorges about 12 years ago

Quick documentation of what I did:

There are a few new functions in bp-custom.php: one that creates the checkbox below the activity box on group pages, one that handles the emailing, and one that inserts the necessary JS in the document head.

The JS is not working properly, which I believe is related to larger problems we're having with script conflicts on the site. Thus I have also made the necessary changes to the core scripts at buddypress/bp-themes/bp-default/_inc/global.js. Once the overall script problem is solved, those core modifications will be ignored and the bp-custom script should take over.

#14 Updated by Boone Gorges about 12 years ago

  • Status changed from Assigned to Reporter Feedback

Seems to be working properly - someone in a group I'm in used it yesterday. Please close the ticket if you're satisfied.

#15 Updated by Matt Gold about 12 years ago

  • Status changed from Reporter Feedback to Resolved

Also available in: Atom PDF