Project

General

Profile

Support #2206

Change anchor location for "Post New Topic" in group forums

Added by Matt Gold almost 9 years ago. Updated almost 9 years ago.

Status:
Resolved
Priority name:
Normal
Category name:
BuddyPress (misc)
Target version:
Start date:
2012-10-19
Due date:
% Done:

100%

Estimated time:

Description

Per our discussion in the team meeting today, let's move the anchor for the "Post New Topic" button above the new announcement that tells people how to post via email.

History

#1 Updated by Boone Gorges almost 9 years ago

  • Assignee changed from Boone Gorges to Dominic Giglio
  • Target version set to 1.4.9

#2 Updated by Dominic Giglio almost 9 years ago

Matt, Boone,

I wasn't at the meeting so I just wanna double check on this before I start editing templates.

I'm looking at the main forum page for our "CAC Community Team – Project Planning" group and I can see the "Post New Topic" button right below the line "Your email status is:"

The button links to the id (#post-new-topic) of the div that holds all the inputs at the bottom of the page where a new topic is created. If I understand correctly, we want to move the button down there? That doesn't make sense to me. The button takes the visitor to that section when it's clicked. If you're already down there, whats the need for the button? I'm sure I'm missing the point of this issue, could one of you explain a little more about what was discussed at the meeting? Thanks.

#3 Updated by Boone Gorges almost 9 years ago

This was sort of a cryptic description, huh? :)

Go to http://commons.gc.cuny.edu/groups/cac-community-team-project-planning/forum/. When you click Post New Topic, you're taken to #post-new-topic, as you note. But #post-new-topic is just a little bit low - it would be nice if it came before the "Post New Topics by Email" paragraph, rather than after.

That paragraph is created by BP Reply By Email, and I imagine that it's put where it is because of some limitations in the hooks included in the bp-default templates. Ray can probably say more about that. In any case, we can certainly customize the template for our own installation, whatever the case with BP more generally. Dom, let's hold off on doing anything until Ray chimes in.

#4 Updated by Dominic Giglio almost 9 years ago

I think I understand what's happening now, yes very cryptic! :-)

When clicking the button you are taken down to the div but you can't see the email instructions? They are being hidden by the toolbar.

Is that the issue here? That if a visitor clicks that button they are taken to the bottom but miss out on the email instructions from RBE?

#5 Updated by Boone Gorges almost 9 years ago

Yes, that's the issue. If the problem is that the toolbar is in the way, maybe we can just fudge it by putting some extra padding on top of the div in question.

#6 Updated by Dominic Giglio almost 9 years ago

I put 40px of padding on the top of the div and that seems to do the trick (in Safari, Firefox and Chrome).

Interestingly, adding margin did not fix the issue. Apparently anchors ignore or do not honor the margin when jumping down the page.

I've attached a screenshot so you can see what the extra padding looks like. But I will wait for Ray to chime in before committing anything.

#7 Updated by Raymond Hoh almost 9 years ago

Hi gang,

What appears to be the problem? Do we want to move the RBE "post by email" block below the post topic textarea field so the "Post New Topic" block is more prominent?

What actually would be a better enhancement is when we click on the "Post New Topic" button, the post form appears immediately below this button (using jQuery) instead of scrolling all the way down the page and relying on an anchor.

Let me know if I'm totally missing the point here!

#8 Updated by Boone Gorges almost 9 years ago

Do we want to move the RBE "post by email" block below the post topic textarea field so the "Post New Topic" block is more prominent?

No, I think the idea is that the "did you know you can post via email?" box is actually hidden given where the anchor currently is. Dom, if the extra padding fixes it, then let's go with that solution, as it's the easiest.

What actually would be a better enhancement is when we click on the "Post New Topic" button, the post form appears immediately below this button (using jQuery) instead of scrolling all the way down the page and relying on an anchor.

Javascript schmavascript :) That would be nice, but what we have now works OK. Let's go with the easy solution for today, and then revisit after moving to bbPress 2.x.

#9 Updated by Dominic Giglio almost 9 years ago

Javascript schmavascript

Best Redmine quote ever!

I'll update our css and post back here with a commit when I'm done. :-)

#10 Updated by Dominic Giglio almost 9 years ago

  • Status changed from Assigned to Resolved
  • % Done changed from 0 to 100

Added the padding. As we talked about above, this isn't an ideal fix - but we'll be redesigning the CAC theme after CBox reaches a more stable state anyways. So this should do for now.

Commit: https://github.com/castiron/cac/commit/6f2d0942f4701ee013fffd25680685c1cd8f637c

#11 Updated by Matt Gold almost 9 years ago

Thanks, guys. This looks like a good solution (and sorry for the cryptic description, which I wrote in the middle of the meeting). The problem was that people (including me!) were unaware that they could start new topics by email.

Also available in: Atom PDF