Project

General

Profile

Bug #2454

Contact Form 7 Plugin

Added by Sarah Morgano about 6 years ago. Updated almost 5 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
WordPress Plugins
Target version:
Start date:
2013-02-20
Due date:
% Done:

0%

Estimated time:

Description

One of our members recently reported having problems with the Contact Form 7 plugin on the CUNY Online Baccalaureate Writing Fellows blog: http://bacwritingfellows.commons.gc.cuny.edu/.

Here's a history of the issue:

  • Emails were going where they were supposed to go, but often didn't include the "required" email address field. Upon testing, the member discovered that when she included the email field sometimes it would and sometimes it wouldn't be included in the body of the email
  • The contact form page had two "forms" to complete
  • A few days ago, the emails stopped going to the address listed in the plugin settings and instead went to one of our Commons' gmail accounts
  • After the member disabled the plugin and removed the shortcode from the page one of the forms was removed from the page, but the bottom form still appeared

I advised the member to delete the contact page and create a new one that just included the email (not the contact form) until we determine what the issue is. I just activated the plugin on a test site and it goes to the email address I have listed in the settings, but also noticed that there are two contact forms on the page instead of one.

History

#1 Updated by Matt Gold about 6 years ago

  • Status changed from New to Assigned
  • Assignee set to Boone Gorges
  • Severity set to Normal

#2 Updated by scott voth about 6 years ago

Hi Sarah - I just tested this on the Help Wanted site where we use it, and on a brand new site on the Commons that I set up with no other plugins. I did notice that the required email field is not getting passed back in the email on both sites. I'm sure that it used to be passed back. I am still getting the emails - and I don't see the duplicated forms. That part is pretty weird. Maybe Boone can tell what's going on.

#3 Updated by Boone Gorges about 6 years ago

Sarah, could I get a link to a page that shows the multiple contact forms?

#4 Updated by Boone Gorges about 6 years ago

Scratch that request. I figured out the duplicate issue. There are a number of themes on the Commons that have Contact templates. if you're using one of these themes, and you create a page with the slug 'contact', it automatically provides contact form markup for you. When you then add a Contact Form 7 form, you get a second one.

IMO this is a confusing theme feature, but in any case not really a bug.

I'll continue to investigate the other issues.

#5 Updated by Boone Gorges about 6 years ago

  • Status changed from Assigned to Reporter Feedback
  • Target version set to 1.4.21

I just tested and here's the email sent:

From: Boone Gorges <boone@gorg.es>
Subject: oeurhcoeu

Message Body:
rchrch

--
This mail is sent via contact form on CUNY Pie http://cunypie.local.cicdev.com

The email shows up in corner brackets after the name. Is this not what's expected?

#6 Updated by Boone Gorges about 6 years ago

  • Target version changed from 1.4.21 to 1.4.22

#7 Updated by Boone Gorges about 6 years ago

  • Target version changed from 1.4.22 to 1.4.23

#8 Updated by Boone Gorges about 6 years ago

  • Target version changed from 1.4.23 to 1.4.24

#9 Updated by Boone Gorges about 6 years ago

  • Target version changed from 1.4.24 to 1.4.25

#10 Updated by Boone Gorges almost 6 years ago

  • Target version changed from 1.4.25 to 1.4.26

#11 Updated by Boone Gorges almost 6 years ago

  • Target version changed from 1.4.26 to 1.4.27

#12 Updated by Boone Gorges almost 6 years ago

  • Target version changed from 1.4.27 to 1.4.28

#13 Updated by Boone Gorges almost 6 years ago

  • Target version changed from 1.4.28 to 1.4.29

#14 Updated by Boone Gorges almost 6 years ago

  • Target version changed from 1.4.29 to 1.4.30

#15 Updated by Boone Gorges almost 6 years ago

  • Target version changed from 1.4.30 to 1.4.31

#16 Updated by Micki Kaufman almost 6 years ago

Hi Sarah - can you verify this is still an open issue? We are having trouble duplicating the error. Thanks!

#17 Updated by Sarah Morgano almost 6 years ago

I just tested this on the Commons Team Testing blog and the email didn't come through even though it was a required field. This is what I received:

From: Sarah
Subject: bah

Message Body:
kldjfksldfjsdl

--
This mail is sent via contact form on Commons Team Testing http://commonsteamtesting.commons.gc.cuny.edu

#18 Updated by Boone Gorges almost 6 years ago

  • Target version changed from 1.4.31 to 1.4.32

#19 Updated by Boone Gorges over 5 years ago

  • Target version changed from 1.4.32 to 135

#20 Updated by Boone Gorges over 5 years ago

  • Target version changed from 135 to 1.5.1

#21 Updated by Boone Gorges over 5 years ago

  • Target version changed from 1.5.1 to 1.5.2

#22 Updated by Boone Gorges over 5 years ago

  • Target version changed from 1.5.2 to 1.5.3

#23 Updated by Boone Gorges over 5 years ago

  • Target version changed from 1.5.3 to 1.5.4

#24 Updated by Boone Gorges over 5 years ago

  • Target version changed from 1.5.4 to 1.5.5

#25 Updated by Boone Gorges over 5 years ago

  • Target version changed from 1.5.5 to 1.5.6

#26 Updated by Boone Gorges over 5 years ago

  • Target version changed from 1.5.6 to 1.5.7

#27 Updated by Boone Gorges over 5 years ago

  • Target version changed from 1.5.7 to 1.5.8

#28 Updated by Boone Gorges over 5 years ago

  • Target version changed from 1.5.8 to Not tracked

Sorry for the delay on this. I spent some time tonight and I think I tracked down the issue.

Basically, Contact Form 7 is working as expected. If you look at the source of a message sent via the contact form, the email address is showing up, in corner-brackets, where it's supposed to. The issue is that mail clients see an email address between corner brackets and interpret it as a piece of markup, which doesn't display properly in the body of an email. If, on the other hand, you escape the brackets like I've done in the "Message body" section here: http://commonsteamtesting.commons.gc.cuny.edu/wp-admin/admin.php?page=wpcf7&message=saved&post=18, it works as expected.

Can you play with this and see if you find the same thing?

#29 Updated by Boone Gorges almost 5 years ago

  • Category name changed from WordPress (misc) to WordPress Plugins
  • Status changed from Reporter Feedback to Resolved

Going to close this ticket as resolved, based on my workaround posted above. Sarah, if you still find that you're having troubles, please feel free to reopen with details.

Also available in: Atom PDF