Project

General

Profile

Bug #2484

Forum posts are vanishing - can only view last few on Help & Support

Added by scott voth about 9 years ago. Updated about 9 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
commonsinabox.org
Target version:
-
Start date:
2013-02-27
Due date:
% Done:

0%

Estimated time:

Description

Hi - Three members of CBOX community have noticed that the forum posts on Help & Support are only displaying the last couple replies (or in some cases, only the last reply). I have an admin account, and when I am logged in, everything looks good. But when I log out, I am seeing what they are reporting. Apparently, this is only happening on commonsinabox.org - according to the members - their personal sites are okay.

The three members confirm that whether they are logged in or logged out, they have this strange issue.

History

#1 Updated by Matt Gold about 9 years ago

  • Status changed from New to Assigned
  • Assignee set to Boone Gorges

#2 Updated by Boone Gorges about 9 years ago

  • Status changed from Assigned to Reporter Feedback

Scott, can you please post some details? Topic URLs, etc.

#3 Updated by scott voth about 9 years ago

Hi Boone - Sorry took so long to get back to you on this. It was happening on pretty much every Forum topic that I went to on Help & Support last night. Ray looked at it (see - http://commonsinabox.org/groups/help-support/forum/topic/cant-see-any-of-the-first-pots-on-this-forum/ ) and he did something that he didn't think worked, but I'm wondering if he actually did fix the issue. When I go to Help & Support, everything seems to be fine, both when I am logged in and logged out.

One member on the forum today said he'd seen this weirdness on his own site.

#4 Updated by scott voth about 9 years ago

Actually, the more I look at it - I still see the issue. See http://commonsinabox.org/groups/help-support/forum/topic/cant-see-any-of-the-first-pots-on-this-forum/
When I am logged on - I see the first post (by Helene). When I am logged out - I don't see the first post - but see all the subsequent ones (starting with Dave).

Last night it was much more noticeable, with more entries missing.

#5 Updated by Boone Gorges about 9 years ago

Ray, what do you know about this?

#6 Updated by Boone Gorges about 9 years ago

  • Status changed from Reporter Feedback to Resolved

On commonsinabox.org, this was being caused by an out-of-date version of BuddyPress Docs. There was one minor release of Docs where there were conflicts between its access control filters and the filter in bbPress that allows a topic post to show up alongside its replies. It just so happened that this version of Docs was the one pinned in Commons In A Box 1.0, which commonsinabox.org was running. I upgraded everything to the latest, and it's working properly now.

For reference, the relevant Docs changesets are:
- https://github.com/boonebgorges/buddypress-docs/commit/50ee8d1db781d54e91dcd71376a1bb8f3c3be585
- https://github.com/boonebgorges/buddypress-docs/commit/7d357d59bb3dcf8fc58b581dd5ae780448c0f069

#7 Updated by Matt Gold about 9 years ago

Thanks, Boone.

Also available in: Atom PDF