Project

General

Profile

Feature #2528

BP emails sent from secondary sites should use main site headers

Added by Matt Gold about 6 years ago. Updated almost 6 years ago.

Status:
Resolved
Priority name:
Low
Assignee:
Category name:
BuddyPress (misc)
Target version:
Start date:
2013-04-01
Due date:
% Done:

100%

Estimated time:

Description

I received the following email notification, which lists the alias for the CUNY Academic Commons address as the GC English Students Association. Any idea what is going on? Please see below for the full email header

from: Graduate Center English Student Association (ESA) <>
to:
date: Fri, Mar 29, 2013 at 1:41 PM
subject: Amanda Licastro added the event "Experiements in Design Fiction" to Digital Humanities Initiative. [CUNY Academic Commons]
mailed-by: gc.cuny.edu

Amanda Licastro added the event "Experiements in Design Fiction" to Digital Humanities Initiative.

To view or reply, log in and go to:
http://commons.gc.cuny.edu/groups/digital-humanities-initiative/

---------------------
To disable all notifications for this group, click: http://commons.gc.cuny.edu/members/admin/?bpass-action=unsubscribe&group=0&access_key=a7a877755beef11ed3234e0890fce6bd

Your email setting for this group is: All Email

FULL EMAIL HEADERS:

Delivered-To:
Received: by 10.182.144.35 with SMTP id sj3csp2856obb;
Fri, 29 Mar 2013 10:41:18 -0700 (PDT)
X-Received: by 10.52.72.67 with SMTP id b3mr2138425vdv.14.1364578878442;
Fri, 29 Mar 2013 10:41:18 -0700 (PDT)
Return-Path: <>
Received: from proofagent.gc.cuny.edu (proofagent.gc.cuny.edu. [146.96.128.224])
by mx.google.com with ESMTPS id a1si3956091vdk.47.2013.03.29.10.41.18
(version=TLSv1 cipher=RC4-SHA bits=128/128);
Fri, 29 Mar 2013 10:41:18 -0700 (PDT)
Received-SPF: pass (google.com: domain of designates 146.96.128.224 as permitted sender) client-ip=146.96.128.224;
Authentication-Results: mx.google.com;
spf=pass (google.com: domain of designates 146.96.128.224 as permitted sender) smtp.mail=
Received: from outmail.gc.cuny.edu (wa10a.gc.cuny.edu [172.29.28.89])
by proofagent.gc.cuny.edu (8.13.8/8.13.8) with ESMTP id r2THfHx3009614
for <>; Fri, 29 Mar 2013 13:41:17 -0400
Received: from commons.gc.cuny.edu (146.96.128.200) by WA10A.gc.cuny.edu
(172.29.28.89) with Microsoft SMTP Server id 8.3.298.1; Fri, 29 Mar 2013
13:41:17 -0400
Received: by commons.gc.cuny.edu (Postfix, from userid 48) id 23865174890;
Fri, 29 Mar 2013 13:41:17 -0400 (EDT)
To: <>
Subject: Amanda Licastro added the event "Experiements in Design Fiction" to Digital Humanities Initiative. [CUNY Academic Commons]
X-PHP-Originating-Script: 500:class-phpmailer.php
Date: Fri, 29 Mar 2013 17:41:17 +0000
From: "Graduate Center English Student Association (ESA)"
<>
Message-ID: <>
X-Priority: 3
X-Mailer: PHPMailer 5.2.1 (http://code.google.com/a/apache-extras.org/p/phpmailer/)
MIME-Version: 1.0
Content-Transfer-Encoding: 8bit
Content-Type: text/plain; charset="UTF-8"
X-Proofpoint-Virus-Version: vendor=fsecure engine=2.50.10432:5.10.8626,1.0.431,0.0.0000
definitions=2013-03-29_08:2013-03-29,2013-03-29,1970-01-01 signatures=0
X-Proofpoint-Spam-Details: rule=outbound_notspam policy=outbound score=0 spamscore=0 ipscore=0
suspectscore=4 phishscore=0 bulkscore=27 adultscore=0 classifier=spam
adjust=0 reason=mlx scancount=1 engine=6.0.2-1211240000
definitions=main-1303290174

Amanda Licastro added the event "Experiements in Design Fiction" to Digital Humanities Initiative.

To view or reply, log in and go to:
http://commons.gc.cuny.edu/groups/digital-humanities-initiative/

---------------------
To disable all notifications for this group, click: http://commons.gc.cuny.edu/members/admin/?bpass-action=unsubscribe&group=0&access_key=a7a877755beef11ed3234e0890fce6bd

Your email setting for this group is: All Email

Screen shot 2013-04-09 at 12.20.37 PM.png (41.9 KB) Screen shot 2013-04-09 at 12.20.37 PM.png Matt Gold, 2013-04-09 12:21 PM
2013-04-09 18-01-46.png (55.2 KB) 2013-04-09 18-01-46.png Raymond Hoh, 2013-04-09 09:02 PM

History

#1 Updated by local admin about 6 years ago

The server does b=not force a particular from: header. I'm afraid this may be an application level issue. I would recommend re-assigning to the dev team, while I'll remain on stand-by to help troubleshoot.

#2 Updated by Matt Gold about 6 years ago

  • Assignee changed from local admin to Boone Gorges

Okay -- thanks, Andre. Reassigning to Boone. Not a huge deal, but may be worth a quick look.

#3 Updated by Matt Gold about 6 years ago

  • Category name changed from Server to WordPress (misc)

#4 Updated by Boone Gorges about 6 years ago

  • Category name changed from WordPress (misc) to BuddyPress (misc)
  • Assignee changed from Boone Gorges to Raymond Hoh
  • Target version set to 1.4.24

I assume that the email header is being set as such because the "event" object was originally added at http://gcenglish.commons.gc.cuny.edu/events/experiements-in-design-fiction/. If so, the email header is behaving as expected. The real question is why that event was added to the activity stream of the DHI group at all. Ray, assigning this to you for now, though I'll have a look if you don't get a chance.

#5 Updated by Matt Gold about 6 years ago

Interesting -- this just happened again. Please see the attached screenshot of an email notification.

#6 Updated by Raymond Hoh about 6 years ago

Boone Gorges wrote:

The real question is why that event was added to the activity stream of the DHI group at all.

The Events Manager plugin has some type of BuddyPress integration. It's quite possible that there is a conflict happening somewhere.

Matt, would it be possible to ask Amanda how she created this event with complete steps to duplicate?

#7 Updated by Matt Gold about 6 years ago

Sure thing.

#8 Updated by Raymond Hoh about 6 years ago

Hi Matt,

I took a closer look at the Events Manager plugin.

It is quite possible that Amanda selected a group when creating an event from the admin area. See the attached screenshot.

If that is the case, then that is how the event got added to the BP group.

#9 Updated by Matt Gold about 6 years ago

Hi Ray --

from Amanda:

for both the Kraus and Dwyer events I simply filled out this form:

http://gcenglish.commons.gc.cuny.edu/submit-an-event/

Exactly as indicated.

#10 Updated by Raymond Hoh about 6 years ago

I don't have access to that form, but I've checked my local install of Events Manager and there is a field to attach an event to a BP group, so this is working as intended by the plugin.

As for the "From" name, we made the decision to allow sub-sites to use their own site name in #2152.

How do we want to address this?

#11 Updated by Boone Gorges about 6 years ago

  • Tracker changed from Bug to Feature
  • Subject changed from Confusing Email Header to BP emails sent from secondary sites should use main site headers
  • Target version changed from 1.4.24 to 1.5

Thanks, Ray.

The form at http://gcenglish.commons.gc.cuny.edu/submit-an-event/ has a group selection dropdown. Though Amanda's terse description of the steps she went through doesn't mention selecting an item from this dropdown, I'm assuming that she did. So the plugin is working as expected.

As for the email headers, we have a blanket function that is designed to allow secondary sites (sites other than the main commons.gc.cuny.edu) to define their own email headers. Since the event creation is taking place in the context of the secondary blog, we use the name of the current blog, which in this case is the GC ESA.

I guess in theory, it'd be nice for us to be a little more discriminating about this: any BP email, whether sent from a secondary blog or the main blog, should have commons.gc.cuny.edu headers. But it's not obvious to me how to make this happen in a non-obtrusive way. Since it's a minor issue, I'm moving this to the 1.5 milestone for further discussion.

#12 Updated by Micki Kaufman almost 6 years ago

Hi Ray: can you chime in with your decision on this issue? We want to include a fix for this in the upcoming major release and need to make a decision soon. Thanks!

#13 Updated by Raymond Hoh almost 6 years ago

I guess in theory, it'd be nice for us to be a little more discriminating about this: any BP email, whether sent from a secondary blog or the main blog, should have commons.gc.cuny.edu headers. But it's not obvious to me how to make this happen in a non-obtrusive way.

Agreed.

The only thing I can think of is overriding the "From" name when Event Manager adds a group activity event. Let me know what you think, Boone.

#14 Updated by Boone Gorges almost 6 years ago

The only thing I can think of is overriding the "From" name when Event Manager adds a group activity event.

Yeah, I suppose this sounds fine. I think Events Manager is the only plugin that's causing this, so we may as well have a targeted solution. Could I ask you to have a look and see if there is an obvious place to hook into EM's process to make the change? If it seems like it's going to be complicated, let me know and we can consider moving it to the next major release.

#15 Updated by Raymond Hoh almost 6 years ago

  • % Done changed from 0 to 100

Fixed in commit 7c82d00.

Boone, I put the commit in 1.4.x branch because all email-related hooks were in 1.4.x and not in the master branch.

#16 Updated by Raymond Hoh almost 6 years ago

  • Status changed from Assigned to Resolved

Applied in changeset commit:7c82d00ec29e89f389114f377e94c4fdfce3e877.

#17 Updated by Boone Gorges almost 6 years ago

  • Target version changed from 1.5 to 1.4.31

Also available in: Atom PDF