Project

General

Profile

Bug #2583

New group blog post not appearing on home page activity

Added by Sarah Morgano about 6 years ago. Updated about 6 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
BuddyPress (misc)
Target version:
Start date:
2013-05-20
Due date:
% Done:

0%

Estimated time:

Description

Hi,

I just published a group blog post (switching from private to public) and noticed that it's not appearing on the homepage activity feed. I then deleted the post and tried to start over by making a new post public initially, but it's still not appearing on the home page. It's does, however, appear multiple times on the News page: http://spsnewsandnotes.commons.gc.cuny.edu/2013/05/20/2013-eportfolio-student-showcase/ and it seems that email notifications are being send to the group each time the blog post is updated (the two posts have generated 5 activity emails to the CUNY SPS group).

Best,
Sarah

History

#1 Updated by Matt Gold about 6 years ago

  • Status changed from New to Assigned
  • Assignee set to Boone Gorges

#2 Updated by Sarah Morgano about 6 years ago

As an update:

I just published a post that I've been editing in private and it appears on the "News" activity page, but does not appear on the Home page: http://connections.commons.gc.cuny.edu/2013/05/21/retweets-of-the-week-may-13-19-2013/

#3 Updated by Sarah Morgano about 6 years ago

Arg, sorry I just noticed that I had the blog coupled with a private group. Just uncoupled. That's probably what the whole issue is because the SPS News and Notes blog is also coupled to a private group. I thought that the blog settings would override the group privacy settings, but I guess it just blocks it from appearing on the home page.

#4 Updated by Boone Gorges about 6 years ago

  • Status changed from Assigned to Reporter Feedback
  • Target version set to Not tracked

Yeah, I think the way that we have the groupblog stuff cobbled together, the groupblog privacy settings take precedence.

Does this mean that the issue is resolved, Sarah?

#5 Updated by Sarah Morgano about 6 years ago

The main issue I reported I believe is resolved, but there is still the issue of multiple email notifications being sent when/if a group blog post is updated. I'm going to do some more testing and if I find that to be the case then I will open a new ticket.

#6 Updated by Sarah Morgano about 6 years ago

  • Status changed from Reporter Feedback to New

Hi Boone,

I think we need to open this back up, here's a report that Jill Cirasella just sent:

I’m writing with an odd question, possibly a bug report. I wrote two blog posts on the OA CUNY blog this week, and I don’t believe either one ever showed up in the Recent Blog Posts section of the Commons homepage. (For example, the newest post (http://openaccess.commons.gc.cuny.edu/2013/06/20/emerald-not-so-sparkling-green/) appeared this morning, and right now the Recent Blog Posts section features posts that appeared both before and after mine.) I remember that our posts have shown up there in the past, and I really appreciated having the posts spend some time there. Are only certain blogs highlighted in that section, and has the OA CUNY blog fallen out of favor as something for the front page? Or is there maybe a bug?

#7 Updated by Sarah Morgano about 6 years ago

Not sure, but could this be related to #2564?

#8 Updated by Boone Gorges about 6 years ago

  • Category name set to BuddyPress (misc)
  • Status changed from New to Assigned
  • Target version changed from Not tracked to 1.4.31

I may be mistaken, but it looks like the code for the Recent Blog Posts widget will never display groupblog posts. It looks like this goes back to https://github.com/boonebgorges/bp-groupblog/commit/a53a46e819b7e3a84ddeee4ac3bd9330c80ed388#bp-groupblog.php, which was included in CAC in https://github.com/castiron/cac/commit/9cda6f9b89d7ff534f247c1d4398dd8c88494800#wp-content/plugins/bp-groupblog.

I'll have to refactor this widget a bit to include these blog posts.

#9 Updated by Sarah Morgano about 6 years ago

I definitely remember that they used to appear on the homepage. If it's possible to enable that again it would be great because there are a lot of great posts from group blogs (CUNY Games, Open Access, etc.) that can now only be viewed through the News tab.

#10 Updated by Boone Gorges about 6 years ago

  • Status changed from Assigned to Resolved

This should be fixed in https://github.com/castiron/cac/commit/dfbfc63471efe5820ad3eac95dbcb2f5d547466f. I'll check after deployment.

#11 Updated by Sarah Morgano about 6 years ago

Thanks Boone, I'll pass this information along to Jill.

Also available in: Atom PDF