Project

General

Profile

Bug #2564

Editing blog posts connected to groups creates activity item/notification

Added by Matt Gold over 8 years ago. Updated about 8 years ago.

Status:
Resolved
Priority name:
High
Assignee:
Category name:
WordPress (misc)
Target version:
Start date:
2013-05-06
Due date:
% Done:

0%

Estimated time:

Description

Report from Marilynn Johnson:

I've noticed lately that when I edit posts on my commons site it posts them on the group page (and emails all subscribed members) as if it were a new post See: http://commons.gc.cuny.edu/groups/philosophy-562225957/. This is confusing and annoying for people who are getting information twice, often information about events that have passed. Is this something that has a quick fix or should I post it on redmine?


Related issues

Related to CUNY Academic Commons - Bug #2958: Commons Erroneous New Post AlertRejected2014-01-12

Related to CUNY Academic Commons - Support #5877: Group Sites -> Activity Stream LimitsResolved2016-08-08

History

#1 Updated by Boone Gorges over 8 years ago

  • Status changed from Assigned to Reporter Feedback
  • Target version set to 1.4.28

Hi Marilynn - I don't see duplicate activity items in your group. Have you deleted them manually?

I tried reproducing the behavior you've described, but I can't do it. There is a check in place that is designed to prevent the kind of duplicate posting that you're reporting here, and I can't seem to bypass it. Can you give more details about the specific posts that caused the problems?

#2 Updated by Sarah Morgano over 8 years ago

I just came across this ticket and this is exactly what I experienced yesterday with the SPS group. I'll do some testing tonight and update this ticket accordingly.

#3 Updated by Boone Gorges over 8 years ago

  • Target version changed from 1.4.28 to 1.4.29

Thanks, Sarah.

#4 Updated by Sarah Morgano over 8 years ago

Hi, Boone. I tested it on another group blog and received two email notifications for the same blog post, the first at 11:18 and the second at 11:20. I've attached screenshots of the two edit screens -- not sure if it's relevant but since I looked up how to take screenshots with a Mac I figured that I would include them...

P.S.: Command-Shift-3 : )

#5 Updated by Boone Gorges over 8 years ago

  • Status changed from Reporter Feedback to Assigned
  • Target version changed from 1.4.29 to 1.4.30

Ray - Bringing you in as a watcher. I seem to recall that you fixed an issue in GES that prevented edited activity items from triggering additional email notifications. Is that correct? If so, can you point me toward it, so I can take a look at how it's not playing nicely with bp-groupblog?

#6 Updated by Boone Gorges over 8 years ago

  • Target version changed from 1.4.30 to 1.4.31

#7 Updated by Marilynn Johnson over 8 years ago

Has there been any update on this? I got an email from a faculty member this week asking what was wrong with the updates since he got emailed 5 times on a post I edited. You can see the repeat posts/emails here: http://commons.gc.cuny.edu/groups/philosophy-562225957/ Thanks!

#8 Updated by Marilynn Johnson over 8 years ago

(And to answer your question from earlier, yes I had been deleting the repeat posts but left them up now so you can see the problem.)

#9 Updated by Raymond Hoh over 8 years ago

Sorry, I missed this ticket.

I seem to recall that you fixed an issue in GES that prevented edited activity items from triggering additional email notifications. Is that correct? If so, can you point me toward it, so I can take a look at how it's not playing nicely with bp-groupblog?

Yes, I added a code snippet to GES that checks if an activity ID is already passed when saving an activity entry, if so, I stop GES from attempting to record / send the group email:
https://github.com/boonebgorges/buddypress-group-email-subscription/blob/master/bp-activity-subscription-functions.php#L496

I'm guessing the problem has to do with bp-groupblog not passing the original activity ID, which is why it's creating a new activity entry each time.

I'll take a closer look.

#10 Updated by Raymond Hoh over 8 years ago

Boone, I've opened a pull request in the bp-groupblog repo, which fixes this issue.

Let me know what you think when you've taken a look.

#11 Updated by Boone Gorges over 8 years ago

  • Status changed from Assigned to Resolved

Thanks, Ray. Your change looks good to me. I've released a new version of bp-groupblog, and updated the Commons to the new version in https://github.com/castiron/cac/commit/28bd6daec3a88d519da11a6b0879e35f4cb94471

#12 Updated by Marilynn Johnson over 8 years ago

Hi Ray & Boone! Thanks for your work on this. Although I am still having the same problem on my philosophy.commons.gc.cuny.edu site. Edits are still being treated like new posts, with emails sent out every time. See here for examples: http://commons.gc.cuny.edu/groups/philosophy-562225957/ You can see that for a number of the so-called "new" posts (CFP: Cognitive Penetration of Perception, Philosophy Department Newsletter 2012-2013, etc) small edits were made. Everyone with a group email subscription is emailed each time an edit is made. I have received complaints from faculty members about getting slammed with emails. Please let me know if I am not being clear about what the issue is. I hope we can get this sorted out soon. Thanks again!

#13 Updated by Matt Gold over 8 years ago

  • Priority name changed from Normal to High

#14 Updated by Matt Gold over 8 years ago

  • Status changed from Resolved to Assigned
  • Target version changed from 1.4.31 to 1.4.32

#15 Updated by Raymond Hoh over 8 years ago

I just took a look at the Philosophy group and it appears this is working.

The recent CAC update occurred on July 11th and since then only one post was edited:

Philosophy Teaching Resource | Enlightened Educators - http://philosophy.commons.gc.cuny.edu/philosophy-teaching-resource-enlightened-educators/

Which was edited yesterday and only one activity item exists. This item should not have been sent by the Group Email Subscription plugin. Let me know if it did.

Just to reiterate: Any edit to a blog post from July 11th and on should not result in duplicate activity entries / group emails.

#16 Updated by Sarah Morgano over 8 years ago

I just tested this as well and it seems to be fixed, I edited a group blog post and only received one notification. It also appeared on the homepage (yay)!

#17 Updated by Marilynn Johnson about 8 years ago

Hi Ray. I see! I think I misunderstood - I thought the change was effective immediately - but it was made internally and then enacted in the July 11 update? It seems to be working perfectly now. Thanks so much for your work on this!

#18 Updated by Matt Gold about 8 years ago

  • Status changed from Assigned to Resolved

Glad to hear that!

Also available in: Atom PDF