Project

General

Profile

Actions

Bug #2629

closed

images not showing in slider on homepage

Added by Matt Gold over 9 years ago. Updated about 9 years ago.

Status:
Rejected
Priority name:
Urgent
Assignee:
Category name:
WordPress (misc)
Target version:
Start date:
2013-06-13
Due date:
% Done:

0%

Estimated time:

Description

related to recent work on image caching?


Files

Actions #1

Updated by Matt Gold over 9 years ago

added Ray as a watcher

Actions #3

Updated by Boone Gorges over 9 years ago

  • Assignee changed from Boone Gorges to Raymond Hoh

They're loading for me. But there is a lag, which would be made worse if you're on a slow connection.

Ray, right now the lazy loading works by only loading the image once the <img> is made visible. That is fine for avatars, but results in a jarring experience for the slider. Can we change it so that (a) the first image is loaded along with the rest of the DOM (ie, not lazy loaded it all), and (b) the subsequent images are loaded immediately after the document is ready, instead of waiting until they're displayed?

Actions #4

Updated by Raymond Hoh over 9 years ago

  • Assignee changed from Raymond Hoh to Boone Gorges

Loads for me as well.

You're right that there would be a lag on a slow connection.

I think loading the first image in the slider makes sense. However, the rest of the slider images should use the placeholder otherwise this kind of defeats the purpose of lazyloading.

Actions #5

Updated by Raymond Hoh over 9 years ago

  • Assignee changed from Boone Gorges to Raymond Hoh

Oops, re-assigning back to me.

Actions #6

Updated by Raymond Hoh over 9 years ago

Commit a49a250 excludes lazyloading for the first slider image.

Let me know if that is enough to resolve this issue.

Actions #7

Updated by Boone Gorges over 9 years ago

Thanks, Ray. I'll look at this change as soon as I get a chance. In terms of the remaining images, I was thinking more something like "Delayed Loading of Images" or "Event to Trigger Loading" on the docs pages of the lazyload plugin: http://www.appelsiini.net/projects/lazyload In other words, trigger the swapout of all of the slides' placeholders before they are displayed.

Actions #8

Updated by local admin over 9 years ago

FWIW i'm seeing the same problem with the loading of the slider. tested it on a PC running Chrome, Firefox, Safari.
Chrome -- had to force refresh to make images show
Firefox -- showed gray between images
Safari -- showed gray between images
although i'm on wifi, the connection is pretty fast (have turbo internet).

Actions #9

Updated by Matt Gold over 9 years ago

My original ticket was filed from a site where I was over a pretty fast wifi network (didn't measure speed, but other sites seemed to load relatively quickly). Back here at the GC on a wired connection, the Commons slider seems to be loading fine, even though I did see a brief flash of gray background even then.

Actions #10

Updated by Raymond Hoh over 9 years ago

In terms of the remaining images, I was thinking more something like "Delayed Loading of Images" or "Event to Trigger Loading"

I'm already using "Event to Trigger Loading". When the slide comes into view, it loads the corresponding image. I guess we could preload the next image as well to prevent the gray placeholder from showing up for the next image.

showed gray between images

even though I did see a brief flash of gray background even then.

The brief flash of gray is intentional when using lazyloading. We use a placeholder gray image for the background, when the slider image is supposed to show, it is loaded and then replaces the gray image.

If we don't like gray as a placeholder, it can be white.

Actions #11

Updated by Matt Gold over 9 years ago

If we don't like gray as a placeholder, it can be white.

No, that's fine -- the problem is just when they don't load. Maybe we should put this on hold and see whether anyone else reports the issue or whether other members of the team experience this.

Actions #12

Updated by scott voth over 9 years ago

I noticed it today, using Chrome. I switched to Firefox, which was fine. Then switched back to Chrome in same browser session - still no images. Closed and reopened Chrome, and all images loaded fine. I was using Windows on a WiFi connection.

Actions #13

Updated by Boone Gorges about 9 years ago

  • Target version set to 1.5

Is this still an issue? I haven't heard any reports.

Actions #14

Updated by Matt Gold about 9 years ago

  • Status changed from Assigned to Rejected

Haven't noticed it. Let's reject for now and reopen if it occurs again.

Actions

Also available in: Atom PDF