Project

General

Profile

Bug #2706

Problem sending group invitations

Added by Matt Gold about 8 years ago. Updated over 7 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
BuddyPress (misc)
Target version:
Start date:
2013-08-20
Due date:
% Done:

0%

Estimated time:

Description

I've been hearing a few reports here and there about problems sending group invites, but I just had it confirmed: a member created a hidden group (Comps Graders) and invited people to it; they say they never received the invitation. The member invited me to the group just now, and I didn't receive an invite. Sounds like something is definitely up.

Giving this a high priority considering the nature of the problem and the time of year, when many people will start using the Commons again and inviting people to groups. Thanks in advance for your quick attention to this.

export (2).pdf (13.6 KB) export (2).pdf Matt Gold, 2013-08-22 03:24 PM

Related issues

Related to CUNY Academic Commons - Bug #2691: Problems inviting members to a groupRejected2013-08-09

Related to CUNY Academic Commons - Bug #2952: Group Invite ErrorResolved2014-01-06

History

#1 Updated by Boone Gorges about 8 years ago

Ray, I'm adding you as a watcher in case you have free time today to look at this. If not, I'll get to it sometime tomorrow.

#2 Updated by Boone Gorges about 8 years ago

  • Status changed from Assigned to Reporter Feedback

I've spent some time with this, and can say the following:

1) I've confirmed that, in the case of the Comps Graders group, no invitations were sent. None are stored in the database.
2) I've been unable to reproduce the issue. I've tried with a number of different group configs and user types, and invitations seem to be working correctly in all cases.

It's possible that this is due to user error. Has the user given you any details about how they attempted to send the invitations?

#3 Updated by Matt Gold about 8 years ago

She said she used the regular send invites interface. And I just got another report from George that I'll forward to you via email.

#4 Updated by Boone Gorges about 8 years ago

Thanks. As you note, it looks like the report from George is unrelated to this.

I'm not sure how to progress with the bug at hand. I'm still not certain that there is not a user issue at work here - "she used the regular send invites interface" could subsume a number of different kinds of missed clicks, etc. (Not blaming anyone, just trying to rule things out.) If there's any other pattern to the reports you've gotten, please share, as I'll need any information I can get.

#5 Updated by Matt Gold about 8 years ago

Okay. Just tested myself and received an invite to a hidden group (you should have received one, too). Tomorrow, I'll see if I can watch the user as she invites people to the group so that I can get a better sense of what is going on. Will report back.

#6 Updated by Boone Gorges about 8 years ago

  • Target version set to Not tracked

#7 Updated by Matt Gold about 8 years ago

Okay - I just sat down with the user in question and watched her try to invite people to a group. The process totally failed in IE: autocomplete in the member list did not work at all; clicking manually on a checkbox next to a user's name did not result in that user being added to the list of invitees on the righthand column; as a result, no one was invited when the user clicked "send invites."

Other problems we noted on IE (may require new tickets):

-- in the list of users, not all entries had checkboxes next to them
-- alphabetical ordering of user names was not consistent

We tried to add a user to the group on the same computer using Firefox and everything worked without a flaw.

The user's configuration is attached. The specific version of IE is 9.0.811216421

The problem is that this Windows environment + IE represents what might be the default environment of users at the GC

#8 Updated by Matt Gold over 7 years ago

  • Status changed from Reporter Feedback to Assigned
  • Target version changed from Not tracked to 1.6.3

Marilyn, can you please look through this ticket and test on a GC web environment in IE? Many thanks.

#9 Updated by Marilyn Weber over 7 years ago

Ok Matt, just invited you to the History group from IE browser within GC.

#10 Updated by Matt Gold over 7 years ago

Thanks, Marilyn. I received the invitation. Did you experience any problems? Weirdly, I received two invites

And is that a hidden group? If not, can you create a hidden group and invite me to it? Thanks

#11 Updated by Boone Gorges over 7 years ago

  • Assignee changed from Boone Gorges to Marilyn Weber
  • Target version changed from 1.6.3 to 1.6.4

Reassigning this to Marilyn to verify and reproduce.

#12 Updated by Marilyn Weber over 7 years ago

Matt -

I had sent you an invite from "Test Hidden Group". Did you receive it? If you did, I think this can be closed.

#13 Updated by Matt Gold over 7 years ago

  • Status changed from Assigned to Resolved
  • Assignee changed from Marilyn Weber to Boone Gorges

> I had sent you an invite from "Test Hidden Group". Did you receive it? If you did, I think this can be closed.

I did indeed receive it! Thank you. I am closing this ticket, but please reopen or start a new ticket if you notice anything amiss as we move forward.

Also available in: Atom PDF