Project

General

Profile

Bug #2733

Address UX issues in Profile submenu on admin bar

Added by Matt Gold about 8 years ago. Updated over 7 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
Public Portfolio
Target version:
Start date:
2013-08-25
Due date:
% Done:

0%

Estimated time:

Description

Per ticket - http://redmine.gc.cuny.edu/issues/2727 - The issue brought up in the meeting was as UX issue -- the member in question did not realize that clicking on his avatar in the admin bar would lead him to his profile. So, he thought he couldn't get to his profile because when we went to the dropdown and clicked on "My Profile," nothing happened (because the third-level nav that would lead to an "Edit" link didn't work).

In advance of fixing the 3rd level nav issue, can we make "My Profile" a link to the user's profile? Or address this in some other way? When I asked the user at the meeting whether he thought it was intuitive that clicking on his avatar would lead to his profile page, he said "no," and I heard a few voices sound strong agreement.

Assigning to Chris for UX issues, and then later we can assign to Boone for implementation.


Related issues

Related to CUNY Academic Commons - Bug #2837: Interface Issues on Touch DevicesResolved2013-10-18

History

#1 Updated by Chris Stein about 8 years ago

I've looked into this a little bit and I think that if we solve #2699 then this will be solved as well. Right now when you first click your avatar on a tablet the dropdown menu shows. That is fine. The problem is that when you try to click any of the items in the drop down navigation nothing happens. My Profile is linked to take you to your profile (and the 3rd level links are correct as well) but on a tablet clicking the links gives you no response.

What happens next I think is that people then click their avatar again with the dropdown open. When they do that then it takes them to their edit profile page. That is the non-intuitive behavior they were describing. Probably what they were expecting is that clicking a second time on the avatar would pull the dropdown back up (since clicking it the first time pulled it down).

The UX change I would recommend is that clicking once on the avatar moved the menu down and clicking another time moved it back up. But I'm not sure we have direct control over that unless we rewrite the code for the dropdown. So it seems we should look into #2699 first. I'll post a few thoughts there too.

#2 Updated by Matt Gold about 8 years ago

Cool - thanks, Chris. What you've posted sounds right to me.

#3 Updated by Boone Gorges about 8 years ago

  • Target version changed from 1.5.1 to 1.5.2

#4 Updated by Boone Gorges about 8 years ago

  • Target version changed from 1.5.2 to 1.5.3

#5 Updated by Boone Gorges almost 8 years ago

  • Target version changed from 1.5.3 to 1.5.4

#6 Updated by Boone Gorges almost 8 years ago

  • Target version changed from 1.5.4 to 1.5.5

#7 Updated by Boone Gorges almost 8 years ago

  • Target version changed from 1.5.5 to 1.5.6

#8 Updated by Boone Gorges almost 8 years ago

  • Target version changed from 1.5.6 to 1.5.7

#9 Updated by Boone Gorges almost 8 years ago

  • Target version changed from 1.5.7 to 1.5.8

#10 Updated by Boone Gorges almost 8 years ago

  • Target version changed from 1.5.8 to 1.5.9

#11 Updated by Boone Gorges almost 8 years ago

  • Target version changed from 1.5.9 to 1.5.10

#12 Updated by Boone Gorges almost 8 years ago

  • Target version changed from 1.5.10 to 1.5.11

#13 Updated by Boone Gorges almost 8 years ago

  • Target version changed from 1.5.11 to 1.5.12

#14 Updated by Boone Gorges over 7 years ago

  • Target version changed from 1.5.12 to 1.5.13

#15 Updated by Boone Gorges over 7 years ago

  • Target version changed from 1.5.13 to 1.5.14

#16 Updated by Boone Gorges over 7 years ago

  • Target version changed from 1.5.14 to 1.5.15

#17 Updated by Boone Gorges over 7 years ago

  • Target version changed from 1.5.15 to 1.5.16

#18 Updated by Boone Gorges over 7 years ago

  • Target version changed from 1.5.16 to 1.5.17

#19 Updated by Boone Gorges over 7 years ago

  • Target version changed from 1.5.17 to 1.5.18

#20 Updated by Boone Gorges over 7 years ago

  • Target version changed from 1.5.18 to 1.5.19

#21 Updated by Boone Gorges over 7 years ago

  • Target version changed from 1.5.19 to 1.5.20

#22 Updated by Boone Gorges over 7 years ago

  • Target version changed from 1.5.20 to 1.5.21

#23 Updated by Boone Gorges over 7 years ago

  • Target version changed from 1.5.21 to 1.5.22

#24 Updated by Chris Stein over 7 years ago

  • Status changed from Assigned to Reporter Feedback
  • Assignee changed from Chris Stein to Matt Gold
  • Target version changed from 1.5.22 to 1.6

#2699 is resolved now and that resolves most of the issues here in terms of links not working.

If you click your avatar once on touch or hover on mouse then the menu appears. My Profile has links to view and edit and clicking on My Profile itself takes you to your profile page.

There is one issue still remaining. What happens when you click on the avatar itself. Right now clicking on your avatar (on touch you click twice since the first click shows the menu) takes you to your profile edit page.

It seems like the previous discussion it would make more sense to people if the avatar led to the profile page (not in edit mode).

Matt, assigning it to you to confirm that. Also changing the target to 1.6 since this could involve some new work (changing the link for the avatar).

#25 Updated by Matt Gold over 7 years ago

  • Status changed from Reporter Feedback to Assigned
  • Assignee changed from Matt Gold to Boone Gorges

It seems like the previous discussion it would make more sense to people if the avatar led to the profile page (not in edit mode).

yes, confirmed. Thanks.

#26 Updated by Boone Gorges over 7 years ago

  • Status changed from Assigned to Testing Required
  • Assignee changed from Boone Gorges to Chris Stein

I've changed the destination of the avatar image link to the logged-in user's profile in https://github.com/castiron/cac/commit/0ca8c35b637055a93f4af35da5b1a531501b51a0 Ready to test on cdev.

#27 Updated by Matt Gold over 7 years ago

  • Status changed from Testing Required to Resolved

Perfect. Marking resolved. Chris, please reopen if needed.

Also available in: Atom PDF