Project

General

Profile

Bug #2789

IE 8 Profile Overlay Issue

Added by Sarah Morgano about 8 years ago. Updated almost 8 years ago.

Status:
Resolved
Priority name:
Urgent
Assignee:
Category name:
-
Target version:
Start date:
2013-09-12
Due date:
% Done:

0%

Estimated time:

Description

A member just reported not being able to dismiss the "You Profile Page Had Changed" message on IE7 (screenshot attached). She said that she kept clicking the X but nothing happened. She was able to download Chrome and dismiss the message from that web browser.

profile Ie.bmp (3.75 MB) profile Ie.bmp Sarah Morgano, 2013-09-12 03:29 PM
export.pdf (14.3 KB) export.pdf Sarah Morgano, 2013-09-17 02:55 PM
support-details.pdf (16.8 KB) support-details.pdf Details of PC IE10 testing environment at GC Matt Gold, 2013-09-18 05:52 PM
profile-viewing.png (370 KB) profile-viewing.png Layout messed up when viewing the profile page Matt Gold, 2013-09-18 05:52 PM
profile-editing.png (625 KB) profile-editing.png Layout messed up when editing the profile Matt Gold, 2013-09-18 05:52 PM
ie-login-buttons.png (662 KB) ie-login-buttons.png Homepage -- click login and buttons out of place Matt Gold, 2013-09-18 05:52 PM

History

#1 Updated by Matt Gold about 8 years ago

  • Priority name changed from Immediate to Urgent

Thanks for the report, Sarah. Just FYI, to my mind, the "Immediate" priority is to be saved for a serious hack to the Commons that needs to be addressed absolutely absolutely absolutely immediately.

#2 Updated by Sarah Morgano about 8 years ago

Thanks for the clarification, Matt. I usually don't assign and set the priority/severity for tickets when I report them, but I thought this was important. Would it be more helpful to leave these fields blank in the future or just use my discretion?

#3 Updated by Matt Gold about 8 years ago

I think that leaving blank is best if you don't mind. Thanks.

#4 Updated by Sarah Morgano about 8 years ago

Cool, will do.

#5 Updated by Matt Gold about 8 years ago

Sarah, have we been able to replicate this issue on IE7? Can you find out more about what OS she was using?

#6 Updated by Sarah Morgano about 8 years ago

Since I've already logged in and dismissed the message I can't replicate the issue. I will reach out to Lindsey and update the ticket with her OS/browser when I hear back from her.

#7 Updated by Matt Gold about 8 years ago

Okay. If you are at a computer with a similar OS/browser, I suppose you could follow the instructions here to test: http://redmine.gc.cuny.edu/issues/2786#note-3 (comment #3)

#8 Updated by Sarah Morgano about 8 years ago

According to another member who sent along their computer specs (attached), she was using IE8 on Windows 7. So far, 4 members have reported this issue.

#9 Updated by Boone Gorges about 8 years ago

  • Status changed from New to Assigned
  • Assignee changed from Boone Gorges to Raymond Hoh

Ray, will you please have a look at this?

#10 Updated by Raymond Hoh about 8 years ago

Hmm, I tested IE10 in IE7-compat mode and I was able to clear the "Your Profile Page Has Changed" overlay, but not the "New CUNY Academic Commons Profiles" notice when you're on your profile page.

Are the reports concerning the "Your Profile Page Has Changed" overlay or the "New CUNY Academic Commons Profiles" notice?

#11 Updated by Sarah Morgano almost 8 years ago

  • Subject changed from IE 7 Profile Overlay Issue to IE 8 Profile Overlay Issue

Another user has reported this issue: http://feedback.commons.gc.cuny.edu/forums/35103-general/suggestions/4447460-can-t-remove-the-announcement-box.

Also, based on the information provided by one of our members who experienced this, I've updated the ticket from IE 7 8.

#12 Updated by Matt Gold almost 8 years ago

Hi All --

Reiterating the urgent nature of this ticket

#13 Updated by Boone Gorges almost 8 years ago

  • Status changed from Assigned to Testing Required

I've spent some time and made a few updates to the JS, and it appears to fix the problem in IE8 and IE7 for me. Can I ask someone with access to these browsers to check? Be sure to do a hard refresh - it's important that the relevant JS files are cleared from your browser cache. (You can check either on the live site or on cdev. Go to your own profile when logged in, and add ?show_overlay=1 to the URL to see the overlay.)

#14 Updated by Matt Gold almost 8 years ago

Hi Boone --

I just tested on a computer at the GC, on IE10, I think, and things were a mess:

-- couldn't dismiss the profile changed message even though I clicked on the x
-- layout was messed up on the homepage (login button, etc., out of place)
-- layout messed up on the profile editing screen
-- layout messed up on the profile viewing screen

Please see screenshots and details of the testing environment attached.

#15 Updated by Raymond Hoh almost 8 years ago

The production version of CAC appears to be on the master branch.

In the master branch of cacap-profiles-overlay.php, there was a `console.log()` call that threw a JS error in IE7 when attempting to close the overlay. This always prevented the overlay from closing.

I've just pushed a commit that removes this call. This needs to be pulled on cdev or production for testing.


Matt's issues appear to be from IE10 being in compatibility view (IE7) mode. We should force the bp-nelo theme to use the newer browser mode so the site will render properly.

#16 Updated by Boone Gorges almost 8 years ago

  • Status changed from Testing Required to Assigned

Thanks, Ray. So, I was using IE's developer toolbar to try to detect problems, which meant that console.log() was defined, which is why I wasn't able to reproduce the issue. On the other hand, if I were able to reproduce the issue, the only way to know about it would be to activate a console, in which case the issue would go away. Conclusion: IE7 is a terrible browser. I'm glad you know more about it than I do :)

I've pulled the changes to the production site.

The production version of CAC appears to be on the master branch.

Yes, this is intentional, in part so I can cherry-pick over urgent fixes like this one. I don't know how the console call ended up in the master branch but not the 1.5.x branch. I guess I did something wrong somewhere.

We should force the bp-nelo theme to use the newer browser mode so the site will render properly.

Yes. I thought I was doing that with the doctype at the top of each profile page. But maybe I've done it wrong, or there's more I have to do? Can you help with this, Ray?

#17 Updated by Raymond Hoh almost 8 years ago

I've pulled the changes to the production site.
Conclusion: IE7 is a terrible browser. I'm glad you know more about it than I do :)

Confirmed that this fixed the IE7 overlay bug. Doesn't fix the fact that the site looks like it was hit with the ugly stick in IE7 though ;) IE7 really does suck as you can't even debug javascript natively!

Yes. I thought I was doing that with the doctype at the top of each profile page. But maybe I've done it wrong, or there's more I have to do? Can you help with this, Ray?

Just pushed a commit to the 1.5.x branch to address this.

#18 Updated by Boone Gorges almost 8 years ago

  • Status changed from Assigned to Testing Required

Awesome. I have pulled these changes to the master branch and then to the production site as a hotfix. Matt, would you please test in the AM whether they've solved the relevant issues for you? Also, anyone else with access to an older version of IE. (I've tested on 7, 8, and 10, and it's working for me, but as we've seen there are some shit quirks in debugging this stuff.)

#19 Updated by Matt Gold almost 8 years ago

Awesome -- huge, huge thanks to you both. Yes, I'll check in the morning.

#20 Updated by Boone Gorges almost 8 years ago

  • Target version set to 1.5.3

#21 Updated by Matt Gold almost 8 years ago

Matt, would you please test in the AM whether they've solved the relevant issues for you?

Just tested again on that environment and can confirm that clicking on either the x in the corner and the text "close window" closed the window as expected. Nice work!

#22 Updated by Boone Gorges almost 8 years ago

  • Status changed from Testing Required to Resolved

Thanks for testing. And Ray, thanks for the advice and help.

Also available in: Atom PDF