Project

General

Profile

Bug #2798

IE10 Profile Display Errors

Added by Matt Gold almost 8 years ago. Updated almost 8 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
BuddyPress (misc)
Target version:
Start date:
2013-09-19
Due date:
% Done:

0%

Estimated time:

Description

In my testing for a related ticket, I saw that the layout of the profile/profile editing screens were messed up in IE10. Environment details and screenshots attached. Happy to test on this environment (default environment on GC PCs) if needed.

support-details.pdf (16.8 KB) support-details.pdf Matt Gold, 2013-09-19 09:37 AM
ie10-profile-editing-screen.png (574 KB) ie10-profile-editing-screen.png Matt Gold, 2013-09-19 09:37 AM
profile-viewing.png (370 KB) profile-viewing.png Matt Gold, 2013-09-19 09:37 AM
profile-editing.png (625 KB) profile-editing.png Matt Gold, 2013-09-19 09:37 AM
ie-login-buttons.png (662 KB) ie-login-buttons.png Matt Gold, 2013-09-19 09:37 AM
supportdetails2.pdf (16.8 KB) supportdetails2.pdf Matt Gold, 2013-09-20 11:03 AM
profile-viewing2.png (418 KB) profile-viewing2.png Matt Gold, 2013-09-20 11:03 AM
profile-editing2.png (575 KB) profile-editing2.png Matt Gold, 2013-09-20 11:03 AM

History

#1 Updated by Boone Gorges almost 8 years ago

  • Assignee changed from Boone Gorges to Raymond Hoh
  • Target version set to 1.5.3

Ray, it looks like the compatibility mode fix is not working. Would you have a look please?

#2 Updated by Raymond Hoh almost 8 years ago

  • Status changed from Assigned to Testing Required

I removed the meta tag version of the fix and replaced it with the HTTP header equivalent in commit 05a308f on the 1.5.x branch.

This is more reliable than using the meta tag. Please let me know if that works.

#3 Updated by Boone Gorges almost 8 years ago

Thanks, Ray!

Matt, I've deployed the change to the production site. Please let us know what you find.

#4 Updated by Matt Gold almost 8 years ago

Still experiencing errors. Dom is here, so I just showed this to him. He may update the ticket with further details. In the meantime, attached are support details on the environment and screenshots. Looks like About Me and short description is being displayed on top of the contact info.

#5 Updated by Raymond Hoh almost 8 years ago

I'm guessing that the issue is an IE config thing on the GC computers.

Read the following article:
http://stackoverflow.com/a/15919569

Check to see:

  • If "cuny.edu" is listed in the "Websites you've added to compatibility view". If so, remove it.
  • If "Display all websites in Compatibility View" is checked. This should be unchecked.
  • If "Display intranet sites in Compatibility View" is checked. This should be unchecked. If the GC computers are running the Commons site over an intranet and this item is checked, this could be causing the problem.

#6 Updated by Matt Gold almost 8 years ago

Yes, Dom and I troubleshooted this in person today and he will be updating this ticket when he gets home. Apparently, IE10 at the GC uses Document Mode: IE7 Standards as the default!

I will follow up with GC IT to see if they can change that.

Chris is looking at a specific CSS fix right now.

#7 Updated by Dominic Giglio almost 8 years ago

Thanks Ray,

Matt and I discussed this very possibility at today's meeting and Matt is going to send an email to the CUNY IT team to see if there is some enterprise level network profile that's forcing IE to revert to IE7 Standards mode. I found a bunch of links with information about changing that setting through the browser and I was going to write up a long response about what I think is going on here, but based on you and Boone's conversation above and the code changes you two have already tried I really don't think I need to. So I'll paste the links I found incase they contain any info that any of us are not aware of and we'll wait to hear back from Matt and the IT staff to see what's going on.

http://stackoverflow.com/questions/10975107/force-to-use-internet-explorer-ie9-standards-document-mode
http://html5center.sourceforge.net/Fix-common-IE-problems
http://stackoverflow.com/questions/2742853/force-internet-explorer-8-browser-mode-in-intranet
http://stackoverflow.com/questions/2742853/force-internet-explorer-8-browser-mode-in-intranet/4130343#4130343

#8 Updated by Matt Gold almost 8 years ago

Chris's note/best guess:

"IE7 doesn't understand after/before pseudo selectors, and we are using after/before in our CSS in the profile header space on the screen.css -- cacap-row:after{clear:both}

we do clearing on those tags but that's not happening because of the IE7 issue

may need to add a conditional stylesheet targeted at IE7 and add fix to that"

#9 Updated by Matt Gold almost 8 years ago

from Chris: we should also check whether our doctype (XHTML transitional) is triggering quirk mode

#10 Updated by Dominic Giglio almost 8 years ago

we should also check whether our doctype (XHTML transitional) is triggering quirk mode

DOCTYPE! issues are mentioned in most of those links I included above.

Boone,

Is there a reason we're using a transitional DOCTYPE? Instead of just <!DOCTYPE html> in bp-nelo?

#11 Updated by Boone Gorges almost 8 years ago

  • Target version changed from 1.5.3 to 1.5.4

#12 Updated by Boone Gorges almost 8 years ago

I'm highly reluctant to introduce IE-specific stylesheets if we can avoid it.

Ray's meta header wasn't working for profile pages, because technically, profile pages are no longer part of bp-nelo. (They include the stylesheet, but the templates are not loaded in the normal way.) Also, on Dom's suggestion, I checked out the transitional DOCTYPE; I'd originally introduced this because I didn't have any DOCTYPE at all, and something was needed to make JS work properly. It turns out that transitional DOCTYPEs can sometimes prevent the meta header from turning off compatibility mode.

By switching the DOCTYPE and adding the meta header tag to the top-level profile template, it appears that the problem is fixed. https://github.com/cuny-academic-commons/cac-advanced-profiles/commit/0f7a6ba9167d7c8b21fb7c43267ab0453e9816c9

Can I ask someone with easy access to a GC computer to check http://cdev.gc.cuny.edu/members/teststudent on IE and see if it looks right?

#13 Updated by Matt Gold almost 8 years ago

Fix tested and confirmed. Looks beautiful. Many, many thanks for your work on this.

#14 Updated by Boone Gorges almost 8 years ago

  • Status changed from Testing Required to Resolved

Excellent. Thanks.

#15 Updated by Matt Gold almost 8 years ago

Thank you! Can you please let me know whether this is being applied as a hotfix or whether you are adding it to the next release?

#16 Updated by Boone Gorges almost 8 years ago

It's slated for the next release. Let me know if you want different.

#17 Updated by Matt Gold almost 8 years ago

I'm conflicted: we set up the release schedule for a reason and I am keenly aware that applying a "hotfix" is a demand on your time. Having said that, the GC community comprises a large selection of the Commons membership, and this affects a major part of how the Commons looks on default setups there. I'd say that if you can reasonably make time to add this sooner, that would be great and would be my preference, but if you're swamped, we can wait.

#18 Updated by Boone Gorges almost 8 years ago

I've deployed the change to the production site.

Also available in: Atom PDF