Project

General

Profile

Support #3061

Domain Mapping

Added by Paul Hebert about 5 years ago. Updated almost 5 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
Domain Mapping
Target version:
Start date:
2014-02-21
Due date:
% Done:

0%

Estimated time:

Description

Professor Robert Reid-Pharr has recently purchased a domain name (reid-pharr.com) for his new commons site: robertreidpharr.commons.gc.cuny.edu. He is also interested in including the sub-domain robert.reid-pharr.com to route to the same page.

In the past, I could do some of the domain mapping through the commons. Since the update (although it may have happened before?) there seems to be no link to Domain Mapping tools. I don't know what information to give Go Daddy and I don't know what needs to be done on the Commons side.

History

#1 Updated by Boone Gorges about 5 years ago

  • Category name set to Domain Mapping
  • Status changed from New to Reporter Feedback
  • Assignee set to Boone Gorges
  • Target version set to Not tracked

At the domain registrar, please go into the DNS settings, and create a CNAME record that points toward commons.gc.cuny.edu. Once this is done, update this ticket and I will make the necessary changes.

#2 Updated by Matt Gold almost 5 years ago

I've requested server set up from IT

#3 Updated by Paul Hebert almost 5 years ago

I'm surprised I don't have to change the A record to have reid-pharr.com resolve to the commons. I don't need to enter a new IP address?

robert.reid-phar.com is now set a C name record pointing to commons.gc.cuny.edu

www.reid-pharr.com is also a C name record by default set to point to the A name host (using an @ symbol in the settings). I guess I don't entirely understand why these two C name records don't point to the same place.

#4 Updated by Boone Gorges almost 5 years ago

Paul - We're still trying to figure out some of the finer points of domain mapping on our specific setup, so please bear with us.

We can generally handle either A record or CNAME record mapping. But if you want to be certain, please do point your primary A record at our IP (146.96.128.200). Each subdomain that you want mapped to the site ('robert' and possibly 'www') will also need its own DNS record; see your registrar's help documentation for more details about this. When this is done, let me know, and I'll do what needs to be done on my end.

#5 Updated by Paul Hebert almost 5 years ago

Boone,

Okay, I think I have a handle on this stuff and I think I'm all set.

From what I've gathered, domains can have multiple A -Name records (although usually 1) and these point to the main server with an IP address. In this case, it makes sense to have it be the Commons. C-name records can point anywhere. So, I have two C-name records that send the www.reid-pharr.com and robert.reid-pharr.com to the same A-name record.

Hypothetically, if Robert eventually has another site on the Commons (or wordpress.com or something), he could create a new C-name and have it point to there using a standard web address (robertsblog.commons.gc.cuny.edu). So, his second site could be blog.reid-pharr.com or something. That makes sense and I hope is right.

#6 Updated by Matt Gold almost 5 years ago

Okay -- IT reports that this is done. Please test and let me know if they it is working as expected. thanks.

#7 Updated by Boone Gorges almost 5 years ago

  • Status changed from Reporter Feedback to Assigned
  • Assignee changed from Boone Gorges to Matt Gold

Matt - same issue here as #3066 and #3062. Please verify with IT. Thanks.

#8 Updated by Matt Gold almost 5 years ago

okay, checking in.

#9 Updated by Matt Gold almost 5 years ago

IT has made further changes. Can you please try again?

#10 Updated by Boone Gorges almost 5 years ago

Thanks. It's now working for http://reid-pharr.com and http://www.reid-pharr.com. However, http://robert.reid-pharr.com is not working. It looks like Apache was not configured to expect this subdomain. Could you please submit the additional request?

#11 Updated by Paul Hebert almost 5 years ago

It looks like it resolves to the Commons servers (the favicon is CUNY), but the page is blank. This is now true for all versions of the address (reid-pharr.com ; cuny.is/reidpharr ; robertreidpharr.commons.gc.cuny.edu ) I can log in and edit pages/posts but clicking "view" turns up a blank page.

#12 Updated by Matt Gold almost 5 years ago

Hi Paul -- I'm seeing the pages as expected on all three links.

#13 Updated by Boone Gorges almost 5 years ago

It looks like it resolves to the Commons servers (the favicon is CUNY), but the page is blank

Yes, it's an Apache config issue on the GC end.

This is now true for all versions of the address (reid-pharr.com ; cuny.is/reidpharr ; robertreidpharr.commons.gc.cuny.edu ) I can log in and edit pages/posts but clicking "view" turns up a blank page.

I can't reproduce this. Please give more details on what you're clicking to lead to the error, including URLs. What "View" are you clicking?

#14 Updated by Matt Gold almost 5 years ago

Okay - http://robert.reid-pharr.com/ has been added. Please test.

#15 Updated by Boone Gorges almost 5 years ago

  • Status changed from Assigned to Reporter Feedback

Thanks, Matt. Looks good to me. Paul, please verify.

#16 Updated by Paul Hebert almost 5 years ago

Yes - everything seems to be working.

The blank page issue only affected the home page and I was able to fix it, although I'm not entirely sure how. I changed some settings, it worked, and I'm not fool enough to reason why.

Thank you Matt and Boone for getting this to work!

#17 Updated by Boone Gorges almost 5 years ago

  • Status changed from Reporter Feedback to Resolved

Great, thanks for your patience!

Also available in: Atom PDF