Project

General

Profile

Bug #3123

Committee for the Study of Religion Calendar Plugin

Added by Sarah Morgano over 7 years ago. Updated almost 6 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
WordPress Plugins
Target version:
Start date:
2014-03-20
Due date:
% Done:

0%

Estimated time:

Description

On March 12th, one of the admins for the Committee for the Study of Religion site reported that events won't convert from draft to published no matter how many times they are edited. They are using the events managerjetpack plugin, but said that no recent changes have been made to the site.

The following plugins are active on the site:

broken link checker
email address encoder
events managerjetpack by wordpress.com
newsletters (says that the download has expired)
photodropper
sansarin PHP widget
social
twitter tools
user role editor
viper’s video quicktags
wordpress importer
wordpress mobile edition
wp-print
wp hide post
wp status notifier
wp UI-tabs, accordions, and more

History

#1 Updated by Sarah Morgano over 7 years ago

and here's the link for the site

http://studyofreligion.gc.cuny.edu/events/

#2 Updated by Matt Gold over 7 years ago

  • Status changed from New to Assigned
  • Assignee set to Boone Gorges
  • Priority name changed from Normal to High

Marking as high priority given the length of time since the ticket was first reported.

#3 Updated by Boone Gorges over 7 years ago

  • Assignee changed from Boone Gorges to Dominic Giglio

Dom, can you have a preliminary look at this?

#4 Updated by Boone Gorges over 7 years ago

  • Status changed from Assigned to Reporter Feedback
  • Target version set to Not tracked

I noticed that when I went to publish a post http://studyofreligion.gc.cuny.edu/wp-admin/post.php?post=1175&action=edit (clicking Publish), I was led to the Social publicize screen. A couple thoughts:

1. It's possible that this interface is interfering with the publishing process. I've had issues with Social in the past when attempting to auto-publicize items. Keith, perhaps you could try disabling the plugin and trying again. This may help us narrow down the issue.
2. I'm not comfortable doing this myself because I don't want to be tweeting from other people's accounts by accident :)

#5 Updated by Keith Miyake over 7 years ago

It seems to be working for me, but only when I click "publish" on individual entries, and not using the bulk post quick edit feature. I also clicked on the "no" box for the social publishing.

Perhaps it's a permissions issue?

Sarah, I didn't see you as a user/admin on the site. Were you using Morgan's login? She should have admin access.

I went ahead and re-published the first few events but didn't go through the whole list since there are about 45 more...

#6 Updated by Boone Gorges over 7 years ago

  • Assignee changed from Dominic Giglio to Boone Gorges
  • Priority name changed from High to Normal

Thanks, Keith. I'm reducing the item in priority since you are able to make the changes necessary, just not in bulk mode.

I'm still guessing that Social is the cause of this. My gut feeling is that Social is blocking the publish event from taking place in the background when you attempt to bulk-publish posts. I'll try to do some more testing of this, but you might also test in the meantime by disabling Social altogether (if you can temporarily disable it without otherwise breaking the site).

#7 Updated by Keith Miyake over 7 years ago

disabling the social plugin didn't help. still unable to bulk publish.

the posts in question are a custom post type. so my guess is that it's either a problem with the events manager plugin or the wordpress custom post type functionality.

boone, i will try replicating this situation on my test server with only the events manager plugin installed to see if i can narrow down the source of the problem.

edit: it half works on my test server. i can bulk publish, but only some of the items (using an export from the religion site). i think that this problem has to do with the events manager plugin and possibly something to do with the way it stores and verifies dates and/or locations as custom post meta fields, but only in the bulk publish mode.

boone: i suggest marking this as resolved since the immediate problem of not being able to publish is resolved, although the solution is a bit annoying for the site maintainers.

sarah: i manually published most of the posts but there are still about a dozen more in "draft" that need to be re-published. sorry, i got tired of the repetitiveness.

#8 Updated by Boone Gorges almost 6 years ago

  • Status changed from Reporter Feedback to Resolved

Also available in: Atom PDF