Project

General

Profile

Bug #3298

jitp.commons.gc.cuny.edu not loading in Windows 8/Firefox 30

Added by Sarah Ruth Jacobs about 7 years ago. Updated about 7 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
-
Target version:
Start date:
2014-07-08
Due date:
% Done:

100%

Estimated time:

Description

For some reason, jitp.commons.gc.cuny.edu doesn't load properly in Windows 8/Firefox 30. However, our seemingly identical site, jitpstaging.commons.gc.cuny.edu does load properly. Other browsers and OSs have not been a problem.

jitp.jpg (125 KB) jitp.jpg Image of site in Windows 8/Firefox 30 Sarah Ruth Jacobs, 2014-07-08 05:41 PM
IE.jpg (263 KB) IE.jpg IE Stephen Klein, 2014-07-09 07:35 AM
jitp2.jpg (354 KB) jitp2.jpg JITP in IE Stephen Klein, 2014-07-16 10:23 AM
2014-07-29_093309.png (239 KB) 2014-07-29_093309.png IE11 on Windows 8.1 Raymond Hoh, 2014-07-29 12:39 PM

History

#1 Updated by Matt Gold about 7 years ago

  • Status changed from New to Assigned
  • Assignee set to Dominic Giglio

Thank you, Sarah. Looks like the stylesheet is not being applied.

#2 Updated by Matt Gold about 7 years ago

  • Tracker changed from Design/UX to Bug

#3 Updated by Stephen Klein about 7 years ago

Suggesting that this is needed in the header.php of the child theme:
<meta http-equiv="X-UA-Compatible" content="IE=edge">

Because many versions of IE do not use the latest and greatest rendering engine. If you launch the site in IE and then use the developer’s tools (F`12) and then select Emulation=>Document Mode=>Edge, the page renders correctly. I have attached a screenshot.

#4 Updated by Luke Waltzer about 7 years ago

I just remembered that Genesis allows you to hook into site files via the admin-- Stephen can you test your fix here?

http://jitpstaging.commons.gc.cuny.edu/wp-admin/admin.php?page=simplehooks

#5 Updated by Stephen Klein about 7 years ago

Added before and then after genesis header hook in staging and did not seem to have resolved.

#6 Updated by Boone Gorges about 7 years ago

Has anyone managed to reproduce this issue? I don't have Windows 8 handy on this machine, but on Windows 7 + FF 30.0, everything is rendering properly.

#7 Updated by Matt Gold about 7 years ago

Hi Boone - it has been experienced by two different members of the JITP team

#8 Updated by Boone Gorges about 7 years ago

  • Assignee changed from Dominic Giglio to Raymond Hoh

Ray, can you look at this please?

#9 Updated by Raymond Hoh about 7 years ago

Just tried loading on Windows 8.1 + Firefox 30 and can open the JITP site with no issues.

As Matt stated above, by the looks of Sarah's screenshot, it appears that the CSS stylesheet is having problems loading.

Perhaps the Firefox install has some addons installed that are blocking some resources?

#10 Updated by Sarah Ruth Jacobs about 7 years ago

I disabled all Firefox add-ons and it loaded properly in Windows 8/Firefox 30. Thanks guys. I could take the time to figure out which add-on it is, but I guess it's not really important. It is odd that the regular jitp.commons.gc.cuny.edu site was disrupted by an add-on but the jitpstaging.commons.gc.cuny.edu site wasn't, but oh well, I guess it isn't worth worrying about. All the help is much appreciated.

#11 Updated by Stephen Klein about 7 years ago

Still issues with IE.

#12 Updated by Boone Gorges about 7 years ago

Stephen, could you please elaborate on the IE issues? The original report was about FF. What are your browser/OS versions? Are you seeing the exact problem that SRJ describes in her original report?

#13 Updated by Stephen Klein about 7 years ago

rendering in IE is off. See attached file.

#14 Updated by Stephen Klein about 7 years ago

Suggesting that this is needed in the header.php of the child theme:
<meta http-equiv="X-UA-Compatible" content="IE=edge">

Because many versions of IE do not use the latest and greatest rendering engine. If you launch the site in IE and then use the developer’s tools (F`12) and then select Emulation=>Document Mode=>Edge, the page renders correctly. I have attached a screenshot.

#15 Updated by Boone Gorges about 7 years ago

Thanks, Stephen. Can you please share the details of your setup? IE/Windows versions.

#16 Updated by Raymond Hoh about 7 years ago

Stephen, I just tested the JITP site in IE 11 and it works for me.

It appears that you have IE running in Compatibility Mode. Can you try turning that off?
http://www.sevenforums.com/tutorials/1196-internet-explorer-compatibility-view-turn-off.html

#17 Updated by Stephen Klein about 7 years ago

Not running in compatibility mode. I checked.

#18 Updated by Raymond Hoh about 7 years ago

Hi Stephen,

What happens when you toggle the "Compatibility View" button? In your attached jitp2.jpg screenshot, it would be the button directly following the address bar and before the tab.

Did you run through all the options in the link I provided? Also, what version of IE are you using?

Here's a screenshot of JITP I just took in IE11. The rendering mode by default is set to "Edge" for me.

#19 Updated by Stephen Klein about 7 years ago

Turned on and off Compatibility option using options two and three:
http://www.sevenforums.com/tutorials/1196-internet-explorer-compatibility-view-turn-off.html

#20 Updated by Raymond Hoh about 7 years ago

Hi Stephen,

Thanks for going through those options. What about option one? What version of IE and Windows are you running?

If option one still doesn't work, we'll just add in the meta tag.

#21 Updated by Stephen Klein about 7 years ago

Running Windows 7, IE 11.

My version of IE did not allow for option one, only two and three.

#22 Updated by Raymond Hoh about 7 years ago

Hi Stephen,

I just fired up IE 11 on Windows 7 and, unfortunately, cannot confirm the problem you have.

It might be a problem with your IE settings. A StackOverflow answer hints at resetting your IE settings:
http://stackoverflow.com/a/22762687

Can you give that a shot?

#23 Updated by Stephen Klein about 7 years ago

Not at work for a while, but I previously checked on several workstations at the GC and it appeared to be a consistent issue.

#24 Updated by Raymond Hoh about 7 years ago

  • Status changed from Assigned to Resolved
  • % Done changed from 0 to 100

Hi Stephen,

I've gone ahead and added the IE meta tag to the JITP theme. This should make its way into the next CAC maintenance release scheduled in about a week from now.

Thanks for attempting to troubleshoot the problem!

#25 Updated by Raymond Hoh about 7 years ago

  • Target version set to 1.6.12

#26 Updated by Stephen Klein about 7 years ago

Thank you for all your effort!

Also available in: Atom PDF