Project

General

Profile

Bug #344

Reports of Logout Problems with WP-MW Single Sign On

Added by Matt Gold over 8 years ago. Updated almost 5 years ago.

Status:
Resolved
Priority name:
Low
Category name:
Wiki
Target version:
Start date:
2010-09-19
Due date:
% Done:

0%

Estimated time:

Description

We've had a few reports of problems on the log-out step of the WP-MW Single Sign On after WP 3.0/BP upgrades. Can we look into this and respond on the Comment thread? Are these problems reproducible, or are they due to user errors?

Examples of reports:

http://dev.commons.gc.cuny.edu/2009/05/21/new-mediawiki-extension-wpmusinglesignon/#comment-688

http://dev.commons.gc.cuny.edu/2009/05/21/new-mediawiki-extension-wpmusinglesignon/#comment-661

Assigning this to Zach since CIC developed the extensions, but Boone, please feel free to jump in if you can.

History

#1 Updated by Matt Gold over 8 years ago

More specific reporting on the error encountered from the comment thread :

Turned on error reporting via Comment 72 by Mark, and get this error:

Fatal error: Cannot access protected property WebRequest::$data in /Users/Frankly/Sites/dip.youthstudies.eu/wiki/extensions/LogoutLoginWP/LogoutLoginWP.php on line 29

Line 29 is this:

if($redirectTo = $wgRequest->data['redirect_to'])

#2 Updated by Andreas Karsten over 8 years ago

I think I found the solution via other MediaWiki extensions who had similar problems, apparently because of a change in MW 1.16 through which a public field became protected (source).

Changing the code in line 29 to this solved all my problems and all works beautifully now:

if($redirectTo = $wgRequest->getVal('redirect_to')) {

#3 Updated by Lucas Thurston over 8 years ago

Nicely done, Andreas.

When I first saw that snippet of code I wondered if the value assignment was intentional or if it was supposed to be an equality check. I assume it's the former, and that this is a case of my own desire for brief and clever code run amok. Readability would be improved by replacing line 29 with:

$redirectTo = $wgRequest->getVal('redirect_to');
if($redirectTo) {

I or someone else at CIC will do that this week.

Lucas

#4 Updated by Andreas Karsten over 8 years ago

Works as smoothly! Lovely :)

#5 Updated by Boone Gorges over 8 years ago

  • Target version set to Not tracked

Lucas - has this been fixed in the version of the extension that's downloadable from the website?

#6 Updated by Boone Gorges over 8 years ago

  • Assignee changed from Zach Davis to Lucas Thurston
  • Priority name changed from Normal to Low

Bump. Lucas, would you mind making the change to the zip downloadable on the dev blog http://dev.commons.gc.cuny.edu/2009/05/21/new-mediawiki-extension-wpmusinglesignon/ ? If you don't have write access to that blog, post the zip as an attachment here and I'll upload it. Thanks!

#7 Updated by Boone Gorges almost 5 years ago

  • Status changed from Assigned to Resolved

I've made the update in the downloadable package.

Also available in: Atom PDF