Project

General

Profile

Bug #352

Member reports problems with avatar cropping

Added by Matt Gold almost 11 years ago. Updated almost 11 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
BuddyPress (misc)
Target version:
Start date:
2010-09-21
Due date:
% Done:

0%

Estimated time:

Description

A member using Windows XP and Internet Explorer reports that when trying to crop an avatar image, the small image on the right doesn't show changes as the cropping square is being adjusted, and no "Crop Image" button appears. Everything worked for this member at home. Can we do some testing on this? I don't know which version of IE was being used. I can help with the testing, as I have XP/IE on a computer here.


Related issues

Related to CUNY Academic Commons - Bug #418: Problems cropping group avatar with IEResolved2010-11-30

History

#1 Updated by Boone Gorges almost 11 years ago

It worked fine for me on XP/IE7. My installation of IE6 is broken, so in order to test with it I'll have to install a new VM. I probably won't be able to get to it today, but I'll try.

#2 Updated by Matt Gold almost 11 years ago

Thanks, Boone. I'll install IE6 on my computer and test.

#3 Updated by Matt Gold almost 11 years ago

Hi Boone,

Either here or via email, can you help me figure out a way to help this member troubleshoot this issue? Perhaps we can start an email thread between the three of us?

If you'd prefer to give me guidance that I can pass on, that would be fine, but it sounds to me like an email correspondence might be the simplest way to go.

#4 Updated by Boone Gorges almost 11 years ago

  • Status changed from Assigned to Hold

Possible fix:

The avatar cropper works by reproducing the uploaded image in a div next to the static box, and as you move the cropper on the left, it essentially resizes/moves the picture in a way that is a mirror-image of what you'd expect: when move the selection box to the right, the picture moves to the left, and when you make the box smaller, the picture gets larger. On a normal browser, there is only a small 150x150 square where you can see what there is to see of the picture, but on IE7 the overflow:hidden property on that div isn't working right, so you see the entire picture. In other words: two identical pictures side by side. The second picture, when you first upload, covers up the Crop Image button, which could explain what the user is seeing.

I've put a rough fix into the master and the 1.0-branch. We'll do more thorough browser testing when we get closer to 1.1 release.

#5 Updated by Boone Gorges almost 11 years ago

  • Status changed from Hold to Resolved
  • Target version set to 1.1

My notes say that we're holding this for further testing. I've run it through on a few machines and it looks OK. And since we haven't gotten more reports, I'm closing it. If the problem arises again, please reopen.

Also available in: Atom PDF