Project

General

Profile

Bug #3574

Address awkward possessive cases on My Commons page

Added by Matt Gold over 7 years ago. Updated almost 7 years ago.

Status:
Duplicate
Priority name:
Normal
Assignee:
Category name:
My Commons
Target version:
-
Start date:
2014-10-15
Due date:
% Done:

0%

Estimated time:

Description

Cases where a user updates a profile results in an awkward My Commons page update. Not sure how to fix this; assigning to Chris and Samantha for ideas.

Screen Shot 2014-10-15 at 10.37.59 PM.png (27.2 KB) Screen Shot 2014-10-15 at 10.37.59 PM.png Matt Gold, 2014-10-16 10:27 PM
LinkedIn Profile Update.png (33 KB) LinkedIn Profile Update.png Samantha Raddatz, 2014-10-21 11:52 AM

Related issues

Related to CUNY Academic Commons - Feature #3844: Site/Blog or Person Emphasis in My CommonsResolved2015-02-26

History

#1 Updated by Raymond Hoh over 7 years ago

We could change the text from "User's profile was updated" to "User updated their profile page".

#2 Updated by Boone Gorges about 7 years ago

  • Target version set to 1.8

See https://buddypress.trac.wordpress.org/ticket/4636#comment:11 for background on the choice of phrasing.

I don't mind singular "their" but I have a feeling it will annoy our users.

#3 Updated by Samantha Raddatz about 7 years ago

How about borrowing from LinkedIn for this?

'User has an updated profile.'
It's dry, but factual and gender neutral!

#4 Updated by Matt Gold about 7 years ago

Boone Gorges wrote:

See https://buddypress.trac.wordpress.org/ticket/4636#comment:11 for background on the choice of phrasing.

I don't mind singular "their" but I have a feeling it will annoy our users.

:) Agreed.

I like Samantha's edit but the problem is that it doesn't imply an action. So I would go with "[User First Name Last Name] 's profile was updated" . The key difference from what we have now is that I think we should repeat the user's name in the actual update text rather than throwing an apostrophe s on the line below the user's name.

So, this would look like

Joe Smith
Joe Smith's profile was updated

Does that make sense?

#5 Updated by Samantha Raddatz about 7 years ago

Works for me!

#6 Updated by Matt Gold about 7 years ago

  • Assignee changed from Chris Stein to Boone Gorges

Thanks. Assigning to Boone for implementation

#7 Updated by Boone Gorges almost 7 years ago

  • Assignee changed from Boone Gorges to Raymond Hoh

Assigning to Ray, as I think this'll fall out of #3844.

#8 Updated by Boone Gorges almost 7 years ago

  • Status changed from Assigned to Duplicate
  • Target version deleted (1.8)

It looks like the changes being worked on in #3844 will fix this completely, so I'm closing this ticket as a duplicate.

Also available in: Atom PDF