Project

General

Profile

Bug #3652

Forum preview doesn't show live link

Added by Matt Gold almost 5 years ago. Updated over 4 years ago.

Status:
Resolved
Priority name:
Low
Assignee:
Category name:
Group Forums
Target version:
Start date:
2014-11-13
Due date:
% Done:

0%

Estimated time:

Description

I was writing a new forum post and thought about embedded a link instead of pasting the URL into the message itself. But when I did so through the TinyMCE formatting buttons, HTML text showed up in the posting box but not in the preview. This made me think that the link probably won't be embedded in the post or the notification email that will get sent out. Can you please clarify? Is there an issue with the preview feature or an issue with HTML in forum posts?

Please see attached screenshot.

History

#1 Updated by Matt Gold almost 5 years ago

Here's a screenshot showing the preview when I paste the URL alone into the posting box

#2 Updated by Boone Gorges almost 5 years ago

  • Assignee changed from Boone Gorges to Raymond Hoh

I can't reproduce the described behavior. Entering the text of the message from the screenshot results in a preview that contains a properly formatted (ie, clickable) link.

When the email is sent, the link is translated into the following format:

The CUNY Academic Commons: What Will You Build? [http://commons.gc.cuny.edu/what-will-you-build/]

This translation is to ensure proper formatting across browsers, regardless of HTML support. This behavior can probably be modified to do the translation only in the context of plaintext emails, but that's probably a subject for a different ticket.

Ray, do you have any idea why Matt might have experienced this?

#3 Updated by Raymond Hoh almost 5 years ago

Ray, do you have any idea why Matt might have experienced this?

From Matt's description, it sounds like he used TinyMCE's link buttons to add a link. Currently, the live preview plugin only updates when a key is typed on the keyboard and not during mouse actions. So if you use TinyMCE, you have to type something into the editor afterwards for live preview to trigger.

Kind of annoying I know. I can look at adding TinyMCE support to trigger live preview.

#4 Updated by Boone Gorges almost 5 years ago

  • Category name set to Group Forums
  • Priority name changed from Normal to Low
  • Target version set to 1.8

Ah, interesting. In that case it's quite minor.

#5 Updated by Raymond Hoh over 4 years ago

  • Status changed from Assigned to Resolved

After looking into this a bit more, the link button is actually using the WP quicktags toolbar and not TinyMCE (since we haven't enabled TinyMCE yet).

I've added support for the WP quicktags toolbar as of commit 866a3a3. Fix is live on cdev for testing as well.

Once we enable the TinyMCE editor in bbPress, I'll need to look at supporting TinyMCE buttons as well. But for now, this fixes the immediate issue.

Also available in: Atom PDF