Project

General

Profile

Feature #3657

Create alert for GC email addresses

Added by Matt Gold over 4 years ago. Updated almost 3 years ago.

Status:
New
Priority name:
Normal
Assignee:
Category name:
WordPress (misc)
Target version:
Start date:
2014-11-14
Due date:
% Done:

0%

Estimated time:
3.00 h

Description

Per our discussion of the coming change in GC student addresses, we should create an alert for GC people to see whether they should change their addresses

the alert should be seen once and should be dismissible. it should lead people to the place where they can change their email address


Related issues

Related to CUNY Academic Commons - Feature #5316: Prompt user email address updatesAssigned2016-03-10

History

#1 Updated by Boone Gorges about 4 years ago

  • Category name set to WordPress (misc)
  • Assignee changed from Boone Gorges to Marilyn Weber
  • Target version set to 1.8
  • Estimated time set to 3.00 h

Can I get a timeline for this please? Marilyn, if you have access to dates (date when the new addresses will be available, and date when the switchover will be complete) that would help me know how to set this up.

#2 Updated by Matt Gold about 4 years ago

I've asked IT about the timing and will update this ticket when I have more info.

#3 Updated by Matt Gold about 4 years ago

  • Status changed from Assigned to Rejected

I spoke to IT about this and it looks like we won't have to do anything, as mail sent to old GC email address will be forwarded to new student email addresses as long as the student is at the GC. New students, starting next fall, will have @gradcenter.cuny.edu email addresses.

#4 Updated by Marilyn Weber almost 3 years ago

  • Status changed from Rejected to New
  • Assignee changed from Marilyn Weber to Boone Gorges
  • Target version deleted (1.8)

Matthew Liston from IT has reassured us that the forwarding is till happening, but we've had a user claim it has stopped, and - more troubling - an IT rep (Nino Imnaishvili) wrote that "it was only until gc.cuny.edu addresses were removed last June."

It is hereby proposed that we address this by converting GC students proactively. Boone, Matt wanted me to reopen the ticket to get your thoughts on that. Thanks!

#5 Updated by Matt Gold almost 3 years ago

Thanks, Marilyn -- as Matt told us, the issue is that the forwarding continues unless a student does not register, in which case it stops. And I am worried that a fair number of students have an occasional semester where they don't register.

I am going to ask IT if there is a way to check addresses -- so that, say, if the CAC team could pull all accounts that are both GC and grad students, GC IT could share the new addresses with us

#6 Updated by Marilyn Weber almost 3 years ago

I am pretty sure that everyone who had a GC address kept the same prefix for their new gradcenter address. History has a student named Megan Brown whose email went from to even though there were no longer 4 other MBrowns

#7 Updated by Boone Gorges almost 3 years ago

If we have a 100% guarantee from IT that every corresponds to an address, then it's easy to do a search and replace.

If we have anything less than a 100% guarantee, then I think we need to prompt users to take action themselves.

#8 Updated by Matt Gold almost 3 years ago

We'll never have that guarantee because student addresses have changed to the gradcenter.cuny.edu address, while faculty addresses have stayed on gc.cuny.edu

My thought was to do a search (possibly on the frontend) for people associated with the GC as institution and grad student as role, and to go from there.

#9 Updated by Boone Gorges almost 3 years ago

Oh right, ugh.

I would be extremely wary of relying too heavily on user-reported Role data. This data could be incorrectly entered, out of date, or not present at all.

How's this for a plan: For all gc.cuny.edu users, show a prompt on next visit that says something like "The Graduate Center has recently migrated student accounts from the gc.cuny.edu domain to gradcenter.cuny.edu. If your email has changed, we can change your Commons profile for you. [No, keep ] [Yes, change to ]"

#10 Updated by Matt Gold almost 3 years ago

The one issue with an alert is that members would only see if if they logged in. However, members may not be able to log in if they do not have a current email address connected to the Commons.

#11 Updated by Boone Gorges almost 3 years ago

This is a fair point. Maybe we could build something into the password reset process that would require a similar yes/no question? I'm pretty strongly against doing any automatic changes based on Role data.

#12 Updated by Matt Gold almost 3 years ago

Boone Gorges wrote:

This is a fair point. Maybe we could build something into the password reset process that would require a similar yes/no question?

Interesting. I am starting a related ticket; you should see it soon

I'm pretty strongly against doing any automatic changes based on Role data.

Just so that we are clear, the plan I was hoping for would go like this:

- we use role data to build a list of users we think are both grad students and members using gc.cuny.edu addresses
- we share that list with GC IT, which runs a comparison against its records, and sends us updated gradcenter.cuny.edu addresses for students who are confirmed to have switched
- we make changes in the database

so, the second step, performed by IT, would be the validation, and we would only change addresses of students whom IT has confirmed 1) are grad students, and 2) have updated email addresses

Note: I do not yet have IT's agreement on this plan.

#13 Updated by Boone Gorges almost 3 years ago

  • Assignee changed from Boone Gorges to Matt Gold
  • Target version set to Not tracked

so, the second step, performed by IT, would be the validation, and we would only change addresses of students whom IT has confirmed 1) are grad students, and 2) have updated email addresses

Ah, I totally missed that this was the suggestion. If IT has an automated way of doing this, then I suggest that we give them a list of all gc.cuny.edu addresses, regardless of Role. If they're able to give us a certified list of changed addresses, then it's easy for us to confidently make the change without bothering users.

#14 Updated by Matt Gold almost 3 years ago

IT has told me that if we can given them a list of all members with gc.cuny.edu addresses, they can tell us which ones have changed to gradcenter.cuny.edu addresses.

#15 Updated by Boone Gorges almost 3 years ago

Excellent. I will send you the email addresses privately. Once they're processed, send them back to me and I'll make the changes. Let's leave this ticket open to track progress.

#16 Updated by Matt Gold almost 3 years ago

Great -- thanks, Boone.

#17 Updated by Matt Gold almost 3 years ago

Hi Boone,

Just wanted to give you a nudge on this

#18 Updated by Boone Gorges almost 3 years ago

Hi Matt - It looks like I sent you the file on March 12, via email. I've just sent it again - check your inbox :-D

#19 Updated by Matt Gold almost 3 years ago

Thanks, Boone. Did you send it to gmail or GC? And what was the subject of the email?

#20 Updated by Boone Gorges almost 3 years ago

I sent it to your Gmail address. The subject line is "Fwd: [CUNY Academic Commons - Feature #3657] Create alert for GC email addresses" (there may be an extra "Fwd" in there for the one I just sent)

#21 Updated by Matt Gold almost 3 years ago

Hmmm.. . .the email does not appear to have arrived either time you sent it.

#22 Updated by Matt Gold almost 3 years ago

check that -- just found it in the gmail spam folder . . .

#23 Updated by Boone Gorges almost 3 years ago

Urp, sorry about that.

Also available in: Atom PDF