Project

General

Profile

Feature #3672

Force captcha on existing contact forms

Added by Matt Gold over 7 years ago. Updated over 7 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
WordPress Plugins
Target version:
Start date:
2014-11-20
Due date:
% Done:

0%

Estimated time:

Description

IT pointed out that spam is still being sent through contact forms on the Commons; here is one example: http://humanshell.net/contact/

Regarding our work on http://redmine.gc.cuny.edu/issues/3520 , did that add CAPTCHAs to already-existing forms or force them into newly created forms? If the latter, can we try to force CAPTCHAs onto existing forms?


Related issues

Related to CUNY Academic Commons - Feature #3520: Encourage or Require CAPTCHA on forms?Resolved2014-10-03

Related to CUNY Academic Commons - Bug #8779: CF7 Not WorkingResolved2017-10-05

History

#1 Updated by Boone Gorges over 7 years ago

  • Status changed from Assigned to Resolved
  • Target version set to 1.7.4

This doesn't have anything to do with existing vs new forms. The problem is that the most recent upgrade to Contact Form 7 made certain object properties (like `$form->form`) inaccessible by direct reference. Had to switch over to their getter/setter methods. https://github.com/cuny-academic-commons/cac/commit/bf51042a2aca517626612d729854a94b7a910f79

This fix will be included in the next release, and is also up as a hotfix.

#2 Updated by Matt Gold over 7 years ago

Thanks very much, Boone.

#3 Updated by Daniel Jones over 7 years ago

Thanks Boone!

#4 Updated by Raymond Hoh over 4 years ago

  • Related to Bug #8779: CF7 Not Working added

Also available in: Atom PDF