Project

General

Profile

Bug #3788

CUNY.is default links?

Added by Matt Gold over 7 years ago. Updated almost 7 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
cuny.is
Target version:
Start date:
2015-02-04
Due date:
% Done:

0%

Estimated time:

Description

Hi Boone,

In today's community team call, a question came up about cuny.is links (two users have the same/similar names, and we were looking at what their cuny.is links where).

As we looked through this, I was surprised to see that not all CAC users have cuny.is links. I had thought that it was a default part of the account creation and that all users had them (ie., new users would get them on sign-up and previous users would have had them created for them). This does not appear to be the case. Can you please refresh my memory here -- provided yours is better than mine -- on this issue? Are all users supposed to have cuny.is links or is this something that users can activate if they want?

History

#1 Updated by Boone Gorges over 7 years ago

  • Status changed from Assigned to Reporter Feedback

My memory here is not perfect either, but here's what I've pieced together from looking at the plugin that links CAC to YOURLs: Users only receive cuny.is URLs when they request them, at the time of profile edit. In an earlier draft of the implementation, users would automatically be assigned URLs. But the implementation was rewritten when we moved to our new profile system. See #2705.

#2 Updated by Matt Gold over 7 years ago

Hi Boone,

My feeling is that everyone with a Commons account should have a cuny.is shortlink to the user's profile page. By default, it should be cuny.is/[username], and users should hvae the ability to edit. How hard would that be to implement? Any reasons not to go this way?

#3 Updated by Boone Gorges over 7 years ago

  • Status changed from Reporter Feedback to Assigned
  • Target version changed from Not tracked to 1.9

I'm not sure how hard it will be. I will have a look as soon as I can.

#4 Updated by Matt Gold over 7 years ago

Thanks, Boone

#5 Updated by Boone Gorges almost 7 years ago

  • Status changed from Assigned to Resolved

Since this appears to be a regression, I've fixed it for the 1.8 branch. https://github.com/cuny-academic-commons/cac/commit/ce358ee48fe2b5dcbbe96e7827551e4f97d10410 When viewing the profile of a user who does not have a short URL, the system attempts to create one based on the current user's user_nicename.

#6 Updated by Boone Gorges almost 7 years ago

  • Target version changed from 1.9 to 1.8.11

#7 Updated by Matt Gold almost 7 years ago

Thanks, Boone!

Also available in: Atom PDF