Project

General

Profile

Bug #3809

BuddyPress member filters not working correctly

Added by Matt Gold over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
BuddyPress (misc)
Target version:
Start date:
2015-02-12
Due date:
% Done:

0%

Estimated time:

Description

I saw a registration of a username that looked spammy, so I went to the Commons homepage to check out the account. I saw the following errors:

  • Homepage: clicking the "Newest" filter does not bring back the newest members. It appears to replicate the list of active members
  • Member page : The drop-down filter of Order By: Newest Registered is bringing back a random assortment of members at the top, including those who were last active two years ago. Screenshot attached

History

#1 Updated by Boone Gorges over 4 years ago

  • Assignee changed from Boone Gorges to Raymond Hoh
  • Target version set to 1.7.14

I can't reproduce this for http://commons.gc.cuny.edu/members. The Order By options seem to be working correctly.

I have reproduced the problem on the front page. Ray, could I ask you to have a look? I'm guessing it has to do with incorrect cache keys.

#2 Updated by Raymond Hoh over 4 years ago

I have reproduced the problem on the front page. Ray, could I ask you to have a look? I'm guessing it has to do with incorrect cache keys.

Frontpage filter appears to be working again.

The widget caching code shouldn't cache AJAX'd member loops caused by clicking on a filter link.

Let me know if this pops up again.

#3 Updated by Boone Gorges over 4 years ago

  • Target version changed from 1.7.14 to 1.7.15

#4 Updated by Boone Gorges over 4 years ago

  • Target version changed from 1.7.15 to 1.7.16

#5 Updated by Boone Gorges over 4 years ago

  • Target version changed from 1.7.16 to 1.7.17

#6 Updated by Raymond Hoh over 4 years ago

  • Status changed from Assigned to Reporter Feedback
  • Assignee changed from Raymond Hoh to Matt Gold

I would suggest closing this as I cannot duplicate the original issue any more.

#7 Updated by Matt Gold over 4 years ago

  • Status changed from Reporter Feedback to Resolved

Thanks, Ray

Also available in: Atom PDF