Project

General

Profile

Actions

Bug #4081

closed

Events Calendar: Allow restriction of event creation ability to admins on groups

Added by Matt Gold over 7 years ago. Updated almost 7 years ago.

Status:
Duplicate
Priority name:
Normal
Assignee:
Samantha Raddatz
Category name:
Events
Target version:
Start date:
2015-05-23
Due date:
% Done:

0%

Estimated time:

Description

Following up from our last Subcommittee meeting in Spring 2015 is this suggestion from Luke:

Allow restriction of event creation ability to admins on groups


Files

event_options.png (116 KB) event_options.png Samantha Raddatz, 2015-06-03 11:37 AM

Related issues

Is duplicate of CUNY Academic Commons - Feature #4483: Group admin should be able to control who can link events to groupResolvedBoone Gorges2015-08-24

Actions
Actions #1

Updated by Boone Gorges over 7 years ago

  • Assignee changed from Boone Gorges to Samantha Raddatz
  • Target version set to 1.9

Assigning to Sam for UX sketch. The way I envision it is:

  • Group admins will see a new subtab under Manage, called "Events" or "Events Calendar"
  • This tab will be the home of whatever group-specific options we add in the future
  • The option being requested here will be something like: "The following group members can connect events to this group" with the options "All group members", "Admins and mods only", and "Admins only". Default will be "All group members".
  • The "New Event" buttons will be hidden in the group interface for users that don't meet the specified criterion.
  • When creating/editing an event, the Groups autocomplete will not return groups where the current user doesn't meet the minimum role

Does this sound right? Better suggestion for wording, etc are welcome.

Actions #2

Updated by Samantha Raddatz over 7 years ago

Sounds right to me, Boone.

Attached is a mockup of suggested layout. This is based on the 'settings' tab within 'manage', which I feel does a nice job of outlining what impact different options have and allows for adding further options later, if needed.

Actions #3

Updated by Matt Gold over 7 years ago

Looks good to me

Actions #4

Updated by Boone Gorges almost 7 years ago

  • Status changed from Assigned to Duplicate

Whoops, it looks like #4483 was opened as a duplicate. That ticket is fixed for 1.9.

Actions

Also available in: Atom PDF