Project

General

Profile

Feature #409

Simplify Process of adding members to blogs

Added by Matt Gold about 8 years ago. Updated almost 8 years ago.

Status:
Duplicate
Priority name:
Normal
Assignee:
Category name:
WordPress (misc)
Target version:
Start date:
2010-11-22
Due date:
% Done:

0%

Estimated time:

Description

It strikes me that the process of adding new members to blogs is unnecessarily convoluted. One needs to do some research to find the member's username and email, and that email may or may not be the email address he/she normally uses on the site.

Is there any way to rework the "add users" interface for our WP blogs so that it more closely remembers the ajaxified auto-complete member search we have on groups? that way, people could just start entering the name of someone they wanted to add, and could just click on that name/profile pic to send an invite.


Related issues

Is duplicate of CUNY Academic Commons - Feature #593: Create intuitive interface for adding site members to subdomain blogsDuplicate2011-02-19

History

#1 Updated by Matt Gold about 8 years ago

  • Subject changed from Adding members to blogs to Simplify Process of adding members to blogs

#2 Updated by Boone Gorges about 8 years ago

I like the idea of having such an interface, but it's probably a lot of work for relatively little benefit.

Referencing ticket #401 on autocomplete in the wiki tags infrastructure, here's what I propose:
1) I build/adapt a flexible autocomplete tool
2) I backport it into BuddyPress itself, whose autocomplete is sorely in need of rewriting
3) I then use BP's core autocomplete to handle this sort of behavior

This is probably the most efficient way to handle things in terms of cost-benefit. If you're OK with it, it'll mean bumping it to Future Release, as it's unlikely that these things will happen in time for 1.2

#3 Updated by Matt Gold about 8 years ago

  • Target version changed from 1.2 to Future release

Sounds good to me.

#4 Updated by Boone Gorges almost 8 years ago

  • Status changed from Assigned to Duplicate

Pretty sure this is a duplicate of #593

Also available in: Atom PDF