Project

General

Profile

Feature #593

Create intuitive interface for adding site members to subdomain blogs

Added by Matt Gold over 10 years ago. Updated over 9 years ago.

Status:
Duplicate
Priority name:
Normal
Assignee:
Category name:
WordPress (misc)
Target version:
Start date:
2011-02-19
Due date:
% Done:

0%

Estimated time:

Description

The process of adding site members to blogs is complicated -- one has to know the user's username and the email address associated with registration; the former is a bit of a pain to find (one has to go to the profile page of each person one wants to add) and the latter is really unavailable to most people (email addresses listed on profile pages may or may not be the ones officially associated with the account).

It would be awesome if the process of adding users to blogs worked like the process of inviting members to groups -- an ajaxy, searchable listing of site members whose names could simply be clicked to be added.

I imagine the process working like this, all through the blog dashboard:

-- a member chooses new members through the search interface, which puts them into a list on the right side of the page
-- the member then chooses adds them to the blog
-- the member would then be pointed to the Users space on the Dashboard, where user roles could be reassigned.

What do you think? is this possible and how much work would it be?


Related issues

Has duplicate CUNY Academic Commons - Feature #409: Simplify Process of adding members to blogsDuplicate2010-11-22

Is duplicate of CUNY Academic Commons - Feature #1329: Create Plugin to Make it Easier to Add Users to a BlogResolved2011-11-08

History

#1 Updated by Boone Gorges over 10 years ago

  • Target version set to Future release

It's possible but it will be a fair amount of work. I'm thinking it'd take me 10-12 hours.

I agree that this part of WP is quite lacking, but I also think that this is a relatively low-priority item. I'm guessing that adding users to a blog is not a very frequent activity on our site, so the cost-benefit ratio is not as favorable as some other to-do items.

#2 Updated by Matt Gold over 10 years ago

Maybe. Why don't we add this to the Roadmap discussion so that community members can let us know their opinions on the relative urgency of the task?

#3 Updated by Boone Gorges over 10 years ago

I should note that this interface has changed a bit (for the better) in WP 3.1. Have a look after the next Commons upgrade and see what you think.

#4 Updated by Matt Gold over 10 years ago

Thanks -- will do.

#5 Updated by Matt Gold over 10 years ago

Maybe we should start creating a sub-list of issues that we can have UX person look at if we can get one on board next semester.

#6 Updated by Chris Stein over 10 years ago

Matt, that sounds like a good idea. Where do you think that list would best live? Or should it just be a list of Redmond tickets?

#7 Updated by Matt Gold over 10 years ago

Or should it just be a list of Redmond tickets?

Great idea, Chris. I just created a page to keep a list: http://redmine.gc.cuny.edu/issues/show/654

#8 Updated by Boone Gorges over 9 years ago

  • Status changed from Assigned to Duplicate

Also available in: Atom PDF