Project

General

Profile

Actions

Design/UX #4244

closed

Posting to multiple groups

Added by Matt Gold over 7 years ago. Updated almost 7 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Daniel Jones
Category name:
User Experience
Target version:
Start date:
2015-06-30
Due date:
% Done:

0%

Estimated time:

Description

Hi All,

When one posts a forum post to multiple groups, there is no indication -- either on the forum or the notification -- that the post was sent to multiple groups. In some ways, this is fine, but it's weird, perhaps, that the author who posted the message receives absolutely no notification that the message was posted to multiple groups (since the email notification system only sends out the notification of the group in which the message was initially posted).

Sam, is this how you'd expect it to work?


Files

mockup1.png (135 KB) mockup1.png Samantha Raddatz, 2015-07-10 02:36 PM
mockup2.png (48.7 KB) mockup2.png Samantha Raddatz, 2015-07-10 02:36 PM
mockup3.png (164 KB) mockup3.png Samantha Raddatz, 2015-07-10 02:36 PM
Screenshot_2015-07-20_09-10-04.png (214 KB) Screenshot_2015-07-20_09-10-04.png Boone Gorges, 2015-07-20 09:15 AM

Related issues

Related to CUNY Academic Commons - Bug #5127: Forum posts to multiple groups -- no notice in attachmentResolvedDaniel Jones2016-01-15

Actions
Related to CUNY Academic Commons - Bug #5128: Botched forum display of posting to multiple groups info ResolvedDaniel Jones2016-01-15

Actions
Actions #1

Updated by Samantha Raddatz about 7 years ago

I agree that it would be helpful for the author to receive confirmation that the post was sent to multiple groups on the initial screen that loads (see mockup1 attached -- the green bar, which is consistent with the confirmation of sending invites for a group, will need to auto-enlarge if there are more groups tagged than will fit on 1 line).

As we discussed on a call earlier this week, it should also be noted in the bottom of emailed post notifications, and include links to the other groups if they're public (see mockup2 attached).

And then when others look at the topic in the forum, the initial post should have a line of text noting on which other groups it appears (see mockup3 attached). I'm not sure how feasible this is code-wise, but putting it there makes it clear that only the first post appears in other groups (not the replies).

Actions #2

Updated by Boone Gorges about 7 years ago

  • Assignee changed from Samantha Raddatz to Daniel Jones
  • Target version set to 1.9

Thanks, Sam. This all seems sensible.

Dan, can you start taking a look at these? mockup3, notwithstanding Sam's guess, is likely to be the easiest to implement :)

Actions #3

Updated by Daniel Jones about 7 years ago

Here's my first pass at implementing mockup #3 - https://github.com/cuny-academic-commons/cac/commit/3980f60b4fc20043703ebb87ba0402e5074173a1

Just realizing I need to add in logic for checking private and public groups and membership.

Should I start working on mockups 1 & 2?

Actions #4

Updated by Boone Gorges about 7 years ago

Thanks, Dan! I made a couple of small cleanups to your changeset while I was looking it over. Sam, a screenshot is attached so you can see how it looks.

Dan, you're correct that we need to check that the user has access to a given group before showing it in the list. Be sure that site admins (current_user_can( 'bp_moderate' )) can see everything.

I guess I'd suggest that the links should go to the specific forum posts, rather than the /forum/ directory for the given groups. People may want to read replies to the cross-posted topics, which would make the more specific links useful; moreover, the cross-posted items may have been buried in the forum directory over time.

Yes, please start looking at the other two items. For mockup2, I recommend first looking at how we add the "This post has attachments" section to the email, and copying that (wp-content/plugins/cac-bp-custom-includes/email-notifications.php).

Actions #5

Updated by Daniel Jones about 7 years ago

Sorry to have moved so slowly on this, but I made some fixes to the notifications on forum topics, and added support for group email notifications here: https://github.com/cuny-academic-commons/cac/commit/68d2a6ec760300ad22f2afcc903f0d366297fb02

Let me know if that looks right to you, Boone!

Next I'll work on the alert that should show up right after the topics are created.

Actions #6

Updated by Boone Gorges about 7 years ago

Thanks, Dan! This looks like the right idea to me. Sam, it's ready to test on cdev.

Actions #7

Updated by Matt Gold almost 7 years ago

Bumping this for Sam. Can we try to move this forward? Thanks!

Actions #8

Updated by Boone Gorges almost 7 years ago

Dan, last chance for 1.9. Are you close to having more of this in place? If not, let's break it into a separate ticket so that we can close the current one against the milestone.

Actions #9

Updated by Daniel Jones almost 7 years ago

Sorry about the delay on this. With this commit I added on-page notifications after creating a topic in multiple forums: https://github.com/cuny-academic-commons/cac/commit/6bcdd7e1d59f07dcbe5a3e0dd618f9e2b623518f

Are we still waiting on feedback from Sam on this, too? I think these were all the pieces I was supposed to be working on for this.

Thanks Boone!

Actions #10

Updated by Boone Gorges almost 7 years ago

Thanks, Dan!

The on-screen notification looks pretty good to me. Let's go with that for now.

I've just done a round of testing of the email notification notice, and I'm getting some weird results. It appears that the "This topic is also posted in" message is sometimes erroneously being put inside of the post content. In these cases, no groups are listed afterward. As a result, email notifications have lines that look like this:

This topic was also posted in:
This topic was also posted in: foo, bar

Could you have a look to see if you can reproduce this?

Actions #11

Updated by Daniel Jones almost 7 years ago

I believe I've fixed that error, along with a couple of others, here: https://github.com/cuny-academic-commons/cac/commit/a44cd4b866fb91c4aee255b13e0a49cf18d1feab

I'm having a weird issue locally where my local email messages don't include the "this topic also posted in" message at all, but that was the case even before this last issue you brought up so it should still be working up on cdev. Let me know if it isn't though. I'll keep trying to figure out what my issue is locally.

Actions #12

Updated by Daniel Jones almost 7 years ago

Setting markup to "false" for the email messages would have meant that the links would have been taken out too, so instead I changed the parameter to "context" and just made it so that "alert" doesn't get any markup, "email" and "forum_topic" get the links, and only "forum_topic" gets the div. Changes are here: https://github.com/cuny-academic-commons/cac/commit/ed090c9f228c22c634bbcf390d927a859a8db292

Actions #13

Updated by Boone Gorges almost 7 years ago

  • Status changed from Assigned to Resolved

This looks good to me. Thanks, Dan! (and sorry about leaving the comment in the wrong place - whoops)

Actions

Also available in: Atom PDF