Project

General

Profile

Design/UX #4290

Forum Messages for Non-Members

Added by Samantha Raddatz over 6 years ago. Updated about 6 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
Group Forums
Target version:
Start date:
2015-07-10
Due date:
% Done:

0%

Estimated time:

Description

When a user is not a member of a group, he/she is not able to post to the forum and instead sees this page (see screenshot -- http://commons.gc.cuny.edu/groups/library-technology-subcommittee-of-the-cuny-committee-on-academic-technology/forum/) with information about how many topics and replies the forum contains. The error message that appears directly contradicts that information by saying that no topics were found.

I suggest that the first yellow bar be deleted entirely. The text in the remaining yellow bar could be modified to say something like "Join this group to access the forum!" (see mockup). If possible, it would be great if 'join this group' within that text was an active link that allows you to join the group.

mockup_forum.png (98.9 KB) mockup_forum.png Samantha Raddatz, 2015-07-10 03:44 PM
screenshot_forum.png (108 KB) screenshot_forum.png Samantha Raddatz, 2015-07-10 03:44 PM

History

#1 Updated by Boone Gorges over 6 years ago

  • Category name set to Group Forums
  • Status changed from New to Assigned
  • Assignee changed from Boone Gorges to Daniel Jones
  • Target version set to 1.9

Yes, good ideas. Dan, can you please take a look? This might also be a good enhancement for bbPress itself, so you might think about an upstream ticket in addition to a CAC-specific fix.

#2 Updated by Daniel Jones over 6 years ago

Weirdly enough, I can't seem to reproduce this locally. On a hidden group, I just get a 404 page, on a private group, I can't get to the forum, and on a public group that I'm not a member of, I can see all the topics. Can't seem to get to the page in Samantha's screenshot. Any thoughts on why, Boone?

#3 Updated by Boone Gorges over 6 years ago

It looks like the screenshot is of a public group that doesn't have any topics. Did you try that combination?

#4 Updated by Daniel Jones over 6 years ago

I didn't, but it looks like from Samantha's screenshot that the forum has topics, they just aren't being displayed - says it has 15 topics and 41 replies, but then right under that it says "Oh bother, no topics were found." I can't seem to reproduce that locally.

#5 Updated by Samantha Raddatz over 6 years ago

You're right Dan -- this doesn't seem to be happening for other public groups, though it does still occur when I go to the group in my screenshot (Library Technology Subcommittee). Could this have something to do with the group's privacy settings? Or is it simply a bug?

#6 Updated by Daniel Jones over 6 years ago

That is really strange! I can't seem to reproduce it with any combination of settings. Any ideas, Boone?

#7 Updated by Boone Gorges over 6 years ago

Really strange indeed! I had to write my own diagnostic tool to figure out what was going on.

Briefly, the problem is https://bbpress.trac.wordpress.org/ticket/2599. The group in question used to be Private, and at some point an admin switched it to Public. But a bug in bbPress prevented the forum privacy from being correspondingly changed.

In https://github.com/cuny-academic-commons/cac/commit/0875b683f556915d7eb80ea8c345cca24484a913, I put a fix in place for the Commons that will prevent the problem from taking place in the future.

I also ran a diagnostic that calculated affected groups (public groups with non-public forums). Only 6 turned up, so I went ahead and updated them manually. You should now be able to visit the group forum pages normally - the message originally reported by Sam should no longer be visible.

I submitted a fix to bbPress here: https://bbpress.trac.wordpress.org/ticket/2599#comment:9

#8 Updated by Matt Gold over 6 years ago

Awesome work! Please add this to whatever list we are keeping of upstream contributions

#10 Updated by Samantha Raddatz over 6 years ago

Great, thanks for figuring that out Dan!

#11 Updated by Boone Gorges about 6 years ago

  • Status changed from Assigned to Resolved

Also available in: Atom PDF