Project

General

Profile

Bug #4403

Redesign social media accounts section of portfolio editing interface

Added by Matt Gold almost 7 years ago. Updated almost 7 years ago.

Status:
Duplicate
Priority name:
Normal
Assignee:
Category name:
Public Portfolio
Target version:
-
Start date:
2015-08-08
Due date:
% Done:

0%

Estimated time:

Description

Right now, when a user goes to edit the personal portfolio page, we have a text box for every single third-party connection we offer (see screenshot). This leads to a pretty cluttered page, and the layout is not ideal, as some third-party options are on the left side of the page and some are on the right.

Would it be possible to consolidate those options (LinkedIn, Fb, Twitter, Github, etc) into a single field where users could choose from a drop-down list of services and add a new one by clicking on the name of the service they wish to add? I am thinking of something like this:

Add links to social media accounts
[dropdown list containing list of services to which we offer connections; when a service is selected, users could enter account info in a text box]
  • Add another account (this would dynamically add another drop-town menu that users could use to add another account)

Assigning to Boone for initial response and then we should assign to Sam


Related issues

Is duplicate of CUNY Academic Commons - Feature #2613: Request: Update social media link options on profile pagesResolved2013-06-02

History

#1 Updated by Boone Gorges almost 7 years ago

  • Status changed from Assigned to Duplicate

I'm going to mark this as a duplicate of #2613. See especially https://redmine.gc.cuny.edu/issues/2613#note-17 and follow-up comments.

#2 Updated by Matt Gold almost 7 years ago

Fair enough, and good to see work progressing there.

Also available in: Atom PDF