Project

General

Profile

Bug #5313

Migrate over to BuddyPress 2.5 Emails

Added by Raymond Hoh almost 3 years ago. Updated over 2 years ago.

Status:
Resolved
Priority name:
High
Assignee:
Category name:
Email Notifications
Target version:
Start date:
2016-03-09
Due date:
% Done:

0%

Estimated time:

Description

Since we're scheduled to roll BuddyPress 2.5 onto the Commons on the 21st, we need to decide whether we want to keep using our existing email system (a hodgepodge of various email plugins - WP Better Emails, WP Better Emails for BuddyPress, BP Group Email Subscription, etc.) or migrate over to BuddyPress 2.5's email system.

For the 1.9.x milestone, we should probably just continue to use what we currently have.

Sometime down the road (probably the 2.0 milestone), we should migrate over to BP's email system.

Migrating over to BuddyPress 2.5 presents a few things that we'll need to address.

Here are the notables (these notes are mostly for Boone to glean over.):

  • Making modifications to BP Group Email Subscription (GES) to support BP 2.5's email system. (I recently did something similar for the Genchem platform, so I'm a little familiar with this.). Should we also use BP's email system for GES digests?
  • Making modifications to Reply By Email to support BP 2.5's email system. (Work is pretty much completed here.)
  • Ensuring that HTML content in emails shows up (blockquotes, bold, italics, links, etc). I'm mostly only concerned with group forum emails here. If time permits, I'll also work on activity updates and private messages (these will require BP core changes).
  • Ensuring that HTML content in plain-text emails degrades well for accessibility reasons (converting over links, text emphasis, etc.)
  • Ensuring that the HTML email option under a user's "Settings > Email" page is respected. (This is a feature of the WP Better Emails for BuddyPress plugin.) Will need to do some research here.
  • Deactivate and remove WP Better Emails for BuddyPress.
  • Deactivate WP Better Emails.
  • Investigate what needs to be done with our custom "WP Better Emails for BP Groupblog" plugin (#3219). (This might not be required after modifications to GES are made.)
  • Make a decision as to whether we should use BP's default email template or use the same template we use with WP Better Emails. If we use the default BP template, we should remove the "unsubscribe" link located in the email footer.

I'm probably forgetting some things, but these are the main items.

Placing this in the 2.0 milestone for now.

2016-05-06_172447.png (46.7 KB) 2016-05-06_172447.png Raymond Hoh, 2016-05-06 08:26 PM

Related issues

Related to CUNY Academic Commons - Bug #5608: BP Email - Group Announcements shound use new email templateResolved2016-05-24

Related to CUNY Academic Commons - Bug #5609: BP Email - Social Paper group emails need to strip HTML from subjectResolved2016-05-24

Related to CUNY Academic Commons - Bug #5610: BP Email - Escape characters are shown in group emailsResolved2016-05-24

Related to CUNY Academic Commons - Bug #5652: BP Email - Multiple Forum Post email doesn't show contentResolved2016-06-02

History

#1 Updated by Boone Gorges almost 3 years ago

I was literally just going to open a similar ticket.

Agreed that for 1.9.x - or at least for 1.9.10 - we should disable BP 2.5 emails.

Making modifications to BP Group Email Subscription (GES) to support BP 2.5's email system. (I recently did something similar for the Genchem platform, so I'm a little familiar with this.).

Yes.

Should we also use BP's email system for GES digests?

That's a good idea, but lower priority. There will also be backward compatiblity concerns, as the CSS for those emails is filterable.

Ensuring that HTML content in plain-text emails degrades well for accessibility reasons (converting over links, text emphasis, etc.)

Cool. There is already some custom code on CAC to make this happen; see eg cac_strip_email_anchors() in cac-bp-custom-includes/email-notifications.php. These improvements should probably go into BuddyPress. And I bet we can find a library to handle it for us.

This list looks quite comprehensive. Please start chipping away at items, and staging the changes on cdev for testing. I'm happy to jump in for any bits where you think it'd be helpful.

In the meantime, would you mind disabling the new emails on the 1.9.x branch?

#2 Updated by Matt Gold almost 3 years ago

thanks for your work on this, guys

#3 Updated by Raymond Hoh almost 3 years ago

In the meantime, would you mind disabling the new emails on the 1.9.x branch?

Done. See:
https://github.com/cuny-academic-commons/cac/commit/879127fe7516d9bf24761c323282910d35599ef2

I've updated cdev to run BuddyPress 2.5.1 with the wp_mail() fix. We should do a bit of testing to ensure that emails are still working correctly before the 21st.

#4 Updated by Boone Gorges almost 3 years ago

Thanks, Ray! Can you deploy to cdev and do some initial tests? If you need testing from anyone else on the team, feel free to reach out here - I would be happy to help, but I'd like your guidance on what should be tested.

#5 Updated by Raymond Hoh almost 3 years ago

Can you deploy to cdev and do some initial tests?

cdev is already updated to run latest 1.9.x branch, so BuddyPress 2.5.1 and the wp_mail() fix is running on there.

I'd like your guidance on what should be tested.

Basically any native BuddyPress email that we rely heavily on like:
  • Registration and activation emails (this might be tricky based on some of our custom registration mods, but I can test this locally)
  • Private message emails
The following should also be tested:
  • Group member promotion / demotion emails
  • Friendship request emails

I'll do some testing and will report back.

#6 Updated by Raymond Hoh almost 3 years ago

Just to update, there is a bug in BP 2.5 where the friendship accepted email does not get sent:
https://buddypress.trac.wordpress.org/ticket/6969

But otherwise, I've tested most of the emails and they appear fine in the 1.9.x milestone.

#7 Updated by Raymond Hoh almost 3 years ago

I've pretty much completed all the points I listed above.

Making modifications to BP Group Email Subscription (GES) to support BP 2.5's email system. (I recently did something similar for the Genchem platform, so I'm a little familiar with this.). Should we also use BP's email system for GES digests?

GES now supports BP 2.5 single activity sendouts.

I haven't worked on digests yet though.

Making modifications to Reply By Email to support BP 2.5's email system.

RBE is pretty stable now with BP 2.5.

I fixed a bug that I ran into with BP 2.5 and PHPMailer. If the mailbox portion of the RBE email address is longer than 64 characters, then PHPMailer wouldn't use our RBE email address. This is now fixed. If you're interested in the details, you can read the commit message.

Ensuring that HTML content in emails shows up (blockquotes, bold, italics, links, etc). I'm mostly only concerned with group forum emails here. If time permits, I'll also work on activity updates and private messages (these will require BP core changes).

Ensuring that HTML content in plain-text emails degrades well for accessibility reasons (converting over links, text emphasis, etc.)

Forum post emails now render all HTML elements that bbPress supports. I've attached a screenshot showcasing this:
https://redmine.gc.cuny.edu/attachments/download/2932/2016-05-06_172447.png

Plain-text content should degrade well as the content is converted over from HTML to a Markdown-like syntax.

Ensuring that the HTML email option under a user's "Settings > Email" page is respected. (This is a feature of the WP Better Emails for BuddyPress plugin.)

Spawned from our WP Better Emails for BuddyPress plugin, I created a new plugin for BP 2.5 so users can select whether they want to receive HTML or plain-text.

Investigate what needs to be done with our custom "WP Better Emails for BP Groupblog" plugin (#3219).

I've removed this custom plugin from our codebase.

I did run into issues with groupblog and BP 2.5. The issue is if you attempt to send a BP email from any site but the main Commons site, the BP email would not send. The problem is due to BP not registering its email taxonomy network-wide.

I've added a workaround for now and I have also opened a ticket on BP Trac with some more details.

Make a decision as to whether we should use BP's default email template or use the same template we use with WP Better Emails. If we use the default BP template, we should remove the "unsubscribe" link located in the email footer.

I've opted to use the new BP 2.5 email template, but made some mods so our CAC logo is displayed and adjusted the color scheme to match our older template. I've made a note about this in our ACTION_REQUIRED list.


I think we're ready to get others to test on cdev now!

#8 Updated by Raymond Hoh over 2 years ago

  • Status changed from New to Resolved

I'm going to close this one as new email issues are being reported as separate tickets now.

Also available in: Atom PDF