Project

General

Profile

Bug #6374

Subscribers Receiving Email Alerts with Bad Links

Added by Leah Feder over 2 years ago. Updated about 2 years ago.

Status:
Resolved
Priority name:
High
Assignee:
Category name:
-
Target version:
Start date:
2016-10-19
Due date:
% Done:

0%

Estimated time:

Description

Hi,

Early in the days of murphyinstituteblog.org, we made it easy for readers to subscribe via a sign-up field. We've long since taken it down.

People who signed up in the early days are still receiving emails, though, and they emails have started going out at times when I'm not posting anything new, including when I add a category to a post.

More pressingly, the links aren't working anymore. For instance, for this post (http://murphyinstituteblog.org/2016/10/14/cooperative-business-and-the-state-of-higher-education/), this was the link that got sent out: http://murphyinstituteblog.org/?p=154375 . I'm not sure when this started, but it's a fairly recent development.

Do you know what might have happened?

I'd happily do away with these email alerts altogether, if possible.

Thanks so much!
Leah

MurphyAutoEmail.PNG (69 KB) MurphyAutoEmail.PNG Leah Feder, 2016-10-20 10:55 AM

Related issues

Has duplicate CUNY Academic Commons - Bug #6875: Link problem with emails announcing new blog postsResolved2016-11-29

History

#1 Updated by Matt Gold over 2 years ago

  • Status changed from New to Assigned
  • Assignee set to Boone Gorges
  • Priority name changed from Normal to High

Perhaps related to https://redmine.gc.cuny.edu/issues/6350, Boone?

#2 Updated by Boone Gorges over 2 years ago

  • Status changed from Assigned to Reporter Feedback

Hi Leah - Sorry to hear about the issue. Can you please provide me with a full copy of one of the emails containing the erroneous URL? At a glance, it's not clear to me how they're being sent, and seeing the exact text and formatting would help me narrow it down. (I followed a couple of hunches to see where the ID 154375 might have come from, but no luck yet.)

#3 Updated by Leah Feder over 2 years ago

Hi Boone,

Thanks so much for your quick reply. Attaching a photo. All the post links go to: http://murphyinstituteblog.org/?p=130029. Here's the text:

From: Murphy Institute Blog [mailto:]
Sent: Tuesday, October 18, 2016 3:59 PM
To: XXXXXX
Subject: [New post] Pope Francis & the Moral Right to “Own Our Labor & Rent Our Capital”

Murphy Institute posted: "A Growing Hybrid-Model-Movement Ripe for Political Consolidation By Michael Peck In America, the world of work has already changed beyond conventional wisdom sense perceptions and the willpower capacity of elected politicians to understand and embra"

New post on Murphy Institute Blog

Pope Francis & the Moral Right to “Own Our Labor & Rent Our Capital”
by Murphy Institute
A Growing Hybrid-Model-Movement Ripe for Political Consolidation By Michael Peck In America, the world of work has already changed beyond conventional wisdom sense perceptions and the willpower capacity of elected politicians to understand and embrace it. This workplace relationship tsunami, “a historic shift that rivals the transition from farms to factories,” calls out the anachronistic redlining […]

Read more of this post

Murphy Institute | September 8, 2015 at 1:23 pm | URL: http://wp.me/p4AvhZ-xPf

Unsubscribe to no longer receive posts from Murphy Institute Blog.
Change your email settings at Manage Subscriptions.

Trouble clicking? Copy and paste this URL into your browser:
http://murphyinstituteblog.org/?p=130029

#4 Updated by Boone Gorges over 2 years ago

  • Target version set to Not tracked

Thanks, Leah! This was enough to figure out that the notifications are being sent by Jetpack's Subscriptions module.

What you've described appears to be similar to this issue https://wordpress.org/support/topic/jetpack-publicize-using-the-wrong-url-permalink/, so you could try following the advice on that thread. Or, you could simply disable the Subscriptions feature of Jetpack.

Let me know if this solves your problem.

#5 Updated by Leah Feder over 2 years ago

Thanks Boone.

I was able to turn off subscriptions altogether as a stopgap, but have received some complaints from folks who had grown accustomed to getting the alerts.

Unfortunately, I am unable to attempt the shortlinks solution from the issue you to, as I am now completely unable to access Jetpack. When I click on the Jetpack menu item on the sidebar of the dashboard, or any of the submenu items, I'm taken to a blank grey screen.

In the meantime, our institutional twitter account (@murphyinstitute) has stopped auto-tweeting our posts. Potentially related?

Thanks for any guidance you might be able to provide.

Thanks,
Leah

#6 Updated by Boone Gorges over 2 years ago

Hi Leah - Sorry to hear you're still having issues.

The grey screen you've described is occurring because of a bug in PressForward, which is causing fatal errors. I've just put a hotfix in place, and I'll follow up with a proper fix within the next day. For the moment, you can access the Jetpack dashboard again.

It's possible that the PressForward fatal error was responsible for the subscription failures. Do you have any more content in the queue with which you could test this theory?

#7 Updated by Boone Gorges over 2 years ago

I've opened an upstream bug ticket for the PressForward fatal error. Until I hear back with details from their dev team, I'll keep my hotfix in place.

Leah, please do let me know when you get a chance whether notifications are being sent now.

#8 Updated by Leah Feder over 2 years ago

Hi Boone,

I'm able to access Jetpack again, but things aren't working as hoped:

(1) When I turned subscriptions back on, the bad link problem returned.
(2) Looks like shortcodes (the solution from the issue to which you referred me) are already activated. I turned them off, and that didn't seem to have any effect.
(3) Twitter notifications (which until now happened via Jetpack's Publicize) aren't working.

In the meantime, I've turned off PressForward, which hasn't been working for a while anyway.

Thanks again,
Leah

#9 Updated by Boone Gorges over 2 years ago

Hi Leah - I'm afraid it's looking like your problems are internal to Jetpack, rather than between Jetpack and other parts of the Commons. Because most of Jetpack's functionality happens on wordpress.com's servers, there's little that I can do to debug. I think your best course of action at this point is to reach out to Jetpack support to report your existing problems. They'll be able to look into their internal logs to detect problems with outgoing notifications, and they may also have something to say about the weird permalinks. I've found them to be pretty responsive in the past. https://jetpack.com/contact-support/

Please let me know if they're able to help you, and feel free to loop me into the conversation if necessary.

#10 Updated by Boone Gorges over 2 years ago

I wanted to record here that I sent an upstream bug report to PressForward, and had a fix committed, that should fix the fatal error described above in future versions of PF: https://github.com/PressForward/pressforward/issues/859

#11 Updated by Boone Gorges about 2 years ago

  • Has duplicate Bug #6875: Link problem with emails announcing new blog posts added

#12 Updated by Boone Gorges about 2 years ago

  • Status changed from Reporter Feedback to Resolved

Hi Leah - I believe that I've tracked down the cause of the issue. It's described in #6875. Please read through that ticket for the gory details. In the meantime, I'm going to mark this one as resolved. If problems continue to come up, please don't hesitate to reopen.

#13 Updated by Leah Feder about 2 years ago

Thanks so much, Boone!

Also available in: Atom PDF