Project

General

Profile

Bug #6875

Link problem with emails announcing new blog posts

Added by Jill Cirasella over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
WordPress Plugins
Target version:
Start date:
2016-11-29
Due date:
% Done:

0%

Estimated time:

Description

Hi,

When a new post is published to the Graduate Center Library blog (gclibrary.commons.gc.cuny.edu) and the email announcement goes out to email subscribers, the link in the email is always a short url like http://gclibrary.commons.gc.cuny.edu/?p=157569, never the full URL of the post. The short URL is not something we ever set, just something the system generates. When clicked in the email, it almost always correctly directs to the blog post in question. Very occasionally, it doesn’t and leads to a 404 error page, and we can’t figure out why. (When it doesn’t work, it is, as far as we can tell, for all users, on all systems, on all browsers.)

This problem happened with our last post. The post's URL is http://gclibrary.commons.gc.cuny.edu/2016/11/28/interlibrary-loan-request-histories-privacy/ but the link in the email was http://gclibrary.commons.gc.cuny.edu/?p=157569 (also further shortened as http://wp.me/p3H0YH-EZr), and it led to a 404 error.

Do you have any idea why the URL of post itself isn't used in the emails, and why the short URL that is used sometime doesn't work? I've attached a PDF of the email announcement for the most recent blog post (the one mentioned above). You can see the two shortened URLs -- http://wp.me/p3H0YH-EZr and http://gclibrary.commons.gc.cuny.edu/?p=157569 -- at the bottom of the post and the very bottom of the email, respectively. (The title of the post is also a link, http://gclibrary.commons.gc.cuny.edu/?p=157569.)

Thanks!

blog_email.pdf (270 KB) blog_email.pdf Jill Cirasella, 2016-11-29 03:38 PM
libraryblogemail.pdf (232 KB) libraryblogemail.pdf Jill Cirasella, 2016-12-13 05:11 PM

Related issues

Related to CUNY Academic Commons - Bug #7043: blog emails still being sent with bad linksResolved2016-12-13

Is duplicate of CUNY Academic Commons - Bug #6374: Subscribers Receiving Email Alerts with Bad LinksResolved2016-10-19

History

#1 Updated by Boone Gorges over 4 years ago

  • Status changed from New to Reporter Feedback

It appears that this is the same issue as #6374. Jill, can you confirm? If so, I'll see if I can get some help from the Jetpack folks.

#2 Updated by Jill Cirasella over 4 years ago

Yes, exactly the same issue -- thanks for noticing that!

And we're having this issue mentioned there too: "emails have started going out at times when I'm not posting anything new, including when I add a category to a post." We're definitely having that problem, e.g., when we edit the categories to take a post out of the slider. It's made me very disinclined to make such updates.

#3 Updated by Boone Gorges over 4 years ago

  • Category name changed from Blogs (BuddyPress) to WordPress Plugins
  • Status changed from Reporter Feedback to Assigned
  • Assignee changed from Jill Cirasella to Boone Gorges

Thanks for the quick follow-up, Jill. I've sent a support request to Jetpack, and I'll update this ticket when I hear back.

#4 Updated by Boone Gorges over 4 years ago

  • Target version set to Not tracked

#5 Updated by Boone Gorges over 4 years ago

I've had a back-and-forth with Jetpack support, and can report that I have a hint at what might be causing this. It appears that there's some sort of weird interplay between Jetpack and WordPress MU Sitewide Tags. Some technical details are at https://wordpress.org/support/topic/incorrect-link-filtering-for-jetpack-subscriptions/

It might be possible to engineer some sort of solution in WordPress MU Sitewide Tags, but I wonder if a saner solution may be to simply discontinue use of that plugin. To my knowledge, our tags site (https://tags.commons.gc.cuny.edu/) is unused by anyone or anything on the Commons. Yet it adds computational overhead to every post action on the site. Matt, do you have objections to turning it off?

#6 Updated by Boone Gorges over 4 years ago

  • Is duplicate of Bug #6374: Subscribers Receiving Email Alerts with Bad Links added

#7 Updated by Matt Gold over 4 years ago

Wow. No, I have no objections to turning it off!!

#8 Updated by Boone Gorges over 4 years ago

  • Status changed from Assigned to Resolved

Thanks, Matt.

Jill, I've deactivated the plugin. I'm confident that this will fix the issue with incorrect links. I'm not entirely confident that it'll fix the notifications-on-update, but it might. I'm going to mark this ticket as resolved, and if the second issue arises again, please open a separate ticket with details.

#9 Updated by Jill Cirasella over 4 years ago

Oh drat! It is with a heavy heart that I report that...it's still sending email notifications with bad blog post links! Email notifications actually didn't seem to go out at all for the posts from Monday and last Wednesday, which was odd, but one did go out today, and it had bad links again. Both http://gclibrary.commons.gc.cuny.edu/?p=158981 and http://wp.me/p3H0YH-Fmd led to the 404 page. PDF of email attached. Any ideas or suggestions? Thanks! Jill

#10 Updated by Matt Gold over 4 years ago

  • Status changed from Resolved to Assigned

Oh no! so sorry, Jill. Thank you for your patience.

#11 Updated by Boone Gorges over 4 years ago

  • Status changed from Assigned to Resolved

#12 Updated by Boone Gorges over 4 years ago

  • Related to Bug #7043: blog emails still being sent with bad links added

Also available in: Atom PDF