Project

General

Profile

Bug #6629

email footer demphasizes RBE

Added by Matt Gold over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority name:
Normal
Assignee:
Category name:
Email Notifications
Target version:
Start date:
2016-11-07
Due date:
% Done:

0%

Estimated time:

Description

I think that the footer to our new emails deemphasizes the fact that one can reply to forum posts via email:

"Go to the discussion to reply or catch up on the conversation.
You are currently receiving notifications for your own posts."

History

#1 Updated by Boone Gorges over 2 years ago

  • Status changed from Assigned to Reporter Feedback
  • Assignee changed from Boone Gorges to Raymond Hoh

I can't think of a simple rewording. How about adding a line?

[Go to the discussion] to reply or catch up on the conversation.
You may also reply to this email to add your response to the thread.
You are currently receiving notifications for your own posts.

Ray, I see that https://commons.gc.cuny.edu/wp-admin/post.php?post=51110&action=edit is a catch-all for group activity. I recall endorsing the idea that all GES content should run through a single template, but now I'm wondering whether there are GES notifications that don't support RBE. Is there an easy way to come up with a comprehensive list of RBE-supported types? Can/should we modify the footer on the fly, rather that/in addition to changing what's stored in the email template post type object?

#2 Updated by Matt Gold over 2 years ago

What about

Reply to this email to add your response to the thread or [go to the discussion] to catch up on the entire conversation.
You are currently receiving notifications for your own posts.

#3 Updated by Boone Gorges over 2 years ago

  • Target version set to 1.10.2

#4 Updated by Raymond Hoh over 2 years ago

Boone's suggestion would be easier to implement due to the way BuddyPress is storing the email content of the message as tokens.

This is what GES stores the HTML email content as:

{{{ges.action}}}:\n\n<blockquote>{{{usermessage}}}</blockquote>\n&ndash;
\n<a href=\"{{{thread.url}}}\">Go to the discussion</a> to reply or catch up on the conversation.
\n{{{ges.email-setting-description}}}

In theory, I could hijack the {{ges.email-setting-description}} token and prepend Boone's suggestion of:

You may also reply to this email to add your response to the thread.

Before the {{ges.email-setting-description}} token is rendered.

#5 Updated by Raymond Hoh over 2 years ago

Boone Gorges wrote:

but now I'm wondering whether there are GES notifications that don't support RBE.

Yes, there are a few like #6674.

Is there an easy way to come up with a comprehensive list of RBE-supported types?

We're really only concerned with GES. All the support I've added for GES is in RBE -- group activity updates, group forum posts powered by bbPress, and BP Docs comments.

Can/should we modify the footer on the fly, rather that/in addition to changing what's stored in the email template post type object?

Yes, we should modify the content on the fly. I would recommend what I posted above.

I'll try to write this code from the GES plugin, but it might have to be coded from RBE's side.

#6 Updated by Boone Gorges over 2 years ago

Ray - your plan sounds good. Thanks for looking into it!

#7 Updated by Matt Gold over 2 years ago

Thanks, Ray. What would the final result be? would it be this:

[Go to the discussion] to reply or catch up on the conversation.
You may also reply to this email to add your response to the thread.
You are currently receiving notifications for your own posts.

Is there any way of making the reply option appear first? If so, would it be:

Reply to this email to add your response to the thread.
[Go to the discussion] to catch up on the conversation.
You are currently receiving notifications for your own posts.

or something like that?

#8 Updated by Raymond Hoh over 2 years ago

Matt, it would be the former due to the way we allow site owners to customize the email content in the WordPress visual editor, and also potential localization issues.

I guess we could introduce pseudo-tokens and place them inside the email content. These tokens would not output anything, unless a plugin decides to filter and hook into it to output something. However, this would probably cause more complexity.

#9 Updated by Matt Gold over 2 years ago

Okay. I kinda sorta understand the code above and don't quite get why the HTML can't be reordered -- though, admittedly, I only kinda sorta get it, which is likely the difference!

#10 Updated by Raymond Hoh over 2 years ago

Okay. I kinda sorta understand the code above and don't quite get why the HTML can't be reordered.

The issue is two-fold:
1. The new email system in BuddyPress allows for site admins to customize the email content for each type of email. Each type of email is stored as a WordPress post, which is written to the database.
2. The Group Email Subscription plugin adds its own email type (four to be exact). The one we're interested in is group activity sendouts. We cannot modify the default email content for group activity sendouts because RBE might not be active on the site.

The method I thought of above would dynamically do a little trickery to inject our custom RBE message in between an existing token.

However, I just thought of another alternative, we could introduce a custom token - {ges.rbe-notice} - and then add this custom token to CAC's GES email content only.

This would allow for Matt's version of the RBE message to be possible.

#11 Updated by Matt Gold over 2 years ago

> This would allow for Matt's version of the RBE message to be possible.

That's great news! I am definitely in favor of it but also happy to have other members of the team (like Paige) weigh in.

#12 Updated by Raymond Hoh over 2 years ago

  • Status changed from Reporter Feedback to Resolved

I've made some updates to GES and added a custom BP email token - {{ges.rbe-notice}} - so we can output the special RBE phrase as noted above.

See:
https://github.com/cuny-academic-commons/cac/compare/9e6a7a2705...e44dd9e4fd

Note: At the moment, this phrase can only be altered in code and not in the Visual Editor. So any changes to the phrase need to be committed to GitHub.

Boone: The ACTION_REQUIRED article has been updated for 1.10.2. You'll need to change the post content to add the new token.

#13 Updated by Matt Gold over 2 years ago

Thank you, Ray!

Also available in: Atom PDF